Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 39776 - Dell Inspiron 8000 pcmcia cardmgr hangs system
Summary: Dell Inspiron 8000 pcmcia cardmgr hangs system
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2004-01-29 09:13 UTC by Joseph Hitt
Modified: 2004-04-08 22:41 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Hitt 2004-01-29 09:13:54 UTC
LiveCD install, loading kernel with the 'dopcmcia' option: When it gets to where it runs cardmgr on a Dell Inspiron 8000 laptop freezes the entire system if cards are inserted.  If the pcmcia cards are not inserted, cardmgr executes fine (at first).  But then if when I then insert a card, the system hangs and I must either disengage the battery or hold the power button for 15 sec to start over.  I have seen reports of this occurring on an Inspiron 8100 also.  Have tried Xircom 32-bit CardBus Ethernet II 10/100 (CBE2-100) as well as Linksys Etherfast 10/100 + 56k Modem PC Card (PCMLM56).  Both cards hang system, so I think it's an incompatibility with cardmgr and the Texas Instruments chipset.

Reproducible: Always
Steps to Reproduce:
1. LiveCD install with Inspiron 8000, at boot, type 'gentoo dopcmcia'
2. One of the cards should already be inserted.

Actual Results:  
System hangs.

Expected Results:  
Not hang.

cardmgr hangs after printing this:
cardmgr[1345]: watching 2 sockets
Comment 1 Tim Yamin (RETIRED) gentoo-dev 2004-01-30 08:31:05 UTC
What LiveCD are you using? Also, can you try the latest LiveCD at and see if that solves your problem? Thanks!
Comment 2 Matt Taylor 2004-01-30 14:44:31 UTC
I have a Inspiron 8100 and if I compile pcmcia into the kernel or as modules then when the pcmcia initscript runs and starts cardmgr it hangs.  If I have no pcmcia in the kernel and just use the pcmcia-cs modules cardmgr doesn't freeze the machine, but my cards dont work.  If I use the kernel pcmcia and no pcmcia init script my cards work fine if I manualy load the modules.

Using gentoo-2004.0-x86-20040123.iso the computer doesn't hang, but there is no pcmcia support when booting with gentoo dopcmcia.  I looked in /lib/modules and there aren't any pcmcia modules there.

Using gentoo-2004.0-x86-20040128.iso I get a error /sbin/rc: line 104: /etc/init.d/pcmcia: No such file of directory.  If I try to probe the modules manualy there is no yenta_socket so it wont work.
Comment 3 Tobias Sodergren 2004-02-15 09:44:26 UTC
This happens to me too, since upgrading world and got pcmcia-2.5.1-r1. At least I think that the new pcmcia is the problem.

I've tried gentoo-dev-sources-2.6.1-r1 and 2.6.2-mm1 and cardmgr hangs just like stated in a comment above.

I didn't have a problem with cardmgr until I upgraded world, but unfortunately I don't know which version I had installed before. I frequently upgrade my system, so it cannot have been that old.
Comment 4 Tobias Sodergren 2004-02-15 09:54:59 UTC
Hmm, problem solved. Dell inspiron 8000 does not like when /etc/pcmcia/config.opts 
include ports 0x800-0x8ff. I simply removed the ports, and cardmgr worked just fine again:

--- from /etc/pcmcia/config.opts
#include port 0x100-0x4ff, port 0x800-0x8ff, port 0xc00-0xcff
include port 0x100-0x4ff, port 0xc00-0xcff

I guess that I replaced my config.opts with the one included in the new pcmcia-cs-2.5.1-r1 sources.
Comment 5 Jason Cox (RETIRED) gentoo-dev 2004-04-08 22:41:25 UTC
Problem solved.
Comment 6 Jason Cox (RETIRED) gentoo-dev 2004-04-08 22:41:46 UTC
Closed. Problem solved.