Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 396563 - dev-lang/ruby-1.8.7_p357 fails to build in dl.c: callback.func:1:7: error: expected identifier or ‘(’ before ‘long’
Summary: dev-lang/ruby-1.8.7_p357 fails to build in dl.c: callback.func:1:7: error: ex...
Status: RESOLVED DUPLICATE of bug 370413
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-31 02:12 UTC by Alexandre Rostovtsev (RETIRED)
Modified: 2011-12-31 07:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info dev-lang/ruby:1.8 (emerge--info.txt,16.76 KB, text/plain)
2011-12-31 02:12 UTC, Alexandre Rostovtsev (RETIRED)
Details
build.log (ruby-1.8.7_p357.build.log,37.29 KB, text/plain)
2011-12-31 02:15 UTC, Alexandre Rostovtsev (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-12-31 02:12:33 UTC
Created attachment 297419 [details]
emerge --info dev-lang/ruby:1.8

dev-lang/ruby-1.8.7_p357 and 1.8.7_p352 both fail to build on my system (~amd64, gcc-4.6.2, glibc-2.14.1-r1) with the same error:

# USE="berkdb doc gdbm ipv6 ncurses readline socks5 ssl threads tk -debug -examples -libedit -rubytests -xemacs" emerge ruby:1.8
[...]
x86_64-pc-linux-gnu-gcc -I. -I../.. -I../../. -I../.././ext/dl -DHAVE_DLFCN_H -DHAVE_DLOPEN -DHAVE_DLCLOSE -DHAVE_DLSYM -DHAVE_DLERROR    -I. -fPIC -march=native -O2 -pipe -fno-strict-aliasing -fno-strict-aliasing  -fPIC  -fno-defer-pop -fno-omit-frame-pointer  -c dl.c
sym.c: In function ‘rb_dlsym_inspect’:
sym.c:275:21: warning: format ‘%lx’ expects argument of type ‘long unsigned int’, but argument 4 has type ‘struct sym_data *’ [-Wformat]
sym.c:275:21: warning: format ‘%lx’ expects argument of type ‘long unsigned int’, but argument 5 has type ‘void *’ [-Wformat]
sym.c:275:21: warning: format ‘%lx’ expects argument of type ‘long unsigned int’, but argument 4 has type ‘struct sym_data *’ [-Wformat]
sym.c:275:21: warning: format ‘%lx’ expects argument of type ‘long unsigned int’, but argument 5 has type ‘void *’ [-Wformat]
In file included from dl.c:104:0:
callback.func:1:1: warning: data definition has no type or storage class [enabled by default]
callback.func:1:7: error: expected identifier or ‘(’ before ‘long’
In file included from dl.c:104:0:
callback.func:78:33: error: expected ‘)’ before ‘(’ token
callback.func:79:3: warning: data definition has no type or storage class [enabled by default]
callback.func:79:24: error: ‘proc’ undeclared here (not in a function)
callback.func:79:39: error: ‘argc’ undeclared here (not in a function)
callback.func:79:45: error: ‘argv’ undeclared here (not in a function)
callback.func:82:1: error: expected identifier or ‘(’ before ‘}’ token
dl.c:106:1: error: expected ‘;’, ‘,’ or ‘)’ before ‘static’
make[1]: *** [dl.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/dev-lang/ruby-1.8.7_p357/work/ruby-1.8.7-p357/ext/dl'


Note that I had been able to build ruby-1.8.7_p352 on this machine in September, when I was using glibc-2.13-r4 and gcc-4.6.1-r1.
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-12-31 02:15:30 UTC
Created attachment 297421 [details]
build.log
Comment 2 Hans de Graaff gentoo-dev 2011-12-31 07:15:40 UTC

*** This bug has been marked as a duplicate of bug 370413 ***