Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 396491 - dont force semantic-desktop on kde-base/gwenview
Summary: dont force semantic-desktop on kde-base/gwenview
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-30 06:12 UTC by Thomas Capricelli
Modified: 2012-04-01 16:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Capricelli 2011-12-30 06:12:55 UTC
It is not possible to install kdelibs without semantic-desktop. The ebuild for gwenview forces the useflag for semantic-desktop to be the same as for kdelibs, hence 'forcing' the useflag for gwenview as well.

But this is not needed, gwenview is quite well written, can can be compiled without semantic-desktop, indepently of what kdelibs did.

I've done/tested it by removing the line in kde-base/gwenview-4.7.4 and emerging : this works.
Also, nepomuk is not searched/displayed in the initial cmake run, as expected.

I dont know ebuild very well, but i'm sure it is possible to make it understand something like 'require nepomuk in kdelibs if this is required for gwenview, but not in other cases'.

Reproducible: Always
Comment 1 Andreas K. Hüttel archtester gentoo-dev 2011-12-30 19:19:42 UTC
(In reply to comment #0)
> It is not possible to install kdelibs without semantic-desktop. The ebuild for
> gwenview forces the useflag for semantic-desktop to be the same as for kdelibs,
> hence 'forcing' the useflag for gwenview as well.

Certainly not. You can always disable semantic-desktop for both.

> But this is not needed, gwenview is quite well written, can can be compiled
> without semantic-desktop, indepently of what kdelibs did.

No. The useflag works as expected, and gwenview links to the nepomuk code exactly if semantic-desktop is enabled.

> I dont know ebuild very well, but i'm sure it is possible to make it understand
> something like 'require nepomuk in kdelibs if this is required for gwenview,
> but not in other cases'.

That's how it is now.
Comment 2 Thomas Capricelli 2012-01-03 17:11:37 UTC
(In reply to comment #1)

> Certainly not. You can always disable semantic-desktop for both.

If you emerge kdelibs with -semantic-desktop, a lot of 'useful' kde packages can't be emerged. But that's not the point here.

> > But this is not needed, gwenview is quite well written, can can be compiled
> > without semantic-desktop, indepently of what kdelibs did.
> 
> No. The useflag works as expected, and gwenview links to the nepomuk code
> exactly if semantic-desktop is enabled.

You misunderstood me. The ebuild for gwenview 'forces' semantic-desktop if kdelibs is compiled with this flag. And this, is not needed. Gwenview can compile without nepomuk support, even if kdelibs has it. I did it on my local computer, and anyway, this is obvious from gwenview cmake files. They did things well, but unfortunately, this is not supported by the gentoo ebuild, hence my report.


> > something like 'require nepomuk in kdelibs if this is required for gwenview,
> > but not in other cases'.
> 
> That's how it is now.

no, current situation forces '==' between kdelibs and gwenview for the semantic-desktop. It should be 'flag set in gwenview' implies 'flag set in kdelibs', and only in this direction.
Comment 3 Maciej Mrozowski gentoo-dev 2012-01-14 14:39:16 UTC
It was intentionally done this way to force semantic-desktop=, however I cannot remember now what was the reason. Any idea guys?
Comment 4 Maciej Mrozowski gentoo-dev 2012-01-14 15:00:46 UTC
Added to Monday's meeting agenda.

"The Gentoo KDE team will have a public meeting on Monday, 16 Jan
2012, 20:00 UTC [1]. The meeting will happen as usual in #gentoo-meetings
on freenode."
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-01-14 15:57:55 UTC
(In reply to comment #3)
> It was intentionally done this way to force semantic-desktop=, however I cannot
> remember now what was the reason. Any idea guys?

I wasn't very please when that change was done (forcing semantic-desktop= in all kde-base packages), but iirc the argument at the time was that not doing so was leading to strange bugs that were confusing and causing issues on upstream bugzilla.
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2012-04-01 16:54:08 UTC
(In reply to comment #5)
> (In reply to comment #3)
> > It was intentionally done this way to force semantic-desktop=, however I cannot
> > remember now what was the reason. Any idea guys?
> 
> I wasn't very please when that change was done (forcing semantic-desktop= in
> all kde-base packages), but iirc the argument at the time was that not doing
> so was leading to strange bugs that were confusing and causing issues on
> upstream bugzilla.

Exactly. We discussed this again at last (March 2012) meeting, and the decision stands that semantic-desktop should be set for all kde packages or for none.