Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 396423 - dev-lang/ruby-1.8.7_p357 fails to build
Summary: dev-lang/ruby-1.8.7_p357 fails to build
Status: RESOLVED DUPLICATE of bug 370413
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-29 16:18 UTC by Davide Pesavento
Modified: 2011-12-29 16:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
full build log (build.log,35.57 KB, text/plain)
2011-12-29 16:18 UTC, Davide Pesavento
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Pesavento gentoo-dev 2011-12-29 16:18:38 UTC
Created attachment 297311 [details]
full build log

In file included from dl.c:104:0:
callback.func:1:1: warning: data definition has no type or storage class
callback.func:1:7: error: expected identifier or ‘(’ before ‘long’
In file included from dl.c:104:0:
callback.func:78:33: error: expected ‘)’ before ‘(’ token
callback.func:79:3: warning: data definition has no type or storage class
callback.func:79:24: error: ‘proc’ undeclared here (not in a function)
callback.func:79:39: error: ‘argc’ undeclared here (not in a function)
callback.func:79:45: error: ‘argv’ undeclared here (not in a function)
callback.func:82:1: error: expected identifier or ‘(’ before ‘}’ token
dl.c:106:1: error: expected ‘;’, ‘,’ or ‘)’ before ‘static’
make[1]: *** [dl.o] Error 1


# emerge -pv ruby:1.8

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/ruby-1.8.7_p357 [1.8.7_p352] USE="berkdb gdbm ipv6 ncurses readline ssl threads -debug -doc -examples -libedit -rubytests -socks5 -tk -xemacs" 0 kB
Comment 1 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-12-29 16:20:03 UTC

*** This bug has been marked as a duplicate of bug 370413 ***