Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 395817 - media-libs/libsndfile-1.0.25: fails tests with python-3
Summary: media-libs/libsndfile-1.0.25: fails tests with python-3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL: https://github.com/erikd/libsndfile/c...
Whiteboard:
Keywords: InVCS, PATCH, PMASKED
: 443600 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-23 17:29 UTC by Michael Palimaka (kensington)
Modified: 2016-01-24 12:38 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,65.36 KB, patch)
2011-12-23 17:29 UTC, Michael Palimaka (kensington)
Details | Diff
libsndfile-1.0.25-python3.patch (libsndfile-1.0.25-python3.patch,5.80 KB, patch)
2011-12-23 17:30 UTC, Michael Palimaka (kensington)
Details | Diff
libsndfile-1.0.25-python3.patch (libsndfile-1.0.25-python3.patch,5.96 KB, patch)
2011-12-23 18:31 UTC, Michael Palimaka (kensington)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2011-12-23 17:29:27 UTC
Created attachment 296763 [details, diff]
build log

When python-3 is set as the default interpreted, libsndfile-1.0.25 fails tests due to invalid syntax. Patch has been sent upstream. (See $URL)


Portage 2.1.10.41 (hardened/linux/amd64, gcc-4.5.3-asneeded, glibc-2.13-r4, 3.0.8-hardened-libre x86_64)
=================================================================
System uname: Linux-3.0.8-hardened-libre-x86_64-06-17-with-gentoo-2.0.3
Timestamp of tree: Fri, 23 Dec 2011 13:45:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles multilib-strict news parallel-fetch protect-owned sandbox sfperms split-elog split-log splitdebug strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS=""
GENTOO_MIRRORS="ftp://mirror.internode.on.net/pub/gentoo/"
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="aac acl acpi alsa amd64 apache2 apng asf bash-completion bazaar berkdb bzip2 cleartype cli consolekit corefonts cracklib crashreporter crypt cups cxx dbus deblob dri dvd ebook exceptions fam ffmpeg flac fontconfig gdbm git glib gmp gpm handbook hardened iconv ipv6 ithreads jit jpeg justify kde kontact lastfm less libnotify mmx mng modules mp3 mp4 mpeg mta mudflap multilib ncurses networkmanager nls nptl nptlonly ogg opengl openmp optimized-qmake pam pax_kernel pcap pcre phonon player png policykit pppd private-headers qt3support qt4 readline rss samba semantic-desktop session sftp sha512 smbclient spell sse sse2 ssl ssse3 startup-notification suhosin svg symlink sysfs tcpd theora threads threadsafe tiff truetype udev unicode upnp uuid vorbis webm xft xorg xscreensaver xvfb zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="*" APACHE2_MODULES="dav alias auth_basic authn_default auth_digest authn_file authz_host authz_user autoindex cgi deflate dir filter headers include info log_config mime mime_magic negotiation proxy proxy_http rewrite speling status vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michael Palimaka (kensington) gentoo-dev 2011-12-23 17:30:21 UTC
Created attachment 296765 [details, diff]
libsndfile-1.0.25-python3.patch
Comment 2 Jeroen Roovers gentoo-dev 2011-12-23 17:39:22 UTC
Looks like that patch will make tests fail when python2 is the system default...
Comment 3 Jeroen Roovers gentoo-dev 2011-12-23 17:40:37 UTC
Alternatively:

--- src/binheader_writef_check.py.org   2011-01-19 11:24:46.000000000 +0100
+++ src/binheader_writef_check.py       2011-12-23 18:40:16.974947986 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python2
 
 # Copyright (C) 2006-2011 Erik de Castro Lopo <erikd@mega-nerd.com>
 #
Comment 4 Michael Palimaka (kensington) gentoo-dev 2011-12-23 17:59:05 UTC
(In reply to comment #2)
> Looks like that patch will make tests fail when python2 is the system
> default...

Should all be backwards-compatible, still passes with patch & python-2 here.
Comment 5 Michael Palimaka (kensington) gentoo-dev 2011-12-23 18:21:13 UTC
Comment on attachment 296765 [details, diff]
libsndfile-1.0.25-python3.patch

...except it breaks gold.
Comment 6 Michael Palimaka (kensington) gentoo-dev 2011-12-23 18:31:14 UTC
Created attachment 296769 [details, diff]
libsndfile-1.0.25-python3.patch

Revised patch in order to play nice with python-2, python-3, ld-bfd & ld-gold.
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-05-04 09:49:32 UTC
If it's fixed upstream, I'd just make the ebuild use python-any-r1 and request proper Python version instead.
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-05-04 09:51:00 UTC
*** Bug 443600 has been marked as a duplicate of this bug. ***
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-05-05 08:15:54 UTC
This one's fixed in 1.0.25-r1, pmasked currently.
Comment 10 Michael Palimaka (kensington) gentoo-dev 2016-01-24 12:38:43 UTC
1.0.25-r1 is stable and 1.0.26 is in tree which contains the fix upstream.