Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 395657 - dev-ruby/capistrano-2.9.0 stable request
Summary: dev-ruby/capistrano-2.9.0 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2011-12-22 09:05 UTC by Hans de Graaff
Modified: 2012-07-11 15:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans de Graaff gentoo-dev 2011-12-22 09:05:45 UTC
This version has been in the tree for serveral months with no open bugs, and a large amount of improvements over the currently stable version.


=dev-ruby/net-ssh-gateway-1.1.0
=dev-ruby/capistrano-2.9.0
Comment 1 Agostino Sarubbo gentoo-dev 2011-12-22 14:42:26 UTC
amd64 stable
Comment 2 Thomas Kahle (RETIRED) gentoo-dev 2012-02-20 12:46:20 UTC
There is a failing test for capistrano on x86:

 * Running test phase for ruby18 ...
/usr/bin/ruby18 -I"lib:lib:test" -I"/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib" "/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_test_loader.rb" "test/**/*_test.rb" 
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require': no such file to load -- bundler/setup (LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
        from ./test/utils.rb:2
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
        from /var/tmp/portage/dev-ruby/capistrano-2.9.0/work/ruby18/capistrano-2.9.0/test/extensions_test.rb:1
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
        from /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_test_loader.rb:10
        from /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_test_loader.rb:9:in `each'
        from /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_test_loader.rb:9
        from /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_test_loader.rb:4:in `select'
        from /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_test_loader.rb:4
rake aborted!
Command failed with status (1): [/usr/bin/ruby18 -I"lib:lib:test" -I"/usr/l...]

Tasks: TOP => test
(See full trace by running task with --trace)
Comment 3 Brent Baude (RETIRED) gentoo-dev 2012-03-11 12:59:13 UTC
already ppc64 stable
Comment 4 Brent Baude (RETIRED) gentoo-dev 2012-03-11 13:01:49 UTC
disregard previous
Comment 5 Hans de Graaff gentoo-dev 2012-04-03 17:48:51 UTC
I'm now also seeing other test failures for this packages, so I'm removing arches until things are properly fixed.
Comment 6 Hans de Graaff gentoo-dev 2012-04-28 18:47:04 UTC
(In reply to comment #5)
> I'm now also seeing other test failures for this packages, so I'm removing
> arches until things are properly fixed.

The problem reported in comment #2 and the other failures I noticed have now been fixed or worked around. Please continue with stabilization.
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2012-05-05 18:40:56 UTC
ia64 keywords dropped
Comment 8 Mark Loeser (RETIRED) gentoo-dev 2012-05-20 11:27:09 UTC
ppc/ppc64 done
Comment 9 Andreas Schürch gentoo-dev 2012-06-30 13:05:10 UTC
=dev-ruby/net-ssh-gateway-1.1.0 fails for me on x86 if USE=doc is set and ruby-1.9 is eselected! It works with 1.8.


 # eselect ruby set 2
Successfully switched to profile:
  ruby19                    

 # USE='doc ruby_targets_ree18 ruby_targets_ruby18'  emerge -av =dev-ruby/net-ssh-gateway-1.1.0

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] dev-ruby/net-ssh-gateway-1.1.0  USE="doc test" RUBY_TARGETS="ree18 ruby18" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] 

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-ruby/net-ssh-gateway-1.1.0
 * net-ssh-gateway-1.1.0.gem RMD160 SHA1 SHA256 size ;-) ...                                                                   [ ok ]
>>> Unpacking source...
 * Running unpack phase for all ...
 * Unpacking .gem file... ...                                                                                                  [ ok ]
 * Uncompressing metadata ...                                                                                                  [ ok ]
 * Unpacking data.tar.gz ...                                                                                                   [ ok ]
>>> Source unpacked in /var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/work
>>> Preparing source in /var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/work ...
 * Running prepare phase for all ...
 * Running source copy phase for ruby18 ...
 * Running source copy phase for ree18 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/work ...
 * Running compile phase for all ...
/usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/alt_system.rb:32: Use RbConfig instead of obsolete and deprecated Config.
(in /var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/work/all/net-ssh-gateway-1.1.0)
rake aborted!
cannot load such file -- net/ssh
/var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/work/all/net-ssh-gateway-1.1.0/Rakefile:1:in `<top (required)>'
(See full trace by running task with --trace)
 * ERROR: dev-ruby/net-ssh-gateway-1.1.0 failed (compile phase):
 *   failed to (re)build documentation
 * 
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
 *   environment, line 4310:  Called ruby-ng_src_compile
 *   environment, line 4007:  Called _ruby_invoke_environment 'all' 'all_ruby_compile'
 *   environment, line  489:  Called all_ruby_compile
 *   environment, line  563:  Called all_fakegem_compile
 *   environment, line  531:  Called die
 * The specific snippet of code:
 *           rake ${RUBY_FAKEGEM_TASK_DOC} || die "failed to (re)build documentation";
 * 
 * If you need support, post the output of `emerge --info '=dev-ruby/net-ssh-gateway-1.1.0'`,
 * the complete build log and the output of `emerge -pqv '=dev-ruby/net-ssh-gateway-1.1.0'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="/usr/libexec/ccp4/bin:/usr/libexec/ccp4/bin:" JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info
 * The complete build log is located at '/var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/work/all/net-ssh-gateway-1.1.0'
 * S: '/var/tmp/portage/dev-ruby/net-ssh-gateway-1.1.0/work/all/net-ssh-gateway-1.1.0'
Comment 10 Hans de Graaff gentoo-dev 2012-07-01 07:49:43 UTC
(In reply to comment #9)
> =dev-ruby/net-ssh-gateway-1.1.0 fails for me on x86 if USE=doc is set and
> ruby-1.9 is eselected! It works with 1.8.

We currently don't support anything other than eselecting ruby 1.8. I've filed bug 424339 to deal with this situation in a more generic way.
Comment 11 Andreas Schürch gentoo-dev 2012-07-11 15:00:53 UTC
x86 stable, thanks! :-)

last arch, closing.