Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 395387 - media-libs/x264-0.0.20111218 - fatal: ambiguous argument 'origin/master': unknown revision or path not in the working tree.
Summary: media-libs/x264-0.0.20111218 - fatal: ambiguous argument 'origin/master': unk...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-20 18:43 UTC by Eric Westbrook
Modified: 2015-10-12 10:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Westbrook 2011-12-20 18:43:58 UTC
Sandbox violation occurs during configure phase of emerge.

Reproducible: Always

Steps to Reproduce:
1. emerge -av =media-libs/x264-0.0.20111218

Actual Results:  
>>> Emerging (1 of 1) media-libs/x264-0.0.20111218
 * x264-snapshot-20111218-2245-stable.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                      [ ok ]
>>> Unpacking source...
>>> Unpacking x264-snapshot-20111218-2245-stable.tar.bz2 to /var/tmp/portage/media-libs/x264-0.0.20111218/work
>>> Source unpacked in /var/tmp/portage/media-libs/x264-0.0.20111218/work
>>> Preparing source in /var/tmp/portage/media-libs/x264-0.0.20111218/work/x264-snapshot-20111218-2245-stable ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-libs/x264-0.0.20111218/work/x264-snapshot-20111218-2245-stable ...
fatal: ambiguous argument 'origin/master': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions
ACCESS DENIED  opendir:      /var/log/sandbox
platform:      X86
system:        LINUX
cli:           no
libx264:       internal
shared:        yes
static:        no
asm:           yes
interlaced:    yes
avs:           no
lavf:          no
ffms:          no
gpac:          no
gpl:           yes
thread:        posix
filters:       crop select_every
debug:         no
gprof:         no
strip:         no
PIC:           yes
visualize:     no
bit depth:     8
chroma format: all

You can run 'make' or 'make fprofiled' now.
>>> Source configured.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-16658.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: opendir
S: deny
P: var/log/sandbox/
A: /var/log/sandbox
R: /var/log/sandbox
C: git status
--------------------------------------------------------------------------------

>>> Failed to emerge media-libs/x264-0.0.20111218, Log file:

>>>  '/var/log/portage/media-libs:x264-0.0.20111218:20111220-182707.log'
Comment 1 Eric Westbrook 2011-12-20 18:45:15 UTC
# emerge --info
Portage 2.1.10.41 (default/linux/x86/10.0, gcc-4.4.5, glibc-2.13-r4, 2.6.39-gentoo-r3 i686)
=================================================================
System uname: Linux-2.6.39-gentoo-r3-i686-Intel-R-_Atom-TM-_CPU_N270_@_1.60GHz-with-gentoo-2.0.3
Timestamp of tree: Tue, 20 Dec 2011 16:30:01 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
ccache version 3.1.6 [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5, 4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo EW-local-g-cpan-repo EW-usr-local-repo EW-dev-portage-repository
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 Broadcom AdobeFlash-10 AdobeFlash-10.1 googleearth skype-eula PUEL Oracle-BCLA-JavaSE"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/X11 /etc/portage /usr/share/X11/app-defaults /usr/share/config /usr/share/gnupg/qualified.txt /var/service"
CONFIG_PROTECT_MASK="/etc/X11/xkb /etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs ccache distcc distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-z,now -Wl,-as-needed -Wl,-O1 -Wl,-hash-style=gnu -Wl,-sort-common"
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/g-cpan /usr/local/portage /home/eric/dev/git/portdir-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi adns aften alsa amr amrnb amrwb aspell audio bash-completion bcmath berkdb bluetooth bugzilla bzip2 cairo ccache cdb cdda cddax cddb cdparanoia cdr cgi cjk cleartype cli corefonts cracklib crypt css ctype cups curl curlwrappers cxx daap dbus dirac djbfft djvu dri dts dv dvb dvd dvdnav dvdr dvdread emacs encode exif fastcgi ffmpeg fftw firefox flac fluidsynth fontconfig fontforge fping ftp gd gdbm gif git gpm graphviz gsm gstreamer gtk hpcups iconv id3tag idn imagemagick imlib ipv6 ivtv java javascript jbig jpeg jpeg2k kate lame lcms libnotify libsamplerate libv4l2 libvisual lighttpd lirc lm_sensors logrotate lua lzo mad math matroska md5sum midi mikmod mjpeg mmx mmxext mng modules mp3 mp4 mpeg mpeg2 mplayer mudflap musepack mysql mysqli mythtv nas ncurses nemesi network nls nptl nptlonly nsplugin nuv offensive ogg openal opengl openmp pam pcre pdf perl png pnm posix ppds pppd pvr python qt3support qt4 quicktime rar raw readline reflection rtc rtmp rtsp ruby samba schroedinger sdl sdl-image session shout slang sndfile snmp soap sox speex spell spl sqlite sqlite3 sse sse2 sse3 ssl startup-notification subtitles svg sysfs syslog tcpd theora tiff timidity tk transcode truetype twolame type3 udev unicode urandom usb utils v4l v4l2 vcd vcdinfo vhosts video vorbis wavpack win32codecs wma wmf wmp x264 x86 xcb xcomposite xine xml xorg xosd xpm xscreensaver xv xvid yv12 zip zlib zvbi" ALSA_CARDS="usb-audio hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" LIRC_DEVICES="mceusb" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2011-12-20 20:16:39 UTC
It does not look like an actual sandbox violation to me (or why would git want to access /var/log/sandbox?). The second error (the alleged sandbox violation) is what causes the build failure, since FEATURES=strict. If you do not set that (or stricter, and so on) it merrily marches on and "succeeds" the compile phase nicely.
Comment 3 Eric Westbrook 2011-12-28 17:42:19 UTC
Okay...  but git still shouldn't be failing at all, should it?  Should it even be invoked at all?
Comment 4 Eric Westbrook 2011-12-29 15:25:23 UTC
Building with FEATURES="-sandbox" also allows the build to proceed and succeed.  Harmless enough in this case, since the offending command is a simple "git status", but still very unsatisfying.

So, I'll keep standing by for response(s) about the need for this git activity in a non-git build.  Since the build succeeds without the success of that git command anyway, I have to posit that it's unnecessary and doesn't belong.  I'd be happy to make a patch to skip or remove it, if consensus agrees.
Comment 5 darkshikari 2012-02-04 20:00:18 UTC
x264 uses git to calculate the version information for x264 --version, which is necessary since x264 doesn't have official release version numbers.  x264 will build without it, but won't list the actual version number, only the API/soname version.
Comment 6 Alexis Ballier gentoo-dev 2015-10-12 10:11:08 UTC
seems fixed in latest snapshots