Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 395337 - dev-perl/PortageXS-0.02.09 fails tests
Summary: dev-perl/PortageXS-0.02.09 fails tests
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Kent Fredric (IRC: kent\n) (RETIRED)
URL:
Whiteboard:
Keywords:
: 395493 (view as bug list)
Depends on:
Blocks: perl-testfailure
  Show dependency tree
 
Reported: 2011-12-20 07:43 UTC by Paweł Hajdan, Jr. (RETIRED)
Modified: 2014-12-27 19:37 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (dev-perl:PortageXS-0.02.09:20111219-190205.log.gz,5.65 KB, application/x-gzip)
2011-12-20 07:43 UTC, Paweł Hajdan, Jr. (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-12-20 07:43:25 UTC
Created attachment 296421 [details]
build.log.gz

make -j3 test TEST_VERBOSE=0 
PERL_DL_NONLAZY=1 /usr/bin/perl5.12.4 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00_PortageXS.t ... ^Mt/00_PortageXS.t ... 1/3 
#   Failed test 'getPortdir: ${EPREFIX}/usr/portage'
#   at t/00_PortageXS.t line 11.
# Looks like you failed 1 test of 3.
^M                          ^Mt/00_PortageXS.t ... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/3 subtests 
t/01_Core.t ........ ^Mt/01_Core.t ........ 1/32 
#   Failed test 'getPortdir: ${EPREFIX}/usr/portage'
#   at t/01_Core.t line 13.

#   Failed test 'getAvailableEbuilds - dev-lang/perl: '
#   at t/01_Core.t line 42.
Cannot open file ${EPREFIX}/usr/portage/profiles/arch.list at lib//PortageXS/Core.pm line 193.
# Looks like you planned 32 tests but ran 8.
# Looks like you failed 2 tests of 8 run.
# Looks like your test exited with 2 just after 8.
^M                           ^Mt/01_Core.t ........ Dubious, test returned 2 (wstat 512, 0x200)
Failed 26/32 subtests 
t/02_UI_Spinner.t .. ^Mt/02_UI_Spinner.t .. 1/1 ^M                          ^Mt/02_UI_Spinner.t .. ok
t/03_System.t ...... ^Mt/03_System.t ...... 1/1 ^M                          ^Mt/03_System.t ...... ok
t/04_Useflags.t .... Use of uninitialized value $usedesc in concatenation (.) or string at t/04_Useflags.t line 14.
^Mt/04_Useflags.t .... 1/4 
#   Failed test 'getUsedesc('perl','${EPREFIX}/usr/portage'): '
#   at t/04_Useflags.t line 14.

#   Failed test 'getUsedescs('perl','${EPREFIX}/usr/portage'): '
#   at t/04_Useflags.t line 20.
Cannot open file ${EPREFIX}/usr/portage/profiles/base/use.mask at lib//PortageXS/Core.pm line 193.
# Looks like you planned 4 tests but ran 3.
# Looks like you failed 2 tests of 3 run.
# Looks like your test exited with 2 just after 3.
^M                          ^Mt/04_Useflags.t .... Dubious, test returned 2 (wstat 512, 0x200)
Failed 3/4 subtests 
t/05_Console.t ..... ^Mt/05_Console.t ..... 1/2 Cannot open file ${EPREFIX}/usr/portage/profiles/base/use.mask at lib//PortageXS/Core.pm line 193.
# Looks like you planned 2 tests but ran 1.
# Looks like your test exited with 2 just after 1.
^M                          ^Mt/05_Console.t ..... Dubious, test returned 2 (wstat 512, 0x200)
Failed 1/2 subtests 

Test Summary Report
-------------------
t/00_PortageXS.t (Wstat: 256 Tests: 3 Failed: 1)
  Failed test:  2
  Non-zero exit status: 1
t/01_Core.t      (Wstat: 512 Tests: 8 Failed: 2)
  Failed tests:  2, 7
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 32 tests but ran 8.
t/04_Useflags.t  (Wstat: 512 Tests: 3 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 4 tests but ran 3.
t/05_Console.t   (Wstat: 512 Tests: 1 Failed: 0)
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 2 tests but ran 1.
Files=6, Tests=17,  2 wallclock secs ( 0.04 usr  0.06 sys +  0.36 cusr  0.17 csys =  0.63 CPU)
Result: FAIL
Failed 4/6 test programs. 5/17 subtests failed.
make: *** [test_dynamic] Error 2
emake failed
 * ERROR: dev-perl/PortageXS-0.02.09 failed (test phase):
 *   test failed

Portage 2.1.10.41 (default/linux/x86/10.0/developer, gcc-4.5.3, glibc-2.13-r4, 3.0.6-gentoo i686)
=================================================================
System uname: Linux-3.0.6-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_P8700_@_2.53GHz-with-gentoo-2.0.3
Timestamp of tree: Mon, 19 Dec 2011 15:00:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect compress-build-logs distlocks ebuild-locks fixlafiles multilib-strict news parallel-fetch protect-owned sandbox sfperms sign splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus device-mapper dri dts dvd dvdr emacs emboss encode exif fam firefox flac fortran gdbm gdu gif git gnome-keyring gnutls gtk iconv icu jpeg lcms libnotify mad mbox mercurial mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nss objc ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline sdl secure-delete session snmp spell sqlite ssl startup-notification subversion svg sysfs tcb tcpd threads tiff toolkit-scroll-bars truetype udev unicode usb vorbis x264 x86 xcb xft xinerama xml xorg xulrunner xv xvfb xvid zlib" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vmware vesa vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Torsten Veller (RETIRED) gentoo-dev 2011-12-22 04:50:52 UTC
*** Bug 395493 has been marked as a duplicate of this bug. ***
Comment 2 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-12-27 19:37:56 UTC
0.02.10-r4 seems to be fine.