Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 394605 - sys-process/lsof does not list libraries anymore
Summary: sys-process/lsof does not list libraries anymore
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-13 21:20 UTC by Dennis Schridde
Modified: 2013-10-18 17:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2011-12-13 21:20:39 UTC
When I run lsof on e.g. /usr, it will only list binaries, i.e. files in /usr/{bin,sbin,libexec}, but no libraries, i.e. files in /usr/lib{32,64}. Some time ago this still worked. Currently /proc/*/maps also lists libraries, so theoretically it seems possible to get that information.

Reproducible: Always




Portage 2.2.0_alpha80 (default/linux/amd64/10.0/desktop/kde, gcc-4.6.2, glibc-2.14.1-r1, 3.1.5-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.1.5-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.1
Timestamp of tree: Tue, 13 Dec 2011 19:15:01 +0000
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.7
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r1
Repositories: gentoo kde sunrise bitcoin local
Installed sets: @kdebase
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=athlon64-sse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/neatx/home"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=athlon64-sse3"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--depclean-lib-check n --with-bdeps y --keep-going"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS=""
GENTOO_MIRRORS="ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--hash-style=gnu"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/gentoo"
PORTDIR_OVERLAY="/var/cache/portage/layman/kde /var/cache/portage/layman/sunrise /var/cache/portage/layman/bitcoin /var/cache/portage/local"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-process/lsof-4.85-r2 was built with the following:
USE="(consolekit) ipv6 (multilib) (policykit) -examples -rpc (-selinux) -static"
Comment 1 SpanKY gentoo-dev 2011-12-14 18:21:42 UTC
post the actual commands you're running
Comment 2 Dennis Schridde 2011-12-14 20:01:14 UTC
(In reply to comment #1)
> post the actual commands you're running
lsof /usr
Previously this showed libraries, too.
Comment 3 SpanKY gentoo-dev 2011-12-14 20:38:59 UTC
that shows nothing at all for me.  is your /usr a sep mount point ?
Comment 4 Dennis Schridde 2011-12-15 01:42:15 UTC
(In reply to comment #3)
> that shows nothing at all for me.  is your /usr a sep mount point ?
Yes, it is.
Comment 5 Dennis Schridde 2011-12-16 16:08:14 UTC
I went back as far as sys-process/lsof-4.82 and still it lists no libraries. Hence I assume it must be either a kernel config option (even though I am just doing "make oldconfig" since quite a while) or it has trouble when compiled with a 3.x kernel.
Comment 6 Dennis Schridde 2011-12-18 13:03:01 UTC
(In reply to comment #5)
> Hence I assume [...]
Another idea: It could be caused by btrfs. Maybe that reports open libraries differently to /proc?
Comment 7 Dennis Schridde 2011-12-18 13:39:12 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Hence I assume [...]
> Another idea: It could be caused by btrfs. Maybe that reports open libraries
> differently to /proc?
P.S: I started to debug it and it seems that it examines the files correctly in process_proc_map(), but they are still missing in the output. Maybe somewhere later the libraries are being filtered for some reason.
Comment 8 SpanKY gentoo-dev 2011-12-31 20:28:26 UTC
(In reply to comment #7)

did you get any further on this ?
Comment 9 Dennis Schridde 2012-01-01 13:05:31 UTC
(In reply to comment #8)
> did you get any further on this ?
Nope, I will probably start another debugging / source-code-reading session when I have more time in a few days.
Comment 10 Tony Vroon gentoo-dev 2013-10-18 17:47:01 UTC
A year and a half has passed, and no follow-up has been provided. Please reopen the bug if you decide to continue the troubleshooting process.
(I am closing old base-system bugs so I can see the forest for the trees)