Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 39392 - Grub 0.93.20031222 kills booting
Summary: Grub 0.93.20031222 kills booting
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2004-01-25 16:15 UTC by drumz
Modified: 2004-03-03 14:14 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---

Output from emerging grub (mylog.txt,269.43 KB, text/plain)
2004-01-25 16:42 UTC, drumz

Note You need to log in before you can comment on or make changes to this bug.
Description drumz 2004-01-25 16:15:25 UTC
Performed an emerge sync, then update.  During update grub was updated/installed.
Rebooted laptop and didn't get the usual grub screen listing my various kernels to boot but instead ended up at a grub prompt.  Had to boot of install cd and re-install an older grub that way.

Once I was back in action, tried running the grub command to update to the one installed by the emerge update.  Correctly issued the root, setup, quit commands with no problems.  Rebooted and back to the darn grub prompt again.

Rebooted _again_ off of an install cd an issued the same commands using the install cd's grub so that I can use my laptop again.

Reproducible: Always
Steps to Reproduce:
1.emerge sync
2.emerge --update --deep world
3.reboot, get grub prompt instead of OS/kernel selection menu.

Actual Results:  
Rebooted and now get grub prompt instead of selection menu.

Expected Results:  
No effect on my ability to reboot and run an installed OS/kernel.

Portage 2.0.50_pre20 (default-x86-1.4, gcc-3.3.2, glibc-2.3.3_pre20040117-r0,
System uname: 2.4.24 i686 Pentium III (Coppermine)
Gentoo Base System version
Autoconf: sys-devel/autoconf-2.59
Automake: sys-devel/automake-1.7.8
CFLAGS="-O3 -march=pentium3 -funroll-loops -pipe"
CONFIG_PROTECT="/etc /opt/tomcat/conf /usr/X11R6/lib/X11/xkb
/usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3/share/config
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -march=pentium3 -funroll-loops -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="X alsa apache2 apm arts avi berkdb crypt cups doc dvd encode foomaticdb
gdbm gif gnome gphoto2 gpm gtk gtk2 imlib innodb java jpeg kde ldap libg++
libwww mad mikmod motif mozilla mpeg mysql ncurses nls oci8 oggvorbis opengl oss
pam pcmcia pdflib perl png pnp postgres python qt quicktime readline samba sdl
slang spell ssl svga tcpd tiff truetype trustedusb x86 xml2 xmms xv zlib"
Comment 1 drumz 2004-01-25 16:42:52 UTC
Created attachment 24421 [details]
Output from emerging grub

This is the output when performing an emerge of grub.  There are numerous
compiler warnings during compilation, then near the end is the message:

Unrecognized option `--just-copy'
Usage: grub-install [OPTION] install_device
Install GRUB on your drive
cp: omitting directory `/usr/lib/grub/grub'

Note the 'unrecognized option' error. and the cp omitting message.  Don't know
if these are relevant or not.  Just trying to provide as much info as possible.

Machine is:  PIII dell laptop (inspiron 5000e).
Comment 2 Jonathan Heaney 2004-01-25 17:25:42 UTC
I've just emerge'd sync etc etc and grub has been updated (to a pre 0.9.4 version), getting the same problem here, booting just dumps me at a grub prompt.  Looks like the same problem as mentioned above, but I'm in Windows at the moment and can't confirm 100%.
Comment 3 Roy Marples (RETIRED) gentoo-dev 2004-01-25 17:27:55 UTC
I can verify this.

It looks like grub doesn't compile correct as there are a load of warnings that flash past during comple and practically nothing gets copied to /boot/grub.

Re-emerging the previous version works like a charm.
Only thing I have in common with the reporters setup is the same glibc version
Comment 4 M Guzman 2004-01-25 17:40:48 UTC
I am also having this problem.  It works if I type in configfile (hd0,0)/grub/grub.conf at the grub prompt (but the splashimage doesn't work), leading me to believe that perhaps it doesn't correctly recognize the 'root' directive or something similar to this.
Comment 5 Deepu Sudhakar 2004-01-25 17:44:43 UTC
Within /boot/grub symlink "menu.lst" to "grub.conf". It seems that the new version of grub isn't using grub.conf (it uses menu.lst) instead. Symlinking should fix everything.
Comment 6 M Guzman 2004-01-25 17:45:55 UTC
Sorry for the double post, but I just realized I was having these problems with grub 0.93.20040125, not grub 0.93.20031222.  I also see that 20040125 was removed from portage or masked (not sure which atm).  I have not yet tried 20031222 (I've been using LILO up to this point, was planning on converting to grub today).
Comment 7 N Addy 2004-01-25 19:15:52 UTC
Just emerged grub-0.93.20040125 and now I can only boot to a grub text menu (i.e. no bootsplash).  "menu.lst" is symlinked to "grub.conf" but doesn't have any effect.
Comment 8 Aaron Gyes 2004-01-25 19:37:32 UTC
Well, I'm on the new one and it works fine here. Glibc 2.3.2, gcc 3.3.2, kernel 2.6.1-rc1.
Comment 9 Jonathan Heaney 2004-01-26 04:06:14 UTC
Can confirm here that you need the /boot/grub/menu.lst symlink to /boot/grub/grub.conf to get grub-0.93.20031222 to work.

Ansd also that the splash screen doesn't work any more - the gzipped xpm is still there though.
Comment 10 drumz 2004-01-26 15:21:59 UTC
I too (origina reporter) confirm the following:

1.  ln -s /boot/grub/grub.conf /boot/grub/menu.lst 'fixes' the booting issue.
2.  No pretty grub screen -> plain jane black and white menu.

I highly recommend that the ebuild at some point automatically create the required link.  I find it very annoying as an end user to have this happen - a newbie might very well assume there system is totally hosed and think a re-install is in order.  Performing this link automatically solves the problem, and should be maintained for the future as a 'just in case'.

Comment 11 Jonathan Heaney 2004-01-26 15:50:54 UTC
The Gentoo Installation Guide has this in it-

"Important: To ensure backwards compatibility with GRUB, make sure to make a link from grub.conf to menu.lst. You can do this by typing ln -s /boot/grub/grub.conf /boot/grub/menu.lst."

Although it seems now that the symlink is needed for forwards compatability as well.

Anyone got a solution to the splash image problem?

Comment 12 drumz 2004-01-26 16:20:44 UTC
As for the reference to the installation manual stating the need for the backwardly compatible link for menu.lst:  It is NOT included in the Handbook Installation Guide.


I DO remember that it was specified in the original installation guide.  But since it wasn't specified in the new handbook I didn't think it was necessary anymore.  Hence to make it easier on the end user they should just automagically create it in the ebuild script (or at least check for it's presence, then create it if it's not there).

I still have not come across a fix for the splash image yet.
Comment 13 Seemant Kulleen (RETIRED) gentoo-dev 2004-01-26 16:40:05 UTC
hi listen, sorry about this -- I'll be updating grub tonight with both splashimage stuff and the menu.lst/grub.conf stuff

My apologies.  In my rush to get this out the door for the ext2/3-acl issue, I neglected those patches.  Stand by, everyone, grub will return as normal, shortly.
Comment 14 Vermyndax 2004-01-28 09:51:48 UTC
Uhhh, did I miss something or has grub not been updated to fix this?
Comment 15 Cletus Lichte 2004-01-30 08:02:32 UTC
I have a symbolic link to grub.conf and it still won't boot.  All I get is a grub command prompt.
Comment 16 Pergamon 2004-02-01 06:15:07 UTC
Grub 20031222 did render two systems of mine unusable. 
One was a machine I just installed from scratch: during Grub installation, the command "setup (hd0)" would fail. Reason: all stage1* files where missing in /boot/grub. The second machine was just updated and after update would just boot into Grub console. Adding "=sys-boot/grub-093.20031222" to my packages.mask and then emerging an older version of Grub did fix both boxes.
Comment 17 Andrus Obukak 2004-02-01 13:41:24 UTC
To boot enter on grub command prompt "kernel /boot/bzImage" and then "boot"
Comment 18 Steven Platt 2004-02-02 20:53:46 UTC
I sure do wish I would look at bugs before I freak out.  I rebooted off the liveCD 3 times before I realized there was no symlink to grub.conf.  What happened to the good old days when you didn't need a menu.lst?  But, I am still stuck with the ugly white on black grub screen.  
Comment 19 Pergamon 2004-02-04 15:08:31 UTC
Grub 0.94 fixes booting for both new installations and updates. Only background image function is broken: no background image is displayed with 0.94.
Comment 20 Pergamon 2004-02-29 04:10:02 UTC
grub 0.94-r1 fixes splashimage functionality that was broken with 0.94
Comment 21 Seemant Kulleen (RETIRED) gentoo-dev 2004-02-29 14:59:12 UTC
closing this bug
Comment 22 Daniel Kasak 2004-03-03 14:14:30 UTC
Note that you have to RE-RUN 'grub' after installing the new version or the menu will still not work!