Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 393335 - dev-java/icedtea-7.2.0-r3 - segmentation fault in /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/jdk1.6.0/bin/java
Summary: dev-java/icedtea-7.2.0-r3 - segmentation fault in /var/tmp/portage/dev-java/i...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Andrew John Hughes
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-06 00:35 UTC by Hack_leberry Finn
Modified: 2013-05-15 10:55 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
hs_err_pid25283.log (hs_err_pid25283.log,15.32 KB, text/plain)
2011-12-06 00:35 UTC, Hack_leberry Finn
Details
full 'emerge --info' output (emerge_info.log,6.97 KB, text/plain)
2011-12-07 18:48 UTC, Hack_leberry Finn
Details
icedtea-7.2.0-r3 build log (build.log.gz,373.56 KB, application/x-gzip)
2011-12-07 19:01 UTC, Hack_leberry Finn
Details
Robert - Build log for icedtea-7.2.0-r3 bzip2 compressed (build.log.bz2,328.83 KB, application/x-bzip)
2011-12-14 07:30 UTC, Robert
Details
Robert - emerge --info output (emerge-info.txt,5.49 KB, text/plain)
2011-12-14 07:30 UTC, Robert
Details
Robert - output of 'emerge -pqv =dev-java/icedtea-7.2.0-r3' (emerge-output.txt,301 bytes, text/plain)
2011-12-14 07:31 UTC, Robert
Details
Build log (build.log.gz,305.37 KB, application/x-gzip)
2011-12-15 04:25 UTC, Andrew Udvare
Details
Tatsh -- emerge --info (emerge-info.txt,4.94 KB, text/plain)
2011-12-15 04:29 UTC, Andrew Udvare
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hack_leberry Finn 2011-12-06 00:35:24 UTC
Created attachment 294915 [details]
hs_err_pid25283.log

When I try compilation of dev-java/icedtea-7.2.0-r3 it fails:

>>>Finished making images @ Tue Dec  6 00:55:14 CET 2011 ...
make[3]: Leaving directory `/var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/openjdk-boot/jdk/make'
########################################################################
##### Leaving jdk for target(s) sanity all  images                 #####
########################################################################
##### Build time 00:24:42 jdk for target(s) sanity all  images     #####
########################################################################

-- Build times ----------
Target all_product_build
Start 2011-12-05 23:44:09
End   2011-12-06 00:55:14
00:04:43 corba
00:35:18 hotspot
00:01:56 jaxp
00:02:18 jaxws
00:24:42 jdk
00:02:08 langtools
01:11:05 TOTAL
-------------------------
make[2]: Leaving directory `/var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/openjdk-boot'
make[1]: Leaving directory `/var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/openjdk-boot'
Bootstrapped IcedTea is served: /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/openjdk.build-boot
mkdir -p stamps
touch stamps/icedtea-boot.stamp
mkdir -p stamps
touch stamps/icedtea-stage1.stamp
rm -rf /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/icedtea
ln -s /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/openjdk.build-boot/j2sdk-image/ /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/icedtea
if ! test -d /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/icedtea/include; then \
  ln -sf /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/openjdk.build-boot/include /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/icedtea/include; \
fi
mkdir -p stamps
touch stamps/bootstrap-directory-stage2.stamp
mkdir -p bootstrap
rm -f /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/jdk1.6.0
ln -sf /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/icedtea /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/jdk1.6.0; \
if ! /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/jdk1.6.0/bin/java -version ; \
         then \
           echo "/var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/jdk1.6.0/bin/java" \
               "cannot be found or is corrupted." ; \
           exit 1; \
        fi
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0xb6beff0f, pid=25283, tid=3064044400
#
# JRE version: 7.0_147-b147
# Java VM: OpenJDK Client VM (21.0-b17 mixed mode linux-x86 )
# Derivative: IcedTea7 2.0
# Distribution: Built on Gentoo Base System release 2.0.3 (Mon Dec  5 23:37:51 CET 2011)
# Problematic frame:
# V  [libjvm.so+0x63f0f]  MacroAssembler::jump(AddressLiteral)+0x3f
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/hs_err_pid25283.log
Could not load hsdis-i386.so; library not loadable; PrintAssembly is disabled
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
#
/bin/sh: line 6: 25283 Aborted                 /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/jdk1.6.0/bin/java -version
/var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/bootstrap/jdk1.6.0/bin/java cannot be found or is corrupted.
make: *** [stamps/bootstrap-directory-symlink-stage2.stamp] Error 1
 * ERROR: dev-java/icedtea-7.2.0-r3 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of 'emerge --info =dev-java/icedtea-7.2.0-r3',
 * the complete build log and the output of 'emerge -pqv =dev-java/icedtea-7.2.0-r3'.
 * The complete build log is located at '/var/tmp/portage/dev-java/icedtea-7.2.0-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/icedtea-7.2.0-r3/temp/environment'.
 * S: '/var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0'

>>> Failed to emerge dev-java/icedtea-7.2.0-r3, Log file:

>>>  '/var/tmp/portage/dev-java/icedtea-7.2.0-r3/temp/build.log'

'emerge -vp icedtea'  gives:

[ebuild  N    ~] dev-java/icedtea-7.2.0-r3  USE="X alsa cups doc examples javascript jbootstrap nsplugin nss pulseaudio source webstart -cjk -debug -jamvm -systemtap" 0 kB
Comment 1 Jeroen Roovers gentoo-dev 2011-12-06 20:43:29 UTC
Comment on attachment 294915 [details]
hs_err_pid25283.log

1) Please post your `emerge --info' output in a comment.
2) Please attach the entire build log to this bug report.
Comment 2 Hack_leberry Finn 2011-12-07 18:48:02 UTC
Created attachment 295117 [details]
full 'emerge --info' output
Comment 3 Hack_leberry Finn 2011-12-07 19:01:14 UTC
Created attachment 295121 [details]
icedtea-7.2.0-r3 build log

Both logs you asked for. I hope they will help.
Comment 4 Jeroen Roovers gentoo-dev 2011-12-08 17:26:54 UTC
Maybe attaching this helps too:

# An error report file with more information is saved as:
# /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/hs_err_pid5745.log

Getting a backtrace might be useful too. Instructions are above the quoted lines.

Also, how much RAM does the system have?
Comment 5 Hack_leberry Finn 2011-12-08 22:24:42 UTC
(In reply to comment #4)
> Maybe attaching this helps too:
> 
> # An error report file with more information is saved as:
> #
> /var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/hs_err_pid5745.log
> 
> Getting a backtrace might be useful too. Instructions are above the quoted
> lines.
> 
> Also, how much RAM does the system have?

:) It was my first attachment: https://bugs.gentoo.org/attachment.cgi?id=294915
So I don't why You have changed it to obsolete - in this log you have all info about system memory, etc. Just read it :)

I don't see any hsdis source code compiled in icedtea sources, it looks like makefile was not executed.
I looked in:
/var/tmp/portage/dev-java/icedtea-7.2.0-r3/work/icedtea-2.0/openjdk/hotspot/src/share/tools/hsdis
and there are only:
hsdis.c  hsdis-demo.c  hsdis.h  Makefile  README
Comment 6 Robert 2011-12-14 07:27:31 UTC
I can confirm that I have this issue as well, I will post my build log, output of emerge --info and output of emerge -pqv =dev-java/icedtea-7.2.0-r3 as it requests in the output of the build. I have tried all kinds of use flag combinations, all of them end with this output unless i remove the jbootstrap flag, in which the build fails almost immediately (within 3 minutes of starting it, whereas this build fails after about 2 hours).

I have a 2.4 GHz Core 2 duo E4600 processor, 2GB of RAM and 2GB of swap space. (I only added this because there was a question about the original posters hardware and whether it was running out of memory. My memory was maxed out during this compile but swap still had over 70% free when it failed.

Been trying to deal with this on my own over the past couple days with no luck. However I would like to say that this build compiled fine on my laptop, with the same USE flags that I have now. The only difference between my desktop and my laptop is that the laptop has 4gb of ram and the desktop has a hardened kernel (only PaX no grsecurity or SELinux) and the laptop just has normal gentoo-sources for a kernel.

Anyway, on to posting my logs.
Comment 7 Robert 2011-12-14 07:30:08 UTC
Created attachment 295763 [details]
Robert - Build log for icedtea-7.2.0-r3 bzip2 compressed

Had to compress, over 6.8 MB if i didnt
Comment 8 Robert 2011-12-14 07:30:36 UTC
Created attachment 295765 [details]
Robert - emerge --info output
Comment 9 Robert 2011-12-14 07:31:30 UTC
Created attachment 295767 [details]
Robert - output of 'emerge -pqv =dev-java/icedtea-7.2.0-r3'

as requested by the compilation failure of icedtea
Comment 10 Robert 2011-12-14 07:37:57 UTC
After looking at our outputs more closely, they are not the same, the OP has a SIGSEGV and I have a SIGILL and our 'problematic frames' are different. He has

 "V  [libjvm.so+0x63f0f]  MacroAssembler::jump(AddressLiteral)+0x3f"

where as I have 

" V [libjvm.so+0x8c5e7d] Symbol::Symbol(unsigned char const*, int)+0xad"

although they do look very similar, if this is not the same bug just let me know and i will file a new bug report.

Thanks guys!
Comment 11 Andrew Udvare 2011-12-15 04:25:32 UTC
Created attachment 295887 [details]
Build log

I'm having a similar problem and the same problem with icedtea-7.2.0-r2. Build log attached.
Comment 12 Andrew Udvare 2011-12-15 04:29:51 UTC
Created attachment 295889 [details]
Tatsh -- emerge --info

emerge --info
output
Comment 13 Hack_leberry Finn 2011-12-19 23:35:22 UTC
I have idea what's going on. Look on bug 389709 especially comment 11: https://bugs.gentoo.org/show_bug.cgi?id=389709#c11

All problems look similar and they are caused by improper handling CFLAGS variable. My CFLAGS are: 
"-O2 -march=pentium-m -mtune=pentium-m -pipe -fomit-frame-pointer -msse -mmmx -msse2"
Problem is with -march -msse and -msse2 flag, when I set CFLAGS as:
"-02 -march=i686  -mtune=pentium-m -pipe -fomit-frame-pointer -mmmx"
compilation went fine. (As I know -march=pentium-m should set -mmmx -msse and -msse2, automatically, when -march=i686 only -mmmx.) In my CFLAGS, sse sse2 and mmx flags are given extra, because some times, march flag is changed to less optimized and compilation product is build without usage of sse mmx and sse2 instruction sets.
I think this is reason for writing r4 ebuild, with correct CFLAGS usage.
Comment 14 Robert 2011-12-25 05:58:41 UTC
(In reply to comment #13)
> I have idea what's going on. Look on bug 389709 especially comment 11:
> https://bugs.gentoo.org/show_bug.cgi?id=389709#c11
> 
> All problems look similar and they are caused by improper handling CFLAGS
> variable. My CFLAGS are: 
> "-O2 -march=pentium-m -mtune=pentium-m -pipe -fomit-frame-pointer -msse -mmmx
> -msse2"
> Problem is with -march -msse and -msse2 flag, when I set CFLAGS as:
> "-02 -march=i686  -mtune=pentium-m -pipe -fomit-frame-pointer -mmmx"
> compilation went fine. (As I know -march=pentium-m should set -mmmx -msse and
> -msse2, automatically, when -march=i686 only -mmmx.) In my CFLAGS, sse sse2 and
> mmx flags are given extra, because some times, march flag is changed to less
> optimized and compilation product is build without usage of sse mmx and sse2
> instruction sets.
> I think this is reason for writing r4 ebuild, with correct CFLAGS usage.

I found that changing my CFLAGS to CFLAGS="-march=core2 -O2 -pipe" and removing all the extra mmx sse sse2 etc flags like Hack stated in the quoted reply works like a charm!

Hopefully proper CFLAG handling will come out in -r4 but I am glad this compiles now. It was really bugging me before.

Cheers Hack leberry Finn!
Comment 15 Andrew John Hughes 2013-05-15 10:55:06 UTC
2.0 has not been supported in a long time.