Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 393161 - x11-drivers/xf86-input-synaptics-1.5.0: TwoFingerScroll no longer has any effect
Summary: x11-drivers/xf86-input-synaptics-1.5.0: TwoFingerScroll no longer has any effect
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gilles Dartiguelongue
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-04 18:09 UTC by Matthew Alexander LaChance
Modified: 2015-03-30 12:15 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Xorg.1.log for x11-drivers/xf86-input-synaptics-1.5.0 (Xorg.1.log,29.82 KB, text/plain)
2011-12-05 14:31 UTC, Matthew Alexander LaChance
Details
diff of Xorg.1.log (1.5.0) against Xorg.1.log (1.4.0) (Xorg.diff,3.35 KB, text/plain)
2011-12-05 14:34 UTC, Matthew Alexander LaChance
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Alexander LaChance 2011-12-04 18:09:04 UTC
Ever since updating, I've been unable to scroll with two fingers. Both VertTwoFingerScroll and HorizTwoFingerScroll are on, but my trackpad treats two fingers just as it would treat one finger.

Just to be explicit, it did work before.

Reproducible: Always

Steps to Reproduce:
1. Start X
2. Open any application with a scroll bar
3. Attempt to scroll with two fingers
Actual Results:  
The cursor moved as if I were using only one finger (the same happens with three or four fingers as well).

Expected Results:  
It should have scrolled.

I can use synclient to turn on edge scrolling, and edge scrolling works just fine. Otherwise, if I run `synclient -l`, it shows that both VertTwoFingerScroll and HorizTwoFingerScroll are set to 1. So it thinks it's on.
Comment 1 Matthew Alexander LaChance 2011-12-04 20:37:59 UTC
I should have mentioned that two-fingered scrolling works just fine after I downgrade to 1.4.0.
Comment 2 Chí-Thanh Christopher Nguyễn gentoo-dev 2011-12-05 14:03:11 UTC
Can you attach the Xorg.0.log from xf86-input-synaptics-1.5.0 and a diff against the log from 1.4.0?
Comment 3 Matthew Alexander LaChance 2011-12-05 14:31:08 UTC
Created attachment 294853 [details]
Xorg.1.log for x11-drivers/xf86-input-synaptics-1.5.0

I used Xorg.1.log instead of Xorg.0.log because it was faster to open a new X instance than to restart the current one. If this messes with the results, let me know, and I'll do it the nonlazy way.
Comment 4 Matthew Alexander LaChance 2011-12-05 14:34:53 UTC
Created attachment 294855 [details]
diff of Xorg.1.log (1.5.0) against Xorg.1.log (1.4.0)

I went ahead and removed all the timestamps at the beginnings of the lines -- if I hadn't, the entirety of each file would appear. Again, let me know if you actually need those timestamps.
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-03-20 16:12:40 UTC
Can you check if the problem still exists in 1.5.99.901?
Comment 6 Nikolaj Šujskij 2012-03-20 16:32:21 UTC
I can confirm this issue and 1.5.99.901 doesn't fix it, unfortunately.

TapButton2 has stopped functioning as well.
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-03-20 16:36:14 UTC
You probably need to report this upstream at https://bugs.freedesktop.org/  because xf86-input-synaptics-1.4.0 does not build against xorg-server-1.12 and that will go stable at some point.
Comment 8 Nikolaj Šujskij 2012-03-22 18:47:21 UTC
I have just tried to `git bisect` the issue, but most changesets can't be compiled on ~amd64 :(

Matthew, do you plan to report this upstream?
Comment 9 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-03-23 17:12:10 UTC
(In reply to comment #6)
> TapButton2 has stopped functioning as well.

I think there is a patch for the right button issue now in 1.5.99.902.
Comment 10 Nikolaj Šujskij 2012-03-23 20:58:34 UTC
(In reply to comment #9)
> (In reply to comment #6)
> > TapButton2 has stopped functioning as well.
> 
> I think there is a patch for the right button issue now in 1.5.99.902.

Nope, I've upgraded to 1.5.99.902 and started new X session to check, but with no success.

I wanted to check whether synaptics can detect two fingers, but

 % synclient -m 100
Can't access shared memory area. SHMConfig disabled?

...and I thought it was gone.
But when I checked it with 1.5.0, synclient did work and reported touch number correctly.
Comment 11 Chí-Thanh Christopher Nguyễn gentoo-dev 2015-03-30 12:15:09 UTC
older xf86-input-synaptics versions will be removed due to bug 544094. If you are still seeing this problem, please work with upstream to get it resolved in newer versions.