Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 392927 - x11-apps/xdm: init script does not depend on dbus when using gdm
Summary: x11-apps/xdm: init script does not depend on dbus when using gdm
Status: RESOLVED DUPLICATE of bug 390609
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-02 15:28 UTC by Qin Jue Hang
Modified: 2011-12-02 16:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Qin Jue Hang 2011-12-02 15:28:07 UTC
gdm requires dbus, but the xdm script does not depend on dbus. Hence, if gdm is used, and parallel boot is enabled, xdm does not start when init starts, with an error message about dbus. A simple fix would be to make xdm depend on dbus, however that would assume the user is not running a simplistic system with no dbus. Perhaps there could be a dbus useflag.

Reproducible: Always

Steps to Reproduce:
1.Select gdm in /etc/conf.d/xdm
2.Enable parallel boot in rc.conf
3.Boot
Actual Results:  
gnome does not start, requires manual #/etc/init.d/xdm restart

Expected Results:  
gnome starts

Problem only manifests with parallel boot
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2011-12-02 16:08:54 UTC
Add the line

  rc_use="dbus"

to your /etc/conf.d/xdm file...
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-12-02 16:40:53 UTC
This was fixed in x11-base/xorg-server-1.11.2-r2

*** This bug has been marked as a duplicate of bug 390609 ***