Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 392741 - ext/dl/callback.func seems corrupt in dev-lang/ruby-1.8.7_p352
Summary: ext/dl/callback.func seems corrupt in dev-lang/ruby-1.8.7_p352
Status: RESOLVED DUPLICATE of bug 370413
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-01 16:42 UTC by Seong-ho Cho
Modified: 2011-12-01 16:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Seong-ho Cho 2011-12-01 16:42:59 UTC
I'm using ~amd64 but I think that this problem also applicable another architecture.

during emerging ruby-1.8.7_p352, we can meet message as below.

callback.func:1:1: warning: data definition has no type or storage class
callback.func:1:7: error: expected identifier or ‘(’ before ‘long’
In file included from dl.c:104:0:
callback.func:78:33: error: expected ‘)’ before ‘(’ token
callback.func:79:3: warning: data definition has no type or storage class
callback.func:79:24: error: ‘proc’ undeclared here (not in a function)
callback.func:79:39: error: ‘argc’ undeclared here (not in a function)
callback.func:79:45: error: ‘argv’ undeclared here (not in a function)
callback.func:82:1: error: expected identifier or ‘(’ before ‘}’ token
sym.c: In function ‘rb_dlsym_inspect’:
sym.c:275:21: warning: format ‘%lx’ expects type ‘long unsigned int’, but argument 4 has type ‘struct sym_data *’
sym.c:275:21: warning: format ‘%lx’ expects type ‘long unsigned int’, but argument 5 has type ‘void *’
sym.c:275:21: warning: format ‘%lx’ expects type ‘long unsigned int’, but argument 4 has type ‘struct sym_data *’
sym.c:275:21: warning: format ‘%lx’ expects type ‘long unsigned int’, but argument 5 has type ‘void *’
dl.c:106:1: error: expected ‘;’, ‘,’ or ‘)’ before ‘static’

so I did check where callback.func is and what that problem is. 
this file is located at /var/tmp/portage/dev-lang/ruby-1.8.7_p352/work/ruby-1.8.7-p352/ext/dl created after fetching and extracting ruby source codes.
the front part of file "callback.func" seems corrupt.

first function has invalid form of function.

I attached that corrupted file in this report.

* i think that this bug needs to report to the upstream *
Comment 1 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-12-01 16:48:45 UTC

*** This bug has been marked as a duplicate of bug 370413 ***