Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 392441 - net-p2p/mldonkey-3.1.0 - mlnet segfaults
Summary: net-p2p/mldonkey-3.1.0 - mlnet segfaults
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at if you want to take care of it
Depends on:
Reported: 2011-11-29 17:37 UTC by Konstantin Agouros
Modified: 2016-01-31 09:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Agouros 2011-11-29 17:37:46 UTC
After the update to ocaml 3.12.1 and mldonkey to 3.1.0 calling mlnet simply segfaults.

I ran an lafilefixer, revdep-rebuild still if I just call mlnet from the commandline I immediately get a segmentation fault.

running strace the last call I set is a cal to getrlimit for stack size.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-12-04 03:30:49 UTC
I think you need to rebuild all dependencies in between ocaml and mldonkey after the ocaml upgrade.
Comment 2 Konstantin Agouros 2011-12-04 07:42:45 UTC
well the message after the ocaml upgrade mentioned this and I tried the command to find the dependencies (I think it was emerge -something 1 ocaml).
This just offered me to rebuild ocaml which I did. Anything else I should rebuild?
Comment 3 Jaakko Perttilä 2012-03-18 23:07:17 UTC
(In reply to comment #2)
I experienced similar behaviour with the same package versions.
Rebuilding (ocaml/mldonkey) without changing the use flags did not help.

I had to remove the ocamlopt use flag from mldonkey to get a segfault free startup.

And with that change I had to change the paludis build_options to symbols=preserve, so that the appended bytecode is not stripped/splitted.
The ebuild has 'use ocamlopt || export STRIP_MASK="*/bin/*"' in the src_install(). No idea if src_install is wrong place or is paludis just ignoring it. Anyway, this should likely be another bug.
Comment 4 Christophe PEREZ 2012-08-15 15:57:27 UTC
Same problem here :
ocamlopt.opt -inline 10 -linkall -o mlnet \
     bigarray.cmxa unix.cmxa str.cmxa nums.cmxa -ccopt "-Wl,-O1 -Wl,--as-needed " -cclib "-lz  " -cclib -lbz2 -ccopt "-pthread" \
 -cclib "-lgd -ljpeg -lfreetype -lz -lm" -ccopt "-Wl,-O1 -Wl,--as-needed -lpng15" \
 -cc 'x86_64-pc-linux-gnu-g++ -march=nocona -O2 -pipe' -ccopt '-fno-omit-frame-pointer -mno-omit-leaf-frame-pointer' \
-I build    build/extlib.cmxa    build/cdk.cmxa    build/bitstring.cmxa    build/magic.cmxa    build/common.cmxa    build/client.cmxa    build/core.cmxa    build/driver.cmxa    src/daemon/common/commonMain.cmx
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: src/utils/cdk/gdstubs.o: undefined reference to symbol 'png_access_version_number@@PNG15_0'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: note: 'png_access_version_number@@PNG15_0' is defined in DSO /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../lib64/ so try adding it to the linker command line
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../lib64/ could not read symbols: Invalid operation
collect2: ld returned 1 exit status
distcc[1438] ERROR: compile (null) on localhost failed
File "caml_startup", line 1, characters 0-1:
Error: Error during linking
make: *** [mlnet] Error 2
emake failed

emerge --info
Portage (default/linux/amd64/10.0/server, gcc-4.5.3, glibc-2.15-r2, 2.6.32-openvz-feoktistov.1 x86_64)
System uname: Linux-2.6.32-openvz-feoktistov.1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Tue, 14 Aug 2012 23:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo x-portage
CFLAGS="-march=nocona -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=nocona -O2 -pipe"
EMERGE_DEFAULT_OPTS="--with-bdeps y --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg ccache config-protect-if-modified distcc distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="a52 aac acl acpi alsa amd64 apache2 audiofile bash-completion berkdb bmp bzip2 caps cdb cdparanoia cdr cli cracklib crypt ctype cups cxx dedicated dvd dvdr dvdread encode exif fam ffmpeg flac foomaticdb ftp gd geoip gif iconv icq idn imagemagick imap imlib innodb iodbc jabber jbig jpeg lcms ldap lm_sensors mad maildir matroska mbox mcal mime mmx mng modules mp3 mpeg msn mudflap multilib mysql mysqli ncurses nls nptl nptlonly odbc ogg openmp oscar pam pcre php png posix ppds pppd prelude readline samba sasl scanner sdl session sharedext simplexml slang slp snmp speex spell spl sse sse2 ssl tcpd theora tiff truetype unicode usb v4l vhosts vorbis wmf xml xsl xvid yahoo zlib" ALSA_CARDS="snd-intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard" KERNEL="linux" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 5 Pacho Ramos gentoo-dev 2016-01-30 17:56:08 UTC
What is the status of this on a fully updated system?
Comment 6 Konstantin Agouros 2016-01-31 09:17:23 UTC
If I try it it wants to install ocaml-obj in the mldonkey directory asks me if I want that and whatever I enter it does not react.