Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 391215 - gnome-base/librsvg-2.34.2 fails with parallel build
Summary: gnome-base/librsvg-2.34.2 fails with parallel build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-21 11:03 UTC by Justin Lecher
Modified: 2011-11-23 23:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/log/portage/build/gnome-base/librsvg-2.34.2:20111121-110119.log (librsvg-2.34.2:20111121-110119.log,36.81 KB, text/plain)
2011-11-21 11:04 UTC, Justin Lecher
Details
/var/log/portage/build/gnome-base/librsvg-2.34.2:20111121-131604.log (librsvg-2.34.2:20111121-131604.log,62.02 KB, text/plain)
2011-11-21 13:21 UTC, Justin Lecher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher gentoo-dev 2011-11-21 11:03:36 UTC
I don't know where the error comes from

x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I. -I. -DLIBRSVG_DATADIR="\"/usr/share\""   -pthread -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng15 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm   -I/usr/include/libcroco-0.6 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2   -DHAVE_LIBCROCO=1   -O2 -pipe -ftracer -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 -mtune=corei7 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g -Wimplicit-function-declaration -c -o rsvg_convert-rsvg-convert.o `test -f 'rsvg-convert.c' || echo './'`rsvg-convert.c
  CC     librsvg_2_la-librsvg-enum-types.lo
/bin/sh ./libtool --silent --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I. -I. -DG_LOG_DOMAIN=\"librsvg\" -DLIBRSVG_DATADIR="\"/usr/share\""   -pthread -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng15 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm   -I/usr/include/libcroco-0.6 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2   -DHAVE_LIBCROCO=1   -O2 -pipe -ftracer -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 -mtune=corei7 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g -Wimplicit-function-declaration -c -o librsvg_2_la-librsvg-enum-types.lo `test -f 'librsvg-enum-types.c' || echo './'`librsvg-enum-types.c
  GISCAN Rsvg-2.0.gir
/usr/include/glib-2.0/glib/gthread.h:347: syntax error, unexpected '{' in '  if ((gpointer) (__extension__ ({ G_STATIC_ASSERT (sizeof *(value_location) == sizeof (gpointer)); __sync_synchronize (); (gpointer) *(value_location); })) != ((void *)0))' at '{'
libtool: link: cannot find the library `librsvg-2.la' or unhandled argument `librsvg-2.la'
linking of temporary binary failed: Command '['/bin/sh', './libtool', '--mode=link', '--tag=CC', '--silent', 'gcc', '-o', '/var/tmp/portage/gnome-base/librsvg-2.34.2/work/librsvg-2.34.2/tmp-introspect1dXnku/Rsvg-2.0', '-export-dynamic', '-O2', '-pipe', '-ftracer', '-march=corei7', '-mcx16', '-msahf', '-mpopcnt', '-msse4.2', '-mtune=corei7', '--param', 'l1-cache-size=32', '--param', 'l1-cache-line-size=64', '--param', 'l2-cache-size=8192', '-mtune=corei7', '-frecord-gcc-switches', '-g', '-Wimplicit-function-declaration', '-L.', 'librsvg-2.la', '-pthread', '-lgio-2.0', '-lpango-1.0', '-lgobject-2.0', '-lgmodule-2.0', '-lgthread-2.0', '-lrt', '-lglib-2.0', '-lxml2', '/var/tmp/portage/gnome-base/librsvg-2.34.2/work/librsvg-2.34.2/tmp-introspect1dXnku/Rsvg-2.0.o']' returned non-zero exit status 1
make[2]: *** [Rsvg-2.0.gir] Error 1
Comment 1 Justin Lecher gentoo-dev 2011-11-21 11:04:04 UTC
Portage 2.2.0_alpha76 (default/linux/amd64/10.0, gcc-4.6.2-asneeded, glibc-2.13-r4, 3.1.1-lh x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.1.1-lh-x86_64-Intel-R-_Core-TM-_i7_CPU_860_@_2.80GHz-with-gentoo-2.1
Timestamp of tree: Mon, 21 Nov 2011 07:00:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.5.4-r4, 2.6.7-r2, 2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.2.4-r1, 4.3.6-r1, 4.4.6-r1, 4.5.3-r1, 4.6.2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise bicatali betagarden dummy neurogeek science last-hope g-ctan
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ftracer -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 -mtune=corei7 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g -Wimplicit-function-declaration"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/eselect/ /usr/share/gnupg/qualified.txt /usr/share/nano/ /usr/share/openvpn/easy-rsa /var/lib/hsqldb /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -ftracer -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 -mtune=corei7 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g -Wenum-compare"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-t --jobs=12 --load-average=12 --keep-going --autounmask-write --autounmask --quiet-build=n"
FEATURES="assume-digests binpkg-logs buildsyspkg ccache collision-protect distlocks ebuild-locks fixlafiles metadata-transfer multilib-strict news noinfo parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms sign split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe -ftracer -march=corei7 -mcx16 -msahf -mpopcnt -msse4.2 -mtune=corei7 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=corei7 -frecord-gcc-switches -g"
GENTOO_MIRRORS=" /mnt/tmpfs/ http://gentoo.j-schmitz.net/mirror/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common"
LINGUAS="en"
MAKEOPTS="-j16 -l12"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-z -e -9 -v"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/data/local/sunrise/reviewed /data/local/bicatali /data/local/betagarden /data/local/dummy /data/local/neurogeek /data/local/sci /data/local/lh/ebuilds /data/local/g-ctan"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit 7zip X acpi additions alsa amd64 arpwarp atlas bash-completion berkdb blas branding bzip2 c++ cairo caps cblas ccache cleartype cli command-args consolekit corefonts cracklib crypt cuda cups cupsddk custom-optimization cxx dbus dri dts exif fbcondecor fortran gdbm gif glib glibc-omitfp gmp gnome gnome-keyring gpm graphics gstreamer gtk hddtemp iconv icu ios ipod iproute2 iptables ipv6 ipython javascript jpeg jpeg2k kqemu lapack largefile lcms ldap libnotify libsexy lm_sensors lzma mailtrain md5sum mmx mmxext mng modules mp3 mudflap multilib multiuser nagios-dns nagios-ntp nagios-ping nagios-ssh nano-syntax ncurses network-cron nis nls nptl nptlonly nsplugin objc objc++ opencl opengl openmp openntpd pam pcre pdf png policykit pppd pymol qt-static qt3support readline rrdcgi rrdtool science sensord session smp sqlite sqlite3 sse sse2 sse3 sse4 sse4a sse5 ssl startup-notification svg sysfs system-sqlite tcpd threads tiff truetype type1 udev unicode vaapi vdpau x264 xcb xcomposite xinerama xorg xulrunner zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Justin Lecher gentoo-dev 2011-11-21 11:04:24 UTC
Created attachment 293291 [details]
/var/log/portage/build/gnome-base/librsvg-2.34.2:20111121-110119.log

build.log
Comment 3 Pacho Ramos gentoo-dev 2011-11-21 11:23:58 UTC
That syntax error message looks "normal" with glib-2.30.2. On the other hand, I would try to rebuild this with MAKEOPTS="-j1" due:

libtool: link: cannot find the library `librsvg-2.la' or unhandled argument `librsvg-2.la'
Comment 4 Rafał Mużyło 2011-11-21 11:49:16 UTC
Just a guess, but it might be again that little thing, that makes introspection stuff link with live system, instead of the just built stuff - mind attaching a V=1 log ?
Comment 5 Justin Lecher gentoo-dev 2011-11-21 13:21:50 UTC
Created attachment 293303 [details]
/var/log/portage/build/gnome-base/librsvg-2.34.2:20111121-131604.log

V=1 build.log
Comment 6 Justin Lecher gentoo-dev 2011-11-21 13:23:07 UTC
(In reply to comment #3)
> That syntax error message looks "normal" with glib-2.30.2. On the other hand, I
> would try to rebuild this with MAKEOPTS="-j1" due:
> 
> libtool: link: cannot find the library `librsvg-2.la' or unhandled argument
> `librsvg-2.la'

Fixed it. Sorry for not considering this before.
Comment 7 Pacho Ramos gentoo-dev 2011-11-21 19:50:46 UTC
Well, in my case it doesn't fail with -j5, maybe it tends to fail more with higher values. Looking at changes between 2.34.2 and 2.34.1, I only would point to Makefile.am changes introduced in:
http://git.gnome.org/browse/librsvg/commit/?h=gnome-3-2&id=e22c4adc8cd46750a6e7c4e0cc1471936258c8ed

But, personally, I don't know what is wrong with it, if no other gnome team members knows, maybe you should report this to upstream also
Comment 8 Sebastian Pipping gentoo-dev 2011-11-21 19:58:33 UTC
(In reply to comment #7)
> Well, in my case it doesn't fail with -j5, maybe it tends to fail more with
> higher values.

It fails with -j3 here.
Comment 9 Pacho Ramos gentoo-dev 2011-11-21 23:40:59 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Well, in my case it doesn't fail with -j5, maybe it tends to fail more with
> > higher values.
> 
> It fails with -j3 here.

Looks much more robust for me :S

If you are able to reproduce when manually compiling from upstream sources, please report to upstream and post link here. Thanks
Comment 10 Rafał Mużyło 2011-11-23 13:28:31 UTC
OK:

1. I suspect bug 391213 might be somehow related to this bug.

2. It seems that there's a simple (and valid upstream) fix for this bug:
in Makefile.am, change
Rsvg-@RSVG_API_VERSION_U@.gir: librsvg-@RSVG_API_MAJOR_VERSION@.la
to:
Rsvg-@RSVG_API_VERSION@.gir: librsvg-@RSVG_API_MAJOR_VERSION@.la
Comment 11 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-11-23 23:08:42 UTC
(In reply to comment #10)
Thank you, that seems to be exactly correct. Should be fixed now (without revision bump, since people who succeeded in building librsvg should not need to rebuild it). Upstream bug filed at https://bugzilla.gnome.org/show_bug.cgi?id=664684

>  23 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
>  librsvg-2.34.2.ebuild, +files/librsvg-2.34.2-gir-filename.patch:
>  Add patch to fix parallel make failure when USE=introspection; many thanks to
>  Rafał Mużyło <galtgendo@o2.pl> for the solution (bug #391215). Should also
>  fix bug #391213. Thanks to all for reporting.