Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 390829 - sys-fs/multipath-tools-0.4.8-r1: Problem with init.d script
Summary: sys-fs/multipath-tools-0.4.8-r1: Problem with init.d script
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-17 13:02 UTC by Marek Królikowski
Modified: 2016-08-05 18:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Królikowski 2011-11-17 13:02:40 UTC
When i try do /etc/init.d/multipath stop i get always failed but he stop multipath.

Reproducible: Always

Steps to Reproduce:
1. /etc/init.d/multipath start
2. /etc/init.d/multipath stop

Actual Results:  
POCZTA2 ~ # /etc/init.d/multipath stop
 * WARNING: you are stopping a boot service
 * Shutting down Multipath devices ...
 * Failed to shut down Multipath devices                                                                                                                                                                                               [ !! ]
 * ERROR: multipath failed to stop


Expected Results:  
Stop with error

The most funny script working good but show error:
POCZTA2 ~ # ls -al /dev/mapper/EMC
ls: nie ma dostępu do /dev/mapper/EMC: Nie ma takiego pliku ani katalogu
POCZTA2 ~ # /etc/init.d/multipath start
 * Activating Multipath devices ...                                                                                                                                                                                                    [ ok ]
POCZTA2 ~ # ls -al /dev/mapper/EMC
brw------- 1 root root 253, 0 11-17 13:53 /dev/mapper/EMC
POCZTA2 ~ # /etc/init.d/multipath stop
 * WARNING: you are stopping a boot service
 * Shutting down Multipath devices ...
 * Failed to shut down Multipath devices                                                                                                                                                                                               [ !! ]
 * ERROR: multipath failed to stop
POCZTA2 ~ # ls -al /dev/mapper/EMC
ls: nie ma dostępu do /dev/mapper/EMC: Nie ma takiego pliku ani katalogu

Looks like script working because delete /dev/mapper/EMC device 


Soo look at debug:
POCZTA2 ~ # ls -al /dev/mapper/EMC
brw------- 1 root root 253, 0 11-17 13:59 /dev/mapper/EMC
POCZTA2 ~ # /etc/init.d/multipath -d stop
 * WARNING: you are stopping a boot service
+ _conf_d=/etc/init.d/../conf.d
+ _c=multipath
+ '[' -n multipath -a multipath '!=' multipath ']'
+ unset _c
+ sourcex -e /etc/init.d/../conf.d/multipath.default
+ '[' -e = -e ']'
+ shift
+ '[' -e /etc/init.d/../conf.d/multipath.default ']'
+ return 1
+ sourcex -e /etc/init.d/../conf.d/multipath
+ '[' -e = -e ']'
+ shift
+ '[' -e /etc/init.d/../conf.d/multipath ']'
+ return 1
+ unset _conf_d
+ sourcex -e /etc/rc.conf
+ '[' -e = -e ']'
+ shift
+ '[' -e /etc/rc.conf ']'
+ . /etc/rc.conf
++ rc_shell=/sbin/sulogin
++ unicode=YES
++ rc_sys=
++ rc_tty_number=12
+ '[' -n '' ']'
+ sourcex /etc/init.d/multipath
+ '[' /etc/init.d/multipath = -e ']'
+ . /etc/init.d/multipath
++ check_bl2_file=/etc/init.d/sysfs
+ unset _d
+ unset _f
+ '[' -n stop ']'
+ '[' stop = depend ']'
+ for _cmd in describe start stop status '${extra_commands:-$opts}' '$extra_started_commands'
+ '[' describe = stop ']'
+ for _cmd in describe start stop status '${extra_commands:-$opts}' '$extra_started_commands'
+ '[' start = stop ']'
+ for _cmd in describe start stop status '${extra_commands:-$opts}' '$extra_started_commands'
+ '[' stop = stop ']'
++ command -v stop
+ '[' stop = stop ']'
+ yesno
+ '[' -z '' ']'
+ return 1
+ unset _cmd
++ command -v stop_pre
+ '[' '' = stop_pre ']'
+ stop
+ run_addon multipath-stop
+ local f=/lib/rcscripts/addons/multipath-stop.sh
+ '[' -r /lib/rcscripts/addons/multipath-stop.sh ']'
+ . /lib/rcscripts/addons/multipath-stop.sh
++ '[' -x /sbin/multipath -a dm_in_proc ']'
++ ebegin 'Shutting down Multipath devices'
 * Shutting down Multipath devices ...
++ /sbin/multipath -v0 -F
++ retval=1
++ eend 1 'Failed to shut down Multipath devices'
 * Failed to shut down Multipath devices                                                                                                                                                                                               [ !! ]
+ exit 1
 * ERROR: multipath failed to stop

So he do: /sbin/multipath -a dm_in_proc
so i try do this from shell:
POCZTA2 ~ # /sbin/multipath -a dm_in_proc
Unknown switch: (null)
multipath-tools v0.4.8 (08/02, 2007)
Usage: /sbin/multipath  [-v level] [-d] [-h|-l|-ll|-f|-F]
                        [-p failover|multibus|group_by_serial|group_by_prio]
                        [device]

        -v level        verbosity level
           0                    no output
           1                    print created devmap names only
           2                    default verbosity
           3                    print debug information
        -h              print this usage text
        -b file         bindings file location
        -d              dry run, do not create or update devmaps
        -l              show multipath topology (sysfs and DM info)
        -ll             show multipath topology (maximum info)
        -f              flush a multipath device map
        -F              flush all multipath device maps
        -p policy       force all maps to specified policy :
           failover             1 path per priority group
           multibus             all paths in 1 priority group
           group_by_serial      1 priority group per serial
           group_by_prio        1 priority group per priority lvl
           group_by_node_name   1 priority group per target node

        device          limit scope to the device's multipath
                        (udev-style $DEVNAME reference, eg /dev/sdb
                        or major:minor or a device map name)
Comment 1 Jeroen Roovers gentoo-dev 2011-11-17 15:52:30 UTC
- ls: nie ma dostępu do /dev/mapper/EMC: Nie ma takiego pliku ani katalogu
+ ls: cannot access /dev/mapper/EMC: No such file or directory
Comment 2 Marek Królikowski 2011-11-17 15:55:55 UTC
A sorry this is Polish Lang.
But like You see - script working good - he shut down Multipath devices because this device stop exist but he say: ERROR: multipath failed to stop
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2016-08-05 18:35:57 UTC
We don't ship /lib/rcscripts/addons/multipath* anymore