Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 390233 - media-tv/tvtime : request for patch merge (for wide monitors)
Summary: media-tv/tvtime : request for patch merge (for wide monitors)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Television related Applications in Gentoo's Portage
URL: http://imageshack.us/photo/my-images/...
Whiteboard:
Keywords:
Depends on: 424289
Blocks:
  Show dependency tree
 
Reported: 2011-11-12 02:36 UTC by Vasiliy Temnikov
Modified: 2013-08-02 19:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
tvtime-16-9.patch (tvtime-16-9.patch,1.27 KB, patch)
2011-11-12 11:08 UTC, Vasiliy Temnikov
Details | Diff
new patch (tvtime-16-9.patch,1.27 KB, patch)
2011-11-14 06:57 UTC, Vasiliy Temnikov
Details | Diff
sorry guys, it is better version of patch. Now saving value "Matte" in config and working "Overscan" (tvtime-16-9.patch,4.27 KB, patch)
2011-11-15 00:33 UTC, Vasiliy Temnikov
Details | Diff
no problems here (tvtime-1.0.2_p20110131-r3.png,862.36 KB, image/png)
2013-04-09 21:33 UTC, markus wolff
Details
this screenshot of tvtime with apply this patch (tvtime.png,611.29 KB, text/plain)
2013-04-09 22:43 UTC, Vasiliy Temnikov
Details
osd hiding problem (test.png,756.52 KB, image/png)
2013-04-17 22:43 UTC, markus wolff
Details
4:3 matte. (with my patch) (4_3.png,424.53 KB, text/plain)
2013-04-23 20:06 UTC, Vasiliy Temnikov
Details
16:9 matte. (with my patch) (16_9.png,491.85 KB, text/plain)
2013-04-23 20:07 UTC, Vasiliy Temnikov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vasiliy Temnikov 2011-11-12 02:36:21 UTC
see http://imageshack.us/photo/my-images/443/73569858oa.jpg/
up image is after patch
bottom image is before patch

on my 16:9 monitor i am not see title channel, time and volume, because is hidden in 16:9 or 16:10 mode.

this patch fixed it.
for 16:10 monitors you may changed some digest in this file.

add this patch as flag USE ("fix_osd_for_16_9_monitors") for tvtime ebuild.

--- src/tvtime.c	2011-11-10 20:23:34.000000000 +0400
+++ src/tvtime.c	2011-11-10 20:23:45.000000000 +0400
@@ -1201,10 +1201,10 @@
     deinterlace_method_t *curmethod;
     int curmethodid;
     int matte_x = 0;
-    int matte_w = 0;
-    int matte_y = 0;
-    int matte_h = 0;
-    int matte_mode = 0;
+    int matte_w = 720;
+    int matte_y = 72;  /* for 16:9 = 72 ; for 16:10 = 48 */
+    int matte_h = 432;  /* for 16:9 = 432 ; for 16:10 = 480 */
+    int matte_mode = 1;  /* for 16:9 = 1 ; for 16:10 = 2 */
     int restarttvtime = 0;
     int return_value = 0;
     int last_current_id = -1;
@@ -1581,6 +1581,9 @@
     build_fspos_menu( commands_get_menu( commands, "fspos" ),
                       config_get_fullscreen_position( ct ) );

+    output->set_matte( 720, 432 );  /* for 16:9 = ( 720, 432 ) ; for 16:10 = ( 720, 480 ) */
+    output->set_window_height( output->get_visible_height() );
+
     /* Initialize our timestamps. */
     for(;;) {
         const char *fifo_args = 0;
--- src/tvtimeosd.c	2011-11-10 20:21:35.000000000 +0400
+++ src/tvtimeosd.c	2011-11-10 20:20:55.000000000 +0400
@@ -141,7 +141,7 @@
     unsigned int other_b;
 };

-const int top_size = 7;
+const int top_size = 14;
 const int left_size = 7;
 const int left_inner_size = 10;
 const int bottom_size = 13;

Reproducible: Always

Steps to Reproduce:
start tvtime is : 
tvtime --window & sleep 1.5 && tvtime-command SET_MATTE 16:9 AUTO_ADJUST_WINDOW
or
start tvtime and press "Insert" key for 16:9 mode screen.
Comment 1 Vasiliy Temnikov 2011-11-12 11:08:21 UTC
Created attachment 292269 [details, diff]
tvtime-16-9.patch

patch
Comment 2 Vasiliy Temnikov 2011-11-14 06:57:10 UTC
Created attachment 292469 [details, diff]
new patch
Comment 3 Vasiliy Temnikov 2011-11-14 06:57:53 UTC
+    output->set_matte( 720, 432 );  /* for 16:9 = ( 720, 432 ) ; for 16:10 = (
720, 480 ) */

right to:

+    output->set_matte( 768, 432 );  /* for 16:9 = ( 768, 432 ) ; for 16:10 = (
768, 480 ) */
Comment 4 Vasiliy Temnikov 2011-11-15 00:33:44 UTC
Created attachment 292575 [details, diff]
sorry guys, it is better version of patch. Now saving value "Matte" in config and working "Overscan"
Comment 5 markus wolff 2013-04-09 21:33:35 UTC
Created attachment 345024 [details]
no problems here

using that program for years now. Never had anything like it?
Comment 6 Vasiliy Temnikov 2013-04-09 22:43:12 UTC
Created attachment 345030 [details]
this screenshot of tvtime with apply this patch

If tv ratio is 16:9
Image is not compressed vertically.
Tvtime window's frame without black bars and resized.
Info messages puts on the screen, but not on black bars.

markus wolff
You image is compressed vertically.
You can do as well as I have in the screenshot?

this patch do Image is not compressed vertically.
Comment 7 markus wolff 2013-04-17 22:43:47 UTC
Created attachment 345838 [details]
osd hiding problem

after finding out what all this could mean...
i could reproduce it and found the patch working.

off topic, but...which genius called that "matte" ? 
isn't that function not usually referred as "aspect-ratio"? 
likewise "16:9  output" -> widescreen
Comment 8 markus wolff 2013-04-23 18:40:10 UTC
since the issue is fixed...

Vasiliy...can you perhaps set this to resolved? 

or who can?
Comment 9 Vasiliy Temnikov 2013-04-23 20:06:59 UTC
Created attachment 346400 [details]
4:3 matte. (with my patch)
Comment 10 Vasiliy Temnikov 2013-04-23 20:07:24 UTC
Created attachment 346402 [details]
16:9 matte. (with my patch)
Comment 11 Vasiliy Temnikov 2013-04-23 20:11:08 UTC
which genius called that "matte" ? 

see these two are screenshots
 4:3 matte. (with my patch)
and
 16:9 matte. (with my patch)

or press key "Insert" to change matte
Comment 12 Samuli Suominen gentoo-dev 2013-08-02 19:23:19 UTC
media-tv/tvtime was removed from portage wrt bug #424289