Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 389511 - net-mail/courier-imap version bump
Summary: net-mail/courier-imap version bump
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: David Heidelberg (okias)
: 412165 (view as bug list)
Depends on:
Blocks: 421431
  Show dependency tree
Reported: 2011-11-04 16:30 UTC by Alexander Wright
Modified: 2014-11-21 10:05 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

courier-imap-4.14.ebuild (courier-imap-4.14.ebuild,7.22 KB, text/plain)
2013-11-13 19:34 UTC, Konstantin Münning
courier-imap-4.14 (courier-imap.tar.bz2,12.32 KB, application/x-bzip2)
2013-11-22 10:21 UTC, Per Pomsel
courier-imap-4.15 ebuild + patches (courier-imap-4.15.tar.bz2,4.19 KB, application/x-bzip2)
2014-01-13 12:17 UTC, Per Pomsel
automake-2.out_error.txt (automake-2.out,225 bytes, text/plain)
2014-01-13 16:53 UTC, David Heidelberg (okias)
courier-imap-4.15.diff (courier-imap.diff,2.89 KB, patch)
2014-01-13 17:16 UTC, David Heidelberg (okias)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Wright 2011-11-04 16:30:44 UTC
Courier-imap version 4.9.3 has been available since May.
(see )

The 4.8.0 ebuild works correctly when renamed to courier-imap-4.9.3.ebuild with no further changes.

Reproducible: Always

Steps to Reproduce:
1. emerge =net-mail/courier-imap-4.9.3

Actual Results:  
No such version

Expected Results:  
Latest version emerged.
Comment 1 Pacho Ramos gentoo-dev 2013-07-27 08:00:15 UTC
*** Bug 412165 has been marked as a duplicate of this bug. ***
Comment 2 Steve Yin 2013-10-22 04:11:31 UTC
why bump to a older version while there is much more newer version exists?


the most recent version of courier-imap is 4.14, and 4.9.3 was released two years ago.
Comment 3 Didier Barvaux 2013-10-22 07:03:01 UTC
(In reply to Steve Yin from comment #2)
> why bump to a older version while there is much more newer version exists?
> see
> the most recent version of courier-imap is 4.14, and 4.9.3 was released two
> years ago.

Bug is 2 year old.
Comment 4 Alexander Wright 2013-10-23 11:35:16 UTC
Since I raised it: I can confirm that courier-imap-4.14 needs work on the patches to get it to compile.

Any help available here?
Comment 5 Konstantin Münning 2013-11-13 19:34:30 UTC
Created attachment 363206 [details]


Since after last update imapd-ssl started producing *** glibc detected *** /usr/sbin/couriertls: malloc(): memory corruption errors. As nothing seemed to help and courier-imap-4.8.0-r1 does not compile with gnutls-3.2.4 I had to try a newer version. I took the 4.8.0-r1-ebuild and with only a few changes it did compile and runs flawless since then. Most notable change needed to make it install was to adapt some paths in the ebuild like imap -> libs/imap. I didn't do much flags testing but everything worked out of the box on my setup. Maybe somebody wants to try, please see attached ebuild :-).
Comment 6 Per Pomsel 2013-11-22 10:20:32 UTC
My ebuild uses the provided (old) patches (which were rewriten by me). I'm not sure if the old patches are still required (especially the db4 patches).
On a smp machine I had to use MAKEOPTS='-j1' to avoid automake errors.
Comment 7 Per Pomsel 2013-11-22 10:21:10 UTC
Created attachment 363790 [details]
Comment 8 Pacho Ramos gentoo-dev 2014-01-01 18:56:33 UTC
4.15 released for some time, also fixes long standing gnutls-3 compat issues
Comment 9 David Heidelberg (okias) 2014-01-11 02:18:13 UTC
So for 

src_prepare() {

***** automake *****
***** PWD: /var/tmp/portage/net-mail/courier-imap-4.15/work/courier-imap-4.15/libs/rfc2045
***** automake --add-missing --copy --foreign error: required file '../../' not found

Otherwise it pass, noone inteligent should try install net-mail/courier-imap-4.15::ixit but I'd like see some ideas, improvments (if someone will want improve this, I'll give you access directly to overlay, and then it could be pushed into gx86)
Comment 10 Per Pomsel 2014-01-13 12:17:16 UTC
Here are my files for courier-imap-4.15.
Comment 11 Per Pomsel 2014-01-13 12:17:56 UTC
Created attachment 367784 [details]
courier-imap-4.15 ebuild + patches
Comment 12 David Heidelberg (okias) 2014-01-13 16:53:12 UTC
Created attachment 367796 [details]

@phantom4 I getting this errors for your ebuild, maybe it's some my issue with automake ?

Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.2, glibc-2.18, 3.12.7-mptcp x86_64)
System uname: Linux-3.12.7-mptcp-x86_64-AMD_A8-3870_APU_with_Radeon-tm-_HD_Graphics-with-gentoo-2.2
KiB Mem:     7658996 total,    936280 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sun, 12 Jan 2014 14:00:01 +0000
ld GNU ld (GNU Binutils) 2.24
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.2.5-r3, 3.3.3
dev-util/ccache:          3.1.9-r3
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r2::FireBurn
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24
sys-devel/gcc:            4.7.3-r1, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1::ixit
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.18
Repositories: gentoo x11 pentoo kde gamerlay qt ixit toolchain hasufell enlightenment crossdev
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O3 -fno-tree-vectorize -march=native -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O3 -fno-tree-vectorize -march=native -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news nodoc noinfo noman parallel-fetch protect-owned sandbox sfperms sign strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/pentoo /var/lib/layman/kde /var/lib/layman/gamerlay /var/lib/layman/qt /var/lib/layman/ixit /var/lib/layman/toolchain /var/lib/layman/hasufell /var/lib/layman/enlightenment /var/lib/layman/crossdev"
USE="3dnow 3dnowext X a52 aac acpi adobe-cff amd64 aspell berkdb branding bzip2 cairo cdda clang cli cracklib crypt custom-optimization cxx dbus declarative dhcpcd djvu dri drm dts dvd dvdr egl embedded emboss emotion encode ethumb exif fam fftw firefox flac fontconfig fpm gallium gbm gdbm geoip gif git gles gles2 glew gnutls google graphite gtk3 iconv inotify int-quality ipv6 jabber jpeg kde kdepim kipi lcms libass libkms libnl libnotify llvm lm_sensors lto lzma lzo mad minizip mmx mmxext mng modules mp3 mp4 mpeg mpg123 mudflap multilib multimedia multiseat ncurses nfsv41 nine nls nptl offensive ogg openal opencl opengl openmp openssl osmesa pam pam_ssh pango pcre pdf phonon plasma png policykit ppds projectm pulseaudio python python3 qalculate qml qt3support qt4 qt5 quicklaunch r600-llvm-compiler readline reviewboard scrypt semantic-desktop session smp spell sse sse2 sse3 ssl startup-notification subversion svg symlink system-cairo system-icu system-jpeg systemd tcpd telepathy theora threads thumbnail tiff truetype udev udisks ukit unicode upower usb vdpau video vorbis wayland webkit webm webp wxwidgets x264 xcb xcomposite xdg xinerama xkb xlib-xcb xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="words tables krita sheets stage" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" ENLIGHTENMENT_MODULES="clock comp conf-applications conf-dialogs conf-display conf-edgebindings conf-interaction conf-intl conf-keybindings conf-menus conf-paths conf-performance conf-randr conf-shelves conf-theme conf-window-manipulation conf-window-remembers cpufreq dropshadow everything fileman fileman-opinfo gadman ibar ibox illume2 mixer msgbus notification pager quickaccess start syscon systray tasks temperature tiling winlist wizard xkbswitch" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="cs" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_conn limit_req map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi geoip spdy" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 pypy2_2" QEMU_SOFTMMU_TARGETS="x86_64 arm i386" QEMU_USER_TARGETS="x86_64 arm i386" RUBY_TARGETS="ruby20" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 13 David Heidelberg (okias) 2014-01-13 17:03:18 UTC
I had set MAKEOPTS="-j5" - never worked with eautoreconf

MAKEOPTS="-j1" - work fine! So, we need force this package to -j1 OR fix it :)
Comment 14 David Heidelberg (okias) 2014-01-13 17:13:13 UTC
so I incorporated all changes (thanks @phantom4) and courier-imap-4.15::ixit should be fully usable, as previous version. Tested in production.
Comment 15 David Heidelberg (okias) 2014-01-13 17:16:58 UTC
Created attachment 367798 [details, diff]

Please review (changes against portage 4.8.0-r1), patches in @phantom4 tarball.
Comment 16 David Heidelberg (okias) 2014-02-04 01:16:19 UTC
all work is done here. Just push it ^
Comment 17 Manuel Rüger (RETIRED) gentoo-dev 2014-04-23 23:05:15 UTC
*courier-imap-4.15 (23 Apr 2014)

  23 Apr 2014; Manuel Rüger <> +courier-imap-4.15.ebuild,
  +files/, metadata.xml:
  Version bump. Updated patches by Per Pomsel. Add David Heidelberger as proxied
  maintainer. Fixes bug #389511.
Comment 18 SpanKY gentoo-dev 2014-11-21 10:05:49 UTC
(In reply to David Heidelberg (okias) from comment #13)

should be fixed now; see bug 529404 for details

i've dropped the MAKEOPTS=-j1 logic from the ebuild