Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 388535 - [Feature Request] layman add webrsync functionality
Summary: [Feature Request] layman add webrsync functionality
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christian Ruppert (idl0r)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-26 11:31 UTC by Sergey S. Starikoff
Modified: 2011-12-03 00:15 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey S. Starikoff 2011-10-26 11:31:47 UTC
One of my Gentoo workstations I use in a private network (with restricted network access, via auth-requires proxy server).
For main portage tree after redefining FETCH_CMD and RESUME_CMD everything (starting from portage tree syncronization up to software installation) needed works well.
But. I would like to use also some packages from layman-managed overlays.
The issue is that for layman base protocols (git/cvs/etc) network is unavailable.

I suggest to extend layman with (possibly optional) layman-webrsync utility (similiar to portage's emerge-webrsync, the only difference in managed trees) together with providing layman-overlays snapshot-spreading infrastructure (I'm not shure about the best way of it's organization).
Comment 1 Brian Dolbec gentoo-dev 2011-10-26 15:15:38 UTC
Layman is already capable of a webrsync type overlay already.  It would be a tar type overlay which is capable of a bz2 download and decompress.  The problem you would have is that the overlay supplier would need to generate the webrsync file for it to download.  You could if you wanted, have layman do a webrsync for the main gentoo tree, instead of emerge.  You just need to create the xml definition it needs to know where to get it.  The only difference is that it would install it to /var/lib/layman instead.  That can also be changed in /etc/layman/layman.cfg.

As for the other types of overlays available to layman, the majority are git based which can use an http protocol.  Layman will automatically cycle through the listed urls for the overlay until one succeeds or it runs out of urls.  Most of the overlays hosted on gentoo servers already have the http protocol urls listed in the overlay definition.  Those that do not are capable, so you just need to contact the overlay maintainer/file a bug to add that http protocol url.  For other git overlays not hosted by gentoo servers, some are also capable of the http protocol, some already list that url, some don't.  Again, contact the overlay maintainer to have that protocol url added to their definition.
Comment 2 Brian Dolbec gentoo-dev 2011-12-03 00:15:53 UTC
I'm going to close this bug, because as I stated, layman can already do a webrsync type overlay.

I am marking it as upstream, since the overlay provider would need to generate the  the needed .bz2 for it to sync with.