Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 388425 - app-emulation/wine-1.6 sound not working, several apps stopped working.
Summary: app-emulation/wine-1.6 sound not working, several apps stopped working.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Wine Maintainers
Depends on:
Reported: 2011-10-25 10:47 UTC by Juanlu Pérez
Modified: 2015-03-15 02:47 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Juanlu Pérez 2011-10-25 10:47:28 UTC
I had some problems between libpng and wine, I looked at bugzilla and it says those were solved, but, wine-1.3.30 is not working for me at all.

$ winecfg
err:mmdevapi:DllGetClassObject Driver initialization failed
err:ole:apartment_getclassobject DllGetClassObject returned error 0x80004005
err:ole:CoGetClassObject no class object {bcde0395-e52f-467c-8e3d-c4579291692e} could be created for context 0x1

Reproducible: Always
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-10-25 13:50:00 UTC
Please post your `emerge --info app-emulation/wine' output too.
Comment 2 Juanlu Pérez 2011-10-25 20:28:10 UTC
# emerge --info app-emulation/wine
Portage (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.12.2-r0, 3.0.6-gentoo x86_64)
                        System Settings
System uname: Linux-3.0.6-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-gentoo-2.0.3
Timestamp of tree: Tue, 25 Oct 2011 03:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            3.4.6-r2, 4.4.5, 4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo My-Local-Overlay sunrise betagarden
CFLAGS="-march=athlon64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="es es_ES en en_US"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/sunrise /var/lib/layman/betagarden"
USE="3dnow X X509 a52 aac acl acpi alsa amd64 applet asf avahi bash-completion berkdb bluetooth branding bzip2 cairo ccache cdda cdr cdrw cgi cjk cli consolekit cracklib crypt css cups cxx daap dbus device-mapper directfb divx dri dts dvd dvdr dvdread eds emboss encode esd evo exif fam fat fbcon ffmpeg firefox flac foomaticdb fortran fuse gd gdbm gdu gedit gif gmedia gnome gnome-keyring gnutls gpm gstreamer gtk hal iconv icu imagemagick ipod jabber java javascript jingle jpeg keyring lame lcms ldap libnotify lm_sensors lzo mad matroska mikmod mmx mng modules mono mp3 mp4 mpeg msn mtp mudflap multilib musicbrainz mysql mysqli nautilus ncurses network-cron networkmanager nls nptl nptlonly nsplugin ntfs ntfsprogs ntp nvidia ogg ogm openal opengl openmp oss pam pango pcre pdf pidgin png policykit ppds pppd pulseaudio python qt3support qt4 quicktime readline realmedia samba sdl session sip slang spell sqlite srt sse sse2 ssl startup-notification svg sysfs taglib tagwriting tcpd theora threads tiff truetype udev unicode usb v4l v4l2 vcd vorbis wav wma wmp x264 xattr xcb xinerama xml xorg xrandr xulrunner xv xvid zeroconf zlib" ALSA_CARDS="hda-intel ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en en_US" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

app-emulation/wine-1.3.30 was built with the following:
USE="X alsa cups dbus fontconfig gecko gnutls gsm jpeg lcms ldap mp3 (multilib) ncurses nls openal opengl oss perl png samba ssl threads truetype v4l win32 win64 xcomposite xinerama xml -capi -custom-cflags -gphoto2 (-gstreamer) -hardened -opencl -scanner -test"
Comment 3 fkhp 2011-11-15 04:58:22 UTC
app-emulation/wine-1.3.32 with the same problem,
the system is GNOME 3.2.1 wiht pulseaudio set up and serve alsa by media-plugins/alsa-plugins
Comment 4 Juanlu Pérez 2012-03-22 12:19:51 UTC
Now I'm using wine-1.5.0, when I run winecfg as root it sounds peferct when pushing test button, but not as user, I just got some ugly choppy sound.
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-03-04 14:26:06 UTC
1.3.30 is gone from portage for a long time.

Please reopen if this bug still occurs with the current ~amd64 version of wine (1.5.25 at the moment).
Comment 6 Juanlu Pérez 2013-12-28 17:52:34 UTC
I'm still getting same errors on wine-1.6
Comment 7 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-12-28 21:59:21 UTC
(In reply to Juanlu Pérez from comment #6)
> I'm still getting same errors on wine-1.6

Are you using pulseaudio?

If yes: please update to pulseaudio-4.0-r1 from ~amd64. You will need to emerge it with ABI_X86="32 64". (And this will probably require you to either add "abi_x86_32" to package.use for a bunch of sound-related packages, or to simply globally add ABI_X86="32 64" to make.conf). After updating, you will need to restart your desktop session.
4.0-r1 is the first pulseaudio ebuild with proper multilib support, which guarantees that 32-bit pulseaudio libraries used by wine will be compatible with your 64-bit pulseaudio daemon.

If no: you might be seeing a duplicate of bug #489004. Please test with wine-1.6.1 or 1.7.9 and see if they work better.