Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 387733 - media-video/mplayer2-9999 fails to build on MacOS X in gentoo prefix
Summary: media-video/mplayer2-9999 fails to build on MacOS X in gentoo prefix
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: x86 OS X
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-19 21:06 UTC by Ruslan U. Zakirov
Modified: 2015-03-15 09:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan U. Zakirov 2011-10-19 21:06:42 UTC
CC	libmpdemux/demux_ogg.o
CC	mplayer
Undefined symbols for architecture x86_64:
  "_mp_csp_names", referenced from:
      _mp_property_colormatrix in command.o
  "_libintl_setlocale", referenced from:
      _mp_gtext in mp_msg.o
  "_libintl_gettext", referenced from:
      _mp_gtext in mp_msg.o
  "_libintl_textdomain", referenced from:
      _mp_msg_init in mp_msg.o
  "_libintl_bindtextdomain", referenced from:
      _mp_msg_init in mp_msg.o
  "_libintl_bind_textdomain_codeset", referenced from:
      _mp_msg_init in mp_msg.o
  "_mp_csp_guess_colorspace", referenced from:
      _get_detected_video_colorspace in dec_video.o
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
make: *** [mplayer] Ошибка 1
 * ERROR: media-video/mplayer2-9999 failed (compile phase):
 *   emake failed


Reproducible: Always




emerge --info
Portage 2.2.01.19478-prefix (prefix/darwin/macos/10.6/x64, gcc-4.2.1, unavailable, 10.8.0 i386)
=================================================================
System uname: Darwin-10.8.0-i386-64bit
Timestamp of tree: Wed, 19 Oct 2011 17:39:42 +0000
distcc 3.1-toolwhip.1 i386-apple-darwin10.0 [disabled]
app-shells/bash:      4.2_p10
dev-lang/python:      2.7.2
dev-util/pkgconfig:   0.25-r2
sys-devel/autoconf:   2.68
sys-devel/automake:   1.11.1
sys-devel/gcc-config: 1.4.1-r00.2
sys-devel/libtool:    2.4-r01.1
sys-devel/make:       3.82
Repositories: gentoo_prefix
Installed sets: 
ACCEPT_KEYWORDS="~x64-macos"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-apple-darwin10"
CFLAGS="-march=nocona -march=nocona"
CHOST="x86_64-apple-darwin10"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/portage /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=nocona -march=nocona"
DISTDIR="/opt/portage/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles news nostrip parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-dead_strip_dylibs"
PKGDIR="/opt/portage/usr/portage/packages"
PORTAGE_CONFIGROOT="/opt/portage/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/opt/portage/var/tmp"
PORTDIR="/opt/portage/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.prefix.freens.org/gentoo-portage-prefix"
USE="aqua bash-completion cairo coreaudio cracklib cxx exif fontconfig git jpeg jpeg2k mmx mmxext modules ncurses nls objc objc++ ogg perl png prefix readline sse sse2 ssl subversion svg tiff truetype unicode vim-syntax x64-macos zlib" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="Darwin" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="Darwin" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-10-19 23:00:29 UTC
Even the non-9999 version doesn't have osx keywords...
Comment 2 Ruslan U. Zakirov 2011-10-21 11:48:30 UTC
On one of bug reports somebody jumped in and said that he would love mplayer2 tested on other platforms. I decided to give it a try.

For example some guy builds it just fine: https://github.com/pigoz/mplayerosx-builds
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-10-21 15:25:29 UTC
(In reply to comment #2)
> On one of bug reports somebody jumped in and said that he would love mplayer2
> tested on other platforms. I decided to give it a try.
> 
> For example some guy builds it just fine:
> https://github.com/pigoz/mplayerosx-builds

Oh, looks like he builds it with modifications though. It would be useful if you can see what he does there (if you want). Otherwise, I'm afraid this bug will just stay dormant due to more pressing bugs that we don't have time to get to..
Comment 4 Nikoli 2011-11-07 21:43:30 UTC
Please report this bug upstream http://devel.mplayer2.org/wiki/Bugs
Comment 5 EEva 2012-05-13 21:53:31 UTC
I met (almost) the same problem with =media-video/mplayer2-2.0_p20120309.

...
CC      libmpdemux/demux_ogg.o
CC      mplayer
Undefined symbols for architecture x86_64:
  "_libintl_setlocale", referenced from:
      _mp_gtext in mp_msg.o
  "_libintl_gettext", referenced from:
      _mp_gtext in mp_msg.o
  "_libintl_textdomain", referenced from:
      _mp_msg_init in mp_msg.o
  "_libintl_bindtextdomain", referenced from:
      _mp_msg_init in mp_msg.o
  "_libintl_bind_textdomain_codeset", referenced from:
      _mp_msg_init in mp_msg.o
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
...

So this has nothing to do with libintl (which btw is just a virtual package)?
Comment 6 Ben de Groot (RETIRED) gentoo-dev 2015-03-15 09:20:26 UTC
mplayer2 is abandoned and last-rited