Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 387487 - mate-base/mate is the Mate Desktop Environment
Summary: mate-base/mate is the Mate Desktop Environment
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Highest enhancement with 3 votes (vote)
Assignee: Tom Wijsman (TomWij) (RETIRED)
URL: https://github.com/Sabayon/mate-overlay
Whiteboard:
Keywords:
: 412533 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-18 05:25 UTC by Ken
Modified: 2014-05-09 12:13 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken 2011-10-18 05:25:06 UTC
A new ebuild/package request. This is a fork of Gnome2 and is useful for users who do not wish to run the Gnome3 User interface. However, The work of getting the Gnome2 Fork and Gnome3 on the same system might be a bit tough.

Reproducible: Always




This Fork does not have a normal Version marker, so the packages might wind up having multiple versions to get all the way up to the most recent.
Comment 1 Gilles Dartiguelongue gentoo-dev 2011-10-22 13:26:06 UTC
Gnome team does not want to support 2 completely different desktops. As soon as gnome3 is unmasked, gnome2 support will be stopped just like upstream stopped working on it. If someone feels like keeping a working gnome2 desktop around past that point, he/she will have to step up as a maintainer.
Comment 2 Simon Oroño 2012-03-29 16:11:58 UTC
https://github.com/perberos/Mate-Desktop-Environment

This is the github of MATE. The packages are completely different, so MATE has
no conflict with Gnome3.
Comment 3 KinG-InFeT 2012-05-02 09:24:53 UTC
*** Bug 412533 has been marked as a duplicate of this bug. ***
Comment 4 xiando 2012-08-01 06:29:06 UTC
MATE is being actively worked on as a new desktop seperate from GNOME. It's a fork. http://mate-desktop.org/2012/07/30/mate-1-4-released/

FEDORA, and other distributions, are including it. https://fedoraproject.org/wiki/Features/MATE-Desktop

I see Dartiguelongue informs that the Gentoo Gnome gang doesn't want to work on MATE. That's fine, just like it's alright that the Gnome gang does not want to work on XFCE4. XFCE4 is, after all, not Gnome. MATE is also not GNOME.
Comment 5 Julian Ospald 2012-08-01 08:44:50 UTC
I think the problem is that when you ship a desktop environment you pretty much have to use it yourself to be able to catch up with the bugs and such.

Apparently no dev does yet? If someone feels like doing this and create a MATE herd I might join it, but I am primarily an openbox user and don't feel like leading this.
Comment 6 Patrick McLean gentoo-dev 2012-08-08 00:27:54 UTC
I would be interested in helping with this this, though it is doubtful I will have time to develop ebuilds from scratch any time soon.

I am certainly interested in using this as my desktop env.
Comment 7 KinG-InFeT 2012-08-08 08:18:08 UTC
link github the project https://github.com/mate-desktop
out 1.4 release
http://mate-desktop.org/2012/07/30/mate-1-4-released/
Comment 8 Pacho Ramos gentoo-dev 2012-09-15 08:58:56 UTC
I think Sabayon overlay has ebuilds for Mate
Comment 9 Sander Sweers 2013-04-05 11:41:29 UTC
(In reply to comment #8)
> I think Sabayon overlay has ebuilds for Mate

layman -a mate

If people want to help out the git repo is at https://github.com/Sabayon/mate-overlay.
Comment 10 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-02-22 22:25:54 UTC
Started running MATE and am taking this on my plate, I'm already in contact with steev (interested dev) and infirit (main maintainer of the overlay, listed as a MATE contributor) about this; if others plan to contribute to this (whether as proxy or as a developer), feel free to ping me about this. Thank you in advance.

Awaiting category decision on the gentoo-dev mailing list:

http://news.gmane.org/find-root.php?message_id=20140222000638.775a030d%40TOMWIJ%2dGENTOO
Comment 11 Joakim Tjernlund 2014-03-23 13:15:21 UTC
I have seen many mate packages go into the tree but they are all MASKed. Are they
not functional yet? Any idea when these will be unmasked?
Comment 12 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-03-23 14:44:42 UTC
When mate-base/mate has been added (later today) and tested (tomorrow); so, I expect the unmask to happen soon after that, definitely the coming week unless actual problems arise.
Comment 13 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-03-24 18:09:03 UTC
Hello everyone.

Alright, after importing, reviewing, adjusting and testing packages for a month.

+  24 Mar 2014; Tom Wijsman <TomWij@gentoo.org> package.mask:
+  Remove MATE Desktop Environment 1.6 introduction mask.

Installation, usage and troubleshooting instructions are available in a Gentoo Wiki entry that was made: https://wiki.gentoo.org/wiki/MATE

Note that MATE is yet to be keyworded on ~x86, and maybe on ~arm too. It is currently keyworded as ~amd64 only (that is what has been fully tested so far).

If you have problems, requests or something along that lines; please file a new separate bug, thank you in advance.
Comment 14 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-03-24 19:29:59 UTC
Many thanks go out to infirit (and other maintainers) from the mate-overlay.
Comment 15 Sander Sweers 2014-03-24 19:34:19 UTC
Great, thanks Tom for adding.

FYI, the overlay has the, still masked, 1.8 ebuilds.

~infirit
Comment 16 Joakim Tjernlund 2014-05-01 15:28:43 UTC
I see that MATE 1.8 is entering the tree, currently only
 x11-themes/mate-icon-theme
 x11-themes/mate-backgrounds
 x11-themes/mate-themes
(and make-base/mate obviously)
are missning for me to remove the MATE overlay. Could these be
added too?

PS.
    I see tha mate-extra/mate-power-manager is at 1.8.0-r1 now
Comment 17 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-05-01 15:49:08 UTC
(In reply to Joakim Tjernlund from comment #16)
> I see that MATE 1.8 is entering the tree, currently only
>  [...]
> (and make-base/mate obviously)
> are missning for me to remove the MATE overlay.

There is more:

mate-base/mate
mate-base/mdm (Won't do this, or at least not under this category; unofficial)
mate-extra/caja-dropbox
mate-extra/caja-extensions
mate-extra/mate-user-share
media-gfx/eom
media-gfx/mate-image-viewer
x11-misc/mate-menu-editor
x11-misc/mozo
x11-themes/mate-backgrounds
x11-themes/mate-icon-theme
x11-themes/mate-icon-theme-faenza
x11-themes/mate-themes

But I'll do x11-themes next.

> Could these be added too?

Yes, though 13 packages will take some time; I'll try to finish it this week though, as it has taken long enough. Will also start stabilization of 1.6 soon.

>     I see that mate-extra/mate-power-manager is at 1.8.0-r1 now

Thank you very much, I'll overlint the overlay when I'm done to catch that. :)
Comment 18 Joakim Tjernlund 2014-05-01 19:07:04 UTC
(In reply to Tom Wijsman (TomWij) from comment #17)
> (In reply to Joakim Tjernlund from comment #16)
> > I see that MATE 1.8 is entering the tree, currently only
> >  [...]
> > (and make-base/mate obviously)
> > are missning for me to remove the MATE overlay.
> 
> There is more:
> 
> mate-base/mate
> mate-base/mdm (Won't do this, or at least not under this category;
> unofficial)
> mate-extra/caja-dropbox
> mate-extra/caja-extensions
> mate-extra/mate-user-share
> media-gfx/eom
> media-gfx/mate-image-viewer
> x11-misc/mate-menu-editor
> x11-misc/mozo
> x11-themes/mate-backgrounds
> x11-themes/mate-icon-theme
> x11-themes/mate-icon-theme-faenza
> x11-themes/mate-themes
> 
> But I'll do x11-themes next.
> 
> > Could these be added too?
> 
> Yes, though 13 packages will take some time; I'll try to finish it this week
> though, as it has taken long enough. Will also start stabilization of 1.6
> soon.
> 
> >     I see that mate-extra/mate-power-manager is at 1.8.0-r1 now
> 
> Thank you very much, I'll overlint the overlay when I'm done to catch that.
> :)

Nice, I see the x11 themes are in :)
I overlooked media-gfx/eom and x11-misc/mozo which I use too.
Then I think/hope mate-base/mate is complete

Also, I think media-gfx/eom replaces media-gfx/mate-image-viewer?
x11-misc/mate-menu-editor is not in the overlay, is it part of 1.8?
Comment 19 Joakim Tjernlund 2014-05-06 17:12:00 UTC
(In reply to Tom Wijsman (TomWij) from comment #17)
> (In reply to Joakim Tjernlund from comment #16)
> > I see that MATE 1.8 is entering the tree, currently only
> >  [...]
> > (and make-base/mate obviously)
> > are missning for me to remove the MATE overlay.
> 
> There is more:
> 
> mate-base/mate
> mate-base/mdm (Won't do this, or at least not under this category;
> unofficial)
> mate-extra/caja-dropbox
> mate-extra/caja-extensions
> mate-extra/mate-user-share
> media-gfx/eom
> media-gfx/mate-image-viewer
> x11-misc/mate-menu-editor
> x11-misc/mozo
> x11-themes/mate-backgrounds
> x11-themes/mate-icon-theme
> x11-themes/mate-icon-theme-faenza
> x11-themes/mate-themes
> 
> But I'll do x11-themes next.
> 
> > Could these be added too?
> 
> Yes, though 13 packages will take some time; I'll try to finish it this week
> though, as it has taken long enough. Will also start stabilization of 1.6
> soon.
> 
> >     I see that mate-extra/mate-power-manager is at 1.8.0-r1 now
> 
> Thank you very much, I'll overlint the overlay when I'm done to catch that.
> :)

mate-extra/mate-power-manager-1.8.0-r1, pretty please :)
Comment 20 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-05-06 17:44:42 UTC
Done, thank you very much.
Comment 21 Joakim Tjernlund 2014-05-06 19:49:26 UTC
(In reply to Tom Wijsman (TomWij) from comment #20)
> Done, thank you very much.

emerge -aNDu world
[ebuild     U ] dev-libs/libical-0.48-r2 [0.48]
[ebuild  N    ] dev-libs/json-glib-0.16.2 
[ebuild  NS   ] sys-kernel/vanilla-sources-3.10.39 [3.10.38]
[ebuild   R   ] mate-base/libmatekbd-1.8.0 [1.8.0]
[ebuild   R   ] mate-extra/mate-calc-1.8.0 [1.8.0]
[ebuild   R   ] app-arch/engrampa-1.8.0 [1.8.0]
[ebuild   R   ] mate-extra/mate-dialogs-1.8.0 [1.8.0]
[ebuild   R   ] mate-base/mate-desktop-1.8.0 [1.8.0]
[ebuild   R   ] x11-wm/marco-1.8.0 [1.8.0]
[ebuild   R   ] mate-extra/mate-system-monitor-1.8.0 [1.8.0]
[ebuild   R   ] mate-extra/mate-utils-1.8.0 [1.8.0]
[ebuild   R   ] x11-misc/mate-notification-daemon-1.8.0 [1.8.0]
[ebuild   R   ] dev-libs/libmateweather-1.8.0 [1.8.0]
[ebuild   R   ] media-gfx/eom-1.8.0 [1.8.0]
[ebuild   R   ] mate-base/mate-panel-1.8.0 [1.8.0]
[ebuild   R   ] app-editors/pluma-1.8.0 [1.8.0]
[ebuild   R   ] x11-terms/mate-terminal-1.8.0 [1.8.0]
[ebuild   R   ] app-text/atril-1.8.0 [1.8.0]
[ebuild   R   ] mate-base/mate-settings-daemon-1.8.0 [1.8.0]
[ebuild   R   ] mate-extra/mate-polkit-1.8.0 [1.8.0]
[ebuild   R   ] mate-extra/mate-screensaver-1.8.0 [1.8.0]
[ebuild   R   ] mate-base/mate-applets-1.8.0 [1.8.0]
[ebuild   R   ] mate-base/mate-session-manager-1.8.1 [1.8.1]
[ebuild   R   ] mate-extra/mate-power-manager-1.8.0-r1 [1.8.0-r1]
[ebuild   R   ] mate-extra/mate-media-1.8.0 [1.8.0]
[ebuild   R   ] mate-base/caja-1.8.0 [1.8.0]
[ebuild   R   ] mate-base/mate-control-center-1.8.1 [1.8.1]
[ebuild   R   ] mate-base/mate-1.8.0 [1.8.0]


I will comment once I have tested a bit.
Comment 22 Joakim Tjernlund 2014-05-06 19:57:28 UTC
Didn't take long :)
* This package will overwrite one or more files that may belong to other
 * packages (see list below).
 * 
 * Detected file collision(s):
 * 
 * 	/usr/share/help/sv/lgpl/index.docbook
 * 	/usr/share/help/sv/gpl/index.docbook
 * 	/usr/share/help/sv/fdl/index.docbook
 * 
 * Searching all installed packages for file collisions...
 * 
 * Press Ctrl-C to Stop
 * 
 * gnome-base/gnome-desktop-3.10.2:3::gentoo
 * 	/usr/share/help/sv/fdl/index.docbook
 * 	/usr/share/help/sv/gpl/index.docbook
 * 	/usr/share/help/sv/lgpl/index.docbook
 * 
 * Package 'mate-base/mate-desktop-1.8.0' NOT merged due to file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.

Got this in my LINGUAS
LINGUAS="en_GB sv_SE sv"

The rest emerge fine though. Time to restart my desktop
Comment 23 Joakim Tjernlund 2014-05-06 20:04:18 UTC
After restart a quick rundown of my Desktop, all seems well. Thanks
Comment 24 Joakim Tjernlund 2014-05-06 20:08:24 UTC
And, naturally, checking MATE overlay we got
  mate-base/mate-desktop-1.8.1
  mate-base/mate-settings-daemon-1.8.1
now.
Comment 25 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-05-09 12:13:41 UTC
Done, including Caja 1.8.1 that contains a fix for endless multiple windows; please consider to file new bugs instead of bumping this, thank you in advance.