Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 387313 - media-video/vdr-1.6.0_p2-r5 fails to build with sys-kernel/linux-headers-2.6.39
Summary: media-video/vdr-1.6.0_p2-r5 fails to build with sys-kernel/linux-headers-2.6.39
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 384733
  Show dependency tree
 
Reported: 2011-10-16 18:51 UTC by Myckel Habets
Modified: 2011-10-19 18:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (vdr-build.log,6.47 KB, text/plain)
2011-10-16 18:52 UTC, Myckel Habets
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Myckel Habets 2011-10-16 18:51:32 UTC
Doing bug 384733 I found that media-video/vdr-1.6.0_p2-r5 fails to build with sys-kernel/linux-headers-2.6.39. Downgrading linux-headers makes the build succeed again.

Reproducible: Always

Steps to Reproduce:
emerge media-video/vdr-1.6.0_p2-r5 with sys-kernel/linux-headers-2.6.39 installed.
Actual Results:  
Build fails due to missing header file (linux/videodev.h).

Expected Results:  
vdr installs successfully.

emerge --info
Portage 2.1.10.11 (default/linux/x86/10.0, gcc-4.5.3, glibc-2.12.2-r0, 2.6.39 i686)
=================================================================
System uname: Linux-2.6.39-i686-Mobile_AMD_Sempron-tm-_Processor_2800+-with-gentoo-2.0.3
Timestamp of tree: Sat, 15 Oct 2011 16:00:01 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon-xp -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs collision-protect distcc distlocks ebuild-locks fixlafiles fixpackages news nostrip parallel-fetch protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="nl_NL.utf8"
LDFLAGS="-Wl,-O1,--as-needed"
LINGUAS="nl en uk"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X abyss acl acpi alisp alsa autoipd avahi bash-completion berkdb bzip2 cairo cg cjk cli cracklib crypt cups cxx dbus device-mapper devil double-precision dri encode fam fancy ffmpeg flac fontconfig fortran fts3 gallium gcj gdbm gdu gif gles gmp gnutls gpm gs gtk iconv icu imap ipv6 ithreads jadetex java5 jpeg kpathsea libnotify mikmod mmx mng modules mp3 mpi mudflap ncurses networking nls nptl nptlonly ogg ogre openexr opengl openmp openssl openvg pam pcre pic player png policykit pppd python qt3support qt4 rdesktop readline romio sdl session smime sockets spell sqlite sqlite3 sse sse2 ssl startup-notification svg sysfs tcpd theora threads thunar tiff timidity tinyxml tordns truetype udev unicode vnc vorbis x86 xcb xcomposite xetex xft xnest xorg xvfb zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nl en uk" PHP_TARGETS="php5-3" RUBY_TARGETS="jruby ruby18 ree18" USERLAND="GNU" VIDEO_CARDS="fglrx r600 radeon nouveau intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Myckel Habets 2011-10-16 18:52:00 UTC
Created attachment 289977 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2011-10-16 19:20:42 UTC
Time to stabilize more recent vdr?
Comment 3 Joerg Bornkessel gentoo-dev 2011-10-17 15:23:44 UTC
looks like, zzam@g.o has fixed this in the  background for
media-video/vdr-1.6.0_p2-r6

thanks in this case to Marco S. for providing this patch

plz use then the fixed -r6 version,

i will stabilized it then for x86 amd64,
in the next few days

(have to update my stable testing environtment at first, give me some dayz plz.)
Comment 4 Joerg Bornkessel gentoo-dev 2011-10-17 15:35:27 UTC
(In reply to comment #2)
> Time to stabilize more recent vdr?

maybe,...
we have newer versions in overlay vdr-devel
but, iam unshure and not a friend to move one of the developer versions to the portage,
anyway, the latetest version running stable on my sytem

I will start a tread on linuxTV vdr ML to stabilize the latest version and provide the next major version vdr-1.8
Comment 5 Joerg Bornkessel gentoo-dev 2011-10-19 16:30:42 UTC
@ Myckel 

this was fixed on 11 April 2011 ( half year ago!) in -r6

Plz, dont combinied stable/unstable versions if you dont know what you do

linux-headers-2.6.38+ are unstable on x86 
try then before ~x86 packages before open unneeded bugs

closed

reopen it, if dont compile the -r6 version
Comment 6 Samuli Suominen gentoo-dev 2011-10-19 16:37:22 UTC
and reopening, since this is blocking bug 384733 for x86 -- they need vdr stable so they can stabilize linux-headers. this is the blocker.
Comment 7 Joerg Bornkessel gentoo-dev 2011-10-19 18:33:10 UTC
(In reply to comment #6)
> and reopening, since this is blocking bug 384733 for x86 -- they need vdr
> stable so they can stabilize linux-headers. this is the blocker.

ha, i know this bug, aim not the only blocker ;)

stable x86, 
amd64 done yesterday,