Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 387061 - New ebuild games-roguelike/tome4-1.0.4
Summary: New ebuild games-roguelike/tome4-1.0.4
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard: [hasufell-overlay]
Keywords:
: 447850 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-13 19:20 UTC by gbz.solus.eliddell
Modified: 2018-12-03 12:58 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
tome4-1.0.4.ebuild (tome4-1.0.4.ebuild,2.73 KB, text/plain)
2013-08-29 13:57 UTC, Julian Ospald
Details
tome4-1.0.4.ebuild (tome4-1.0.4.ebuild,2.73 KB, text/plain)
2013-08-29 16:36 UTC, Julian Ospald
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gbz.solus.eliddell 2011-10-13 19:20:23 UTC
ToME has moved to http://te4.org/ and gone through a major version release since its ebuild was last updated. I suggest bumping to 4.0.0b32 rather than the most recent beta (34) because I believe b32 is the last version that will build under current stable SDL.

Reproducible: Always
Comment 1 Julian Ospald 2012-12-20 12:27:31 UTC
*** Bug 447850 has been marked as a duplicate of this bug. ***
Comment 2 Julian Ospald 2012-12-20 12:29:49 UTC
what's the correct version scheme?

It seems something like tome4-1.0.0_rc1?

also: this package uses premake, probably one of the reason no one bothered with it. Tell upstream it's bad, broken, retarded.
Comment 3 Paweł Jastrzębski 2012-12-20 12:34:19 UTC
Yep. tome4-1.0.0_rc1 is correct.

You do not have to convince me that premake sucks. Is quite possible that compilation also require patches for SDL libs. That is just overkill IMHO.

As I said in bug 447850 - This week I will upload tome4-bin ebuild here.
Comment 4 Paweł Jastrzębski 2012-12-20 12:37:49 UTC
There is tome4 ebuild that try grasp this mess but it don't work for me.

https://raw.github.com/leycec/raiagent/master/games-roguelike/tome4/tome4-1.0.0_beta43.ebuild
Comment 5 Anton Romanov 2013-01-07 12:51:24 UTC
1.0.0 is out
Comment 6 Julian Ospald 2013-01-07 17:31:33 UTC
sadly this seems to be "CANTFIX" until SDL-2 gets released
Comment 7 Julian Ospald 2013-08-28 21:53:53 UTC
sdl2 is in the tree now
Comment 8 Julian Ospald 2013-08-29 10:43:17 UTC
I get segfault on startup for _every_ optimization level (except -O0).
Comment 9 Julian Ospald 2013-08-29 13:57:22 UTC
Created attachment 357328 [details]
tome4-1.0.4.ebuild

based on your overlay ebuild

issues:
* a lot of libs are bundled
* parallel make is broken (forced -j1)
* game segfaults when compiled with any optimization level except -O0 (appended -O0 and provided custom-cflags useflag)

at least the last one is REALLY nasty
Comment 10 Julian Ospald 2013-08-29 16:36:12 UTC
Created attachment 357340 [details]
tome4-1.0.4.ebuild

oops, fiex
Comment 11 Julian Ospald 2013-08-29 17:34:30 UTC
this is still WIP, more problems like respecting FHS
Comment 13 Julian Ospald 2013-08-31 14:46:55 UTC
until some of those bugs are resolved upstream it will stay in overlay

https://github.com/hasufell/hasufell-overlay/blob/master/games-roguelike/tome4
Comment 14 Julian Ospald 2013-09-28 00:26:33 UTC
6 out of 6 bug reports ignored so far, feel free to make some noise upstream
Comment 15 Julian Ospald 2013-12-29 14:49:32 UTC
http://forums.te4.org/viewtopic.php?f=42&t=39859