Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 386461 - xen-tools-9999 need dev-libs/yajl dependency
Summary: xen-tools-9999 need dev-libs/yajl dependency
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Xen Devs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-08 21:23 UTC by Norbert Marx
Modified: 2011-10-23 10:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
unified diff for ebuild (xen-tools-9999.patch,2.89 KB, patch)
2011-10-14 16:10 UTC, Ian Delaney (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert Marx 2011-10-08 21:23:30 UTC
xen-tools-9999 need dev-libs/yajl dependency which is documented in the current READMED (4.2 unstable)

Reproducible: Always
Comment 1 Maxim Koltsov gentoo-dev 2011-10-14 14:54:48 UTC
Please tell us how is that needed and provide build.log of failure, if any. Also, post your emerge --info.
Comment 2 Ian Delaney (RETIRED) gentoo-dev 2011-10-14 16:10:50 UTC
Created attachment 289803 [details, diff]
unified diff for ebuild

tested, lib added to CDEPEND list.  Minor other adjustment
Comment 3 Norbert Marx 2011-10-15 08:44:19 UTC
Thank you for the patch. I can confirm that the patch is working.

But I have a problem with ipxe-git-v1.0.0.tar.gz. This file will not copied at src_prepare(). With the complete source path everything is fine.
 
The ebuild line:
130:    cp "$DISTDIR/ipxe-git-v1.0.0.tar.gz" tools/firmware/etherboot/ipxe.tar.gz

pc10 portage # emerge --info | grep DIST
DISTDIR="/usr/portage/distfiles"

pc10 portage_test # ebuild app-emulation/xen-tools/xen-tools-9999-r2.ebuild compile
 * checking ebuild checksums ;-) ...                                                                                                                                           [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                          [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                         [ ok ]
>>> Unpacking source...
 * Updating /usr/portage/distfiles/hg-src/xen-tools/xen-unstable.hg from http://xenbits.xensource.com/xen-unstable.hg
 * Creating working directory in /var/tmp/portage/app-emulation/xen-tools-9999-r2/work/xen-unstable.hg (target revision: tip)
 * Work directory: /var/tmp/portage/app-emulation/xen-tools-9999-r2/work/xen-unstable.hg global id: 6880bfc48504 branch: default
>>> Source unpacked in /var/tmp/portage/app-emulation/xen-tools-9999-r2/work
>>> Preparing source in /var/tmp/portage/app-emulation/xen-tools-9999-r2/work/xen-unstable.hg ...
cp: cannot stat `/var/tmp/portage/app-emulation/xen-tools-9999-r2/distdir/ipxe-git-v1.0.0.tar.gz': No such file or directory
>>> Source prepared.
............

rm -rf ipxe
gzip -dc ipxe.tar.gz | tar xf -
gzip: ipxe.tar.gz: No such file or directory
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
............

emake failed
 * ERROR: app-emulation/xen-tools-9999-r2 failed (compile phase):
 *   compile failed

Any hints?
Comment 4 Ian Delaney (RETIRED) gentoo-dev 2011-10-15 16:25:56 UTC
tar: This does not look like a tar archive

yes.  I have just had this in other unrelated ebuilds.  This apparently happens when it downloads via mirrors., the download is corrupted.  Either acquire the file manually, and / or do the following

# cd $PORTDIR/app-emulation/xen-tools
# rm $DISTDIR/Ipxe-git-v1.0.0.tar.gz  [ OR WHATEVER IT'S CALLED]
# nano Manifest
[remove the line that has the Ipxe file.
# GENTOO_MIRRORS="" ebuild xen-tools-9999 digest

this enforces acquiring the file from the nominated source site, not a mirror.

easy.  It's only co-incidence I learned of this a few days ago.  Have no idea what causes this file corruption via morrors.
Comment 5 Norbert Marx 2011-10-21 17:56:01 UTC
I believe my description was not really clear. The issue is the cp command. On runtime $DISTDIR does not have the right value.

If I stop the build process after 

cp: cannot stat
`/var/tmp/portage/app-emulation/xen-tools-9999-r2/distdir/ipxe-git-v1.0.0.tar.gz':
No such file or directory

with Ctrl-Z at this point and copy it directly from my $DISTDIR, everything is fine. I do not understand why $DISTDIR has at this point the value '/var/tmp/portage/app-emulation/xen-tools-9999-r2/distdir'.
Comment 6 Ian Delaney (RETIRED) gentoo-dev 2011-10-22 07:06:06 UTC
curious.  the wrong value is a type of bug in portage, but easily fixed.
Set DISTDIR in /etc/bash/bashrc or /etc/make.conf to stop it from being mis-set.
Alternately do a run of export DISTDIR="nominated/path".  Anyway, that's relatively trivial.  Still awaiting a commit of the patch.
Comment 7 Patrick Lauer gentoo-dev 2011-10-23 10:49:47 UTC
+  23 Oct 2011; Patrick Lauer <patrick@gentoo.org> xen-tools-9999.ebuild:
+  Bump for #386461, thanks to Ian Delaney
+
Had to fix the yajl dep a bit, it needs <2