Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 386239 - ebuild for geogebra
Summary: ebuild for geogebra
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-08 09:35 UTC by Tobias Leupold
Modified: 2015-07-25 21:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for geogebra 3.2.42.0 (geogebra-3.2.42.0.ebuild,597 bytes, text/plain)
2011-10-08 09:35 UTC, Tobias Leupold
Details
ebuild for Geogebra 4.4.12.0 (geogebra-4.4.12.0.ebuild,771 bytes, text/plain)
2014-02-23 22:15 UTC, Tobias Leupold
Details
Corrected ebuild (geogebra-4.4.12.0.ebuild,769 bytes, text/plain)
2014-02-24 13:19 UTC, Tobias Leupold
Details
GeoGebra License (GeoGebra,2.85 KB, application/mbox)
2014-02-24 13:24 UTC, Tobias Leupold
Details
ebuild for Geogebra 4.4.12.0 (geogebra-4.4.12.0.ebuild,769 bytes, text/plain)
2014-02-24 13:26 UTC, Tobias Leupold
Details
Text version of the geoGebra License (GeoGebra,2.85 KB, text/plain)
2014-02-24 13:28 UTC, Tobias Leupold
Details
ebuild for Geogebra 4.4.12.0 (geogebra-bin-4.4.12.0.ebuild,819 bytes, text/plain)
2014-03-11 16:19 UTC, Tobias Leupold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Leupold 2011-10-08 09:35:46 UTC
Created attachment 289193 [details]
ebuild for geogebra 3.2.42.0

GeoGebra is "Free mathematics software for learning and teaching". Here's an ebuild installing the current version 3.2.42.0 from the Debian packages provided by the GeoGebra authors (cf. http://www.geogebra.org/en/wiki/index.php/Package_for_Ubuntu_and_Debian )
Comment 1 Thomas Capricelli 2012-07-21 22:05:08 UTC
hello,

The ebuild installs and runs fine here (up to date ~amd64). Thanx a lot !
Comment 2 Christoph Junghans gentoo-dev 2012-07-21 22:19:12 UTC
If it works, please fork on 
https://github.com/gentoo-science/sci
and do a pull request after adding your ebuild.
Comment 3 Dennis New 2014-02-23 14:34:43 UTC
Bounce. 4.4 is out.
Comment 4 Tobias Leupold 2014-02-23 22:15:25 UTC
Created attachment 371144 [details]
ebuild for Geogebra 4.4.12.0

I'm not familiar with git at all, so I don't know how to put the ebuild in the mentionned overlay (but perhaps anybody else does?!).

But at least, I have updated the ebuild to install the lastest version 4.4.12.0 of Geogebra from the Debian package, also considering both the x86 and the amd64 version.
Comment 5 Justin Lecher gentoo-dev 2014-02-24 07:06:07 UTC
If you like you can sent a pull request for our github repo

https://github.com/gentoo-science/sci/blob/master/CONTRIBUTING.md
Comment 6 Tobias Leupold 2014-02-24 13:19:00 UTC
Created attachment 371170 [details]
Corrected ebuild

I tried to do what the howto says, bit I couldn't push my newly created branch … hub push said "fatal: The current branch geogebra has no upstream branch.".

Sorry … but at least, here's the corrected ebuild that passes the repoman check.
Comment 7 Tobias Leupold 2014-02-24 13:24:37 UTC
Created attachment 371172 [details]
GeoGebra License

I also tried to add this text version of the GeoGebra license which is referenced by the ebuild.
Comment 8 Tobias Leupold 2014-02-24 13:26:00 UTC
Created attachment 371174 [details]
ebuild for Geogebra 4.4.12.0

Sorry, I forgot to obsolete the older ebuilds.
Comment 9 Tobias Leupold 2014-02-24 13:28:36 UTC
Created attachment 371176 [details]
Text version of the geoGebra License
Comment 10 Justin Lecher gentoo-dev 2014-02-24 13:33:34 UTC
(In reply to Tobias Leupold from comment #6)
> Created attachment 371170 [details]
> Corrected ebuild
> 
> I tried to do what the howto says, bit I couldn't push my newly created
> branch … hub push said "fatal: The current branch geogebra has no upstream
> branch.".

Did you fork?
Comment 11 Tobias Leupold 2014-02-24 13:38:18 UTC
Yes, just as described in https://github.com/gentoo-science/sci/blob/master/CONTRIBUTING.md
Comment 12 Justin Lecher gentoo-dev 2014-02-24 13:41:27 UTC
(In reply to Tobias Leupold from comment #11)
> Yes, just as described in
> https://github.com/gentoo-science/sci/blob/master/CONTRIBUTING.md

I just checked the instructions and they are working here.

did you do

hub push your_github_user geogebra

?
Comment 13 Tobias Leupold 2014-02-24 18:56:24 UTC
I think everything worked now :-) The text of my pull request ended up in the title, but I think everything is committed now. I hope I did everything correctly …
Comment 14 Tobias Leupold 2014-03-11 16:19:58 UTC
Created attachment 372392 [details]
ebuild for Geogebra 4.4.12.0

Just if somebody searches for it here, here's the current state of the ebuild (nobody will find it as long as it just exits in my fork ;-)
Comment 15 lalebarde 2014-05-15 15:29:57 UTC
I am trying geogebra-4.4.34.ebuild or geogebra-4.4.34.0.ebuild, but I get "emerge: there are no ebuilds to satisfy "geogebra"", though the manifest is build.Any idea please ?
Comment 16 Justin Lecher gentoo-dev 2014-05-15 17:06:27 UTC
Did you add the science overlay to your overlays?
Comment 17 Dennis New 2014-06-18 16:29:07 UTC
How is it possible that this package has no dependencies? (Besides Java.) Is it just a big monolithic closed-source pre-compiled Java binary?
Comment 18 Tobias Leupold 2014-06-18 17:31:23 UTC
I think so …
Comment 19 Tobias Leupold 2014-06-18 17:32:16 UTC
It's open source, but this is for the pre-compiled version.
Comment 20 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-09-05 22:41:39 UTC
Shouldn't it be closed because of this:

>*geogebra-4.1.120.0 (23 Aug 2014)
>
>  23 Aug 2014; Amy Winston <amynka@gentoo.org>
>  +files/geogebra-fix-install.sh.patch, +geogebra-4.1.120.0.ebuild,
>  +metadata.xml:
>  Initial commit. Package for geometry

?
Comment 21 Dennis New 2014-09-05 22:45:18 UTC
I don't know if this ebuild counts -- it's a precompiled binary.
Comment 22 Tobias Leupold 2014-09-06 00:00:34 UTC
Why should it not count?! It's really not the only ebuild that installs a precompiled binary and it does make geogebra available for Gentoo!

If so, www-client/firefox-bin, app-office/openoffice-bin, www-plugins/adobe-flash and all the others would also "not count".

So what?!
Comment 23 Dennis New 2014-09-06 00:02:48 UTC
It should be called sci-mathematics/geogebra-bin ... and a proper source-compiled (the gentoo way) ebuild should be made, with all it's dependencies. Like net-p2p/freenet does it.
Comment 24 Tobias Leupold 2014-09-06 00:14:25 UTC
Well, I posted "ebuild for Geogebra 4.4.12.0", so you can call it what you want. But however, the ebuild emerged in a quite long process. Would be a pity if it was rejected because it installs a binary package as long as we don't have an alternative way to use geogebra.

Surely, it would be fine if we had an ebuild compiling and installing the Java sources of geogebra. But, speaking of me, I'm not able to create such an ebuild.

If you can add it, I'd surely choose "geogebra" instead of "geogebra-bin".
Comment 25 Dennis New 2014-09-14 01:31:51 UTC
Bah, I give up. I tried compiling it on my own, and although portage has many of the required dependencies, there are too many that are missing. (This includes "gwt" (Google Web Toolkit), and "jdt" (Eclipse's Java Development Tools -- which may or may not be part of dev-java/eclipse-sdk which is massive), and others).
Comment 26 Tobias Leupold 2014-09-14 09:59:09 UTC
That's why I used the pre-compiled version ...