Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 386125 - x11-drivers/xf86-video-vmware does not install with reason bad programming practice
Summary: x11-drivers/xf86-video-vmware does not install with reason bad programming pr...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Tiziano Müller
URL:
Whiteboard:
Keywords:
: 399067 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-07 18:26 UTC by Roelof Wobben
Modified: 2017-01-26 05:58 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge_info (emerge_info,5.46 KB, text/plain)
2011-10-08 07:42 UTC, Roelof Wobben
Details
emerge_pgv (emerge_pgv,161 bytes, text/plain)
2011-10-08 07:42 UTC, Roelof Wobben
Details
/var/tmp/portage/x11-drivers/xf86-video-vmware-11.0.3/temp/build.log (build.log,25.39 KB, text/plain)
2011-10-08 07:44 UTC, Roelof Wobben
Details
/var/tmp/portage/x11-drivers/xf86-video-vmware-11.0.3/temp/environment (environment,129.91 KB, text/plain)
2011-10-08 07:44 UTC, Roelof Wobben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roelof Wobben 2011-10-07 18:26:54 UTC
When I do emerge xorg-server it stops with the message in the summary.


Reproducible: Always

Steps to Reproduce:
1. Do a clean install
2. emerge xorg-server
3.
Actual Results:  
Emerge fails 

Expected Results:  
Emerge will succeed

I can't copy or attach the info in this screen because I don't have a working X enviroment.
So I will give the links to the paste screens.

emerge --info  : http://paste.pacoo.org/show/4489034
emerge -pqv : http://paste.pacoo.org/show/489035
build.log : http://paste.pacoo.org/show/489036
enviroment : http://paste.pacoo.org/show/489039
Comment 1 Naohiro Aota gentoo-dev 2011-10-08 06:34:06 UTC
(In reply to comment #0)
> I can't copy or attach the info in this screen because I don't have a working X
> enviroment.
> So I will give the links to the paste screens.
> 
> emerge --info  : http://paste.pacoo.org/show/4489034
> emerge -pqv : http://paste.pacoo.org/show/489035
> build.log : http://paste.pacoo.org/show/489036
> enviroment : http://paste.pacoo.org/show/489039

please emerge pybugz and use "bugz attach bugid filename" to attach files.

...and the links seems broken

emerge --info  : http://paste.pocoo.org/show/4489034
emerge -pqv : http://paste.pocoo.org/show/489035
build.log : http://paste.pocoo.org/show/489036
enviroment : http://paste.pocoo.org/show/489039
Comment 2 Roelof Wobben 2011-10-08 07:31:48 UTC
Oke, 

Wait a moment.

Roelof
Comment 3 Roelof Wobben 2011-10-08 07:42:13 UTC
Created attachment 289179 [details]
emerge_info


The emerge--info log
Comment 4 Roelof Wobben 2011-10-08 07:42:49 UTC
Created attachment 289181 [details]
emerge_pgv


emerge -pqv log
Comment 5 Roelof Wobben 2011-10-08 07:44:03 UTC
Created attachment 289183 [details]
/var/tmp/portage/x11-drivers/xf86-video-vmware-11.0.3/temp/build.log


build log
Comment 6 Roelof Wobben 2011-10-08 07:44:24 UTC
Created attachment 289185 [details]
/var/tmp/portage/x11-drivers/xf86-video-vmware-11.0.3/temp/environment


enviroment
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-01-16 14:35:38 UTC
*** Bug 399067 has been marked as a duplicate of this bug. ***
Comment 8 Phil Falcon 2013-01-31 10:43:42 UTC
I have a similar problem with version 12.0.2-r1 and 13.0.0

Here is my emerge --info:

Portage 2.1.11.31 (default/linux/amd64/10.0/selinux, gcc-4.4.2, unavailable, 3.1.5-gentoo x86_64)
=================================================================
System uname: Linux-3.1.5-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Thu, 31 Jan 2013 08:30:01 +0000
ld GNU ld (GNU Binutils) 2.23
app-shells/bash:          4.2_p20
dev-java/java-config:     1.3.7-r1, 2.1.12-r1
dev-lang/python:          2.4.6, 2.5.4-r4, 2.6.8, 2.7.3-r3, 3.1.4-r3, 3.2.3-r2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.5, 1.9.6-r2, 1.10.2, 1.11.6
sys-devel/binutils:       2.23
sys-devel/gcc:            4.1.2, 4.4.2, 4.5.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        1.5.26-r1, 2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo armagetron spring sunrise x-custom
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8@euro"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/armagetron /usr/local/portage/layman/Spring /usr/local/portage/layman/sunrise /usr/local/portage/custom"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 apache2 apm apng bash-completion battery berkdb bzip2 cairo cdda cddb cjk cli cpufreq cracklib crypt cups curl cxx dbus dga divx dri dv dvd ffmpeg firefox flac fortran gd gdbm gif gimp gpm iconv ieee1394 imagemagick imap inifile ipv6 java java6 jpeg jpeg2k json lame laptop latex libkms mbox midi mikmod mjpeg mmx mng mod modplug modules mp3 mpeg mplayer mudflap multilib mysql ncurses nls nptl nsplugin ogg open_perms opengl openmp pam pcre pdf php physfs png python qt3support qt4 quicktime readline realmedia samba sdl selinux session sharedext smpeg sockets speex sqlite sse sse2 ssl ssse3 static static-libs subtitles svg sysvipc tcpd threads tiff timidity tokenizer truetype unicode usb v4l v4l2 vcd vorbis webkit wifi wmf wmp x246 x264 xa xcb xml xmlreader xmlwriter xosd xpm xulrunner xvid yv12 zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias asis auth_digest authn_dbd cern_meta charset_lite dbd dumpio ident imagemap log_forensic proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http substitute version" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="mouse keyboard synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

emerge -pqv '=x11-drivers/xf86-video-vmware-13.0.0'
[ebuild  N    ] x11-drivers/xf86-video-vmware-13.0.0 

emerge -pqv '=x11-drivers/xf86-video-vmware-12.0.2-r1'
[ebuild  N    ] x11-drivers/xf86-video-vmware-12.0.2-r1
Comment 9 Phil Falcon 2013-01-31 11:11:18 UTC
Last parts of the build log for versio 12.0.2-r1:


  CC     libvmwgfx_la-vmwgfx_output.lo
/bin/sh ../libtool --silent --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2/vmwgfx -I..    -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wformat=2 -Wold-style-definition -Wdeclaration-after-statement -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1   -I/usr/include/libdrm     -I/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2/src -I/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2/saa -march=nocona -O2 -pipe -c -o libvmwgfx_la-vmwgfx_output.lo `test -f 'vmwgfx_output.c' || echo '/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2/vmwgfx/'`vmwgfx_output.c
In file included from /var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2/vmwgfx/vmwgfx_output.c:49:
/usr/include/X11/extensions/dpms.h:40: error: expected ')' before '*' token
/usr/include/X11/extensions/dpms.h:41: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSGetVersion'
/usr/include/X11/extensions/dpms.h:42: error: expected ')' before '*' token
/usr/include/X11/extensions/dpms.h:43: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSSetTimeouts'
/usr/include/X11/extensions/dpms.h:44: error: expected ')' before '*' token
/usr/include/X11/extensions/dpms.h:45: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSEnable'
/usr/include/X11/extensions/dpms.h:46: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSDisable'
/usr/include/X11/extensions/dpms.h:47: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSForceLevel'
/usr/include/X11/extensions/dpms.h:48: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSInfo'
In file included from /var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2/vmwgfx/vmwgfx_crtc.c:52:
/usr/include/X11/extensions/dpms.h:40: error: expected ')' before '*' token
/usr/include/X11/extensions/dpms.h:41: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSGetVersion'
/usr/include/X11/extensions/dpms.h:42: error: expected ')' before '*' token
/usr/include/X11/extensions/dpms.h:43: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSSetTimeouts'
/usr/include/X11/extensions/dpms.h:44: error: expected ')' before '*' token
/usr/include/X11/extensions/dpms.h:45: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSEnable'
/usr/include/X11/extensions/dpms.h:46: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSDisable'
/usr/include/X11/extensions/dpms.h:47: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSForceLevel'
/usr/include/X11/extensions/dpms.h:48: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'DPMSInfo'
make[2]: *** [libvmwgfx_la-vmwgfx_output.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [libvmwgfx_la-vmwgfx_crtc.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2_build/vmwgfx'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2_build'
make: *** [all] Error 2
 * ERROR: x11-drivers/xf86-video-vmware-12.0.2-r1 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=x11-drivers/xf86-video-vmware-12.0.2-r1'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/xf86-video-vmware-12.0.2-r1'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2_build'
 * S: '/var/tmp/portage/x11-drivers/xf86-video-vmware-12.0.2-r1/work/xf86-video-vmware-12.0.2'


I would like to add the complete log as an attachment, but this features seems not to work for me (I tried Firefox and Opera).
Comment 10 Matt Turner gentoo-dev 2017-01-26 05:58:57 UTC
I cannot reproduce with 13.2.1