Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 386037 - app-crypt/qca-ossl-2.0.0_beta3-r2: fails to build x86-abi with portage-multilib enabled
Summary: app-crypt/qca-ossl-2.0.0_beta3-r2: fails to build x86-abi with portage-multil...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Low normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard: multilib
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-07 10:22 UTC by 颜烈彬
Modified: 2014-10-31 13:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (build.log.gz,1.83 KB, application/x-gzip)
2011-10-07 10:25 UTC, 颜烈彬
Details
conf.log (conf.log,2.18 KB, text/plain)
2011-10-07 10:27 UTC, 颜烈彬
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 颜烈彬 2011-10-07 10:22:08 UTC
It doesn't find QTDIR correctly when building for x86-abi and then breaks compilation.

Reproducible: Always

Steps to Reproduce:
1. emerge -1v app-crypt/qca-ossl
2.
3.
Actual Results:  
compilation stops.

Expected Results:  
compilation finishes.

Portage 2.2.0_alpha60-r1 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.0.4-gentoo x86_64)
=================================================================
System uname: Linux-3.0.4-gentoo-x86_64-Intel-R-_Core-TM-_i3_CPU_M_350_@_2.27GHz-with-gentoo-2.1
Timestamp of tree: Fri, 07 Oct 2011 07:00:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo enlightenment gentoo-zh gnome hardened-dev kde multilib proaudio qting-edge science sunrise x11 xemacs
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10 AdobeFlash-10.1 DOOM3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -mtune=native -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -mtune=native -march=native"
DISTDIR="/opt/distfiles/"
EMERGE_DEFAULT_OPTS="--autounmask=n --load-average=1.5"
FEATURES="assume-digests binpkg-logs compress-build-logs distlocks ebuild-locks fixlafiles fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="zh_CN.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en zh en_GB en_US zh_CN zh_HK zh_TW"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/mnt/stuff/layman/enlightenment /mnt/stuff/layman/gentoo-zh /mnt/stuff/layman/gnome /mnt/stuff/layman/hardened-development /mnt/stuff/layman/kde /mnt/stuff/layman/multilib /mnt/stuff/layman/pro-audio /mnt/stuff/layman/qting-edge /mnt/stuff/layman/science /mnt/stuff/layman/sunrise /mnt/stuff/layman/x11 /mnt/stuff/layman/xemacs"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="PyQt X a52 aac aalib accessibility acl acpi ada agg alsa amd64 amr apache2 apm arpack audiofile avahi bittorrent branding bzip2 cairo calendar cdio chm cjk cli clisp consolekit cracklib crypt cscope cue cups custom-optimization cvs cvsgraph cxx dbus devkit dirac djvu doxygen dri ebook edje encode enscript espeak exif expat faac faad fbcon ffmpeg fftw flac fluidsynth fortran frei0r ftp gallium gd gdbm gif git glitz glpk gmp gnat gnutls gpm graphite gsm gstreamer hardened hvm iconv icu imlib iproute2 ipv6 joystick jpeg jpeg2k kde kernel-patch lame lastfmradio latex lcms libg++ libmms libnotify libsamplerate libwww lzma lzo mad midi mikmod mjpeg mmx mng mod_python modperl modplug modules mp3 mpeg mplayer mudflap multilib multimedia musepack mysql ncurses nepomuk network nls nptl nptlonly nsplugin nvidia odbc ogg openal opengl openmp openvg pam pcre perl pipe plugin_stardict png poliykit polkitqt portaudio ppp pppd private-headers pulseaudio pvr pygments python qt4 quicktime readline realtime redeyes ree18 rtmp ruby savedconfig schroedinger sdl semantic-desktop session socks5 speex spell sql sqlite sse sse2 sse4 ssl ssse3 subversion svg synaptics sysfs tcpd theora threads tiff trace truetype unicode usb v4l2 vaapi vdpau vhosts vorbis x264 xanim xattr xcb xcomposite xetex xine xinerama xml xorg xv xvid xvmc xz zh zh_CN zh_TW zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en zh en_GB en_US zh_CN zh_HK zh_TW" MULTILIB_ABIS="amd64 x86" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64 ppc64" QEMU_USER_TARGETS="i386 x86_64 ppc64" RUBY_TARGETS="ruby18 ree18" USERLAND="GNU" VIDEO_CARDS="v4l2 nvidia intel vesa fbdev nouveau" XTABLES_ADDONS="cui gfw zhang" multilib_abi="amd64 x86"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 颜烈彬 2011-10-07 10:25:22 UTC
Created attachment 289055 [details]
build.log.gz
Comment 2 颜烈彬 2011-10-07 10:27:00 UTC
Created attachment 289057 [details]
conf.log

generated by app-crypt/qca-ossl-2.0.0_beta3-r2
Comment 3 Alon Bar-Lev gentoo-dev 2012-12-21 23:50:47 UTC
as far as I know the moc which is installed at /usr/bin is building a specific ABI.

It is not crypto issue, nor package.

Is there any reason why this is opened on this specific package?
Comment 4 Alon Bar-Lev gentoo-dev 2013-01-12 22:18:36 UTC
I do not believe this is specific to this package, re-CC crypto if you think it is.

Thanks!
Comment 5 Johannes Huber gentoo-dev 2013-11-23 16:17:13 UTC
(In reply to Alon Bar-Lev from comment #4)
> I do not believe this is specific to this package, re-CC crypto if you think
> it is.
> 
> Thanks!

Because crypto herd is in the maintainer list.
Comment 6 Michael Palimaka (kensington) gentoo-dev 2014-10-31 13:18:07 UTC
As per bug #277711 comment #25, we don't support multilib-portage and it might not even be possible. We can look at multilib support via eclass in the future if it's required.