Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385897 - media-gfx/enblend-4.0 USE=image-cache - ?
Summary: media-gfx/enblend-4.0 USE=image-cache - ?
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-06 18:57 UTC by Johannes Niess
Modified: 2013-09-06 20:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Niess 2011-10-06 18:57:00 UTC
Disableing image-cache use flag compiles as expected

Reproducible: Always

Actual Results:  
../include/vigra/accessor.hxx:813: warning: array subscript is above array bounds
{standard input}: Assembler messages:
{standard input}:136252: Warning: end of file not at end of a line; newline inserted
{standard input}:136594: Error: bad register name `%'
{standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
x86_64-pc-linux-gnu-g++: Internal error: Killed (program cc1plus)
Comment 1 Jeroen Roovers gentoo-dev 2013-08-06 21:08:46 UTC
1) Please attach the entire build log to this bug report.
2) Please post your `emerge --info' output in a comment.
Comment 2 Johannes Niess 2013-08-07 17:11:34 UTC
Build log and 'emerge --info' no longer available after 2 years.

Current version works as expected, including +image-cache:

niess@sawfish ~ $ eix -v enblend                                                                                                                                                                                                                           
* media-gfx/enblend                                                                                                                                                                                                                                          
     Available versions:  4.1.1                                                                                                                                                                                                                              
     IUSE (all versions): debug doc gpu +image-cache +openexr openmp                                                                                                                                                                                         
     Installed versions:  Version:   4.1.1                                                                                                                                                                                                                   
                          Date:      13:59:47 09.06.2013                                                                                                                                                                                                     
                          USE:       image-cache openmp -debug -doc -gpu -openexr
Comment 3 Markus Meier gentoo-dev 2013-09-06 20:53:24 UTC
I guess we can close this bug, since vigra is not bundled anymore.