Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385819 - app-cdr/dvdisaster-0.72.2[debug] does not respect LDFLAGS ( only --hash-style=gnu )
Summary: app-cdr/dvdisaster-0.72.2[debug] does not respect LDFLAGS ( only --hash-style...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal QA (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords: REGRESSION
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2011-10-05 23:34 UTC by Agostino Sarubbo
Modified: 2011-10-08 11:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (dvdisaster-0.72.2:20111005-232939.log,74.55 KB, text/plain)
2011-10-05 23:34 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2011-10-05 23:34:56 UTC
Created attachment 288927 [details]
build.log

app-cdr/dvdisaster-0.72.2 does not respect LDFLAGS
Comment 1 Samuli Suominen gentoo-dev 2011-10-08 10:14:23 UTC
It does here. I'm unable to reproduce this and upstream CHANGELOG says:

- configure will now correctly honor $LDFLAGS from the user environment

Then GNUmakefile.template has:

LOPTS = $(LDFLAGS) [cut off rest of the line]

Followed by:

$(CC) $(LOPTS) $(OFILES) $(LIBS) -o dvdisaster [cut off rest of the line]
Comment 2 Agostino Sarubbo gentoo-dev 2011-10-08 10:26:22 UTC
(In reply to comment #1)
> It does here. I'm unable to reproduce this and upstream CHANGELOG says:
added more info to the summary
Comment 3 Samuli Suominen gentoo-dev 2011-10-08 11:03:05 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > It does here. I'm unable to reproduce this and upstream CHANGELOG says:
> added more info to the summary

That's exactly what I'm using and can't reproduce.

$ emerge --info |grep LDFLAGS
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
Comment 4 Samuli Suominen gentoo-dev 2011-10-08 11:03:25 UTC
Ahh, USE=debug, hold on a moment
Comment 5 Samuli Suominen gentoo-dev 2011-10-08 11:11:53 UTC
+  08 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> dvdisaster-0.72.2.ebuild:
+  Remove --debug which was only overriding flags from environment with -ggdb
+  wrt #385819 by Agostino Sarubbo