Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385643 - sys-power/hibernate-script-2.0-r3 init script should change opts variable to use either extra_commands or extra_started_commands
Summary: sys-power/hibernate-script-2.0-r3 init script should change opts variable to ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Krzysztof Pawlik (RETIRED)
URL: http://sources.gentoo.org/cgi-bin/vie...
Whiteboard:
Keywords:
: 425762 (view as bug list)
Depends on:
Blocks: init.d-depr-opts
  Show dependency tree
 
Reported: 2011-10-04 17:56 UTC by Martin von Gagern
Modified: 2012-07-11 02:46 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
correct the 'einfon' typo (hibernate-script-2.0-init.d.patch,988 bytes, patch)
2012-06-07 20:07 UTC, Khayyam
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin von Gagern 2011-10-04 17:56:59 UTC
The sys-power/hibernate-script-2.0-r3 init script uses variables deprecated by sys-apps/openrc-0.9.x. See bug #381895 for details.

 * Use of the opts variable is deprecated and will be
 * removed in the future.
 * Please use extra_commands or extra_started_commands.
 * Invalidating stale software suspend images ...        [ ok ]
Comment 1 Krzysztof Pawlik (RETIRED) gentoo-dev 2011-11-30 19:22:56 UTC
Fixed in 2.0-r4.
Comment 2 Khayyam 2012-06-07 20:07:00 UTC
Created attachment 314609 [details, diff]
correct the 'einfon' typo

The init.d script, both for 2.0-r1 and 2.0-r4, contains a typo:

+   einfon "$1"

Attatched patch corrects this, and corrects 'opts', and (and also removes approx 8 or 9 lines of whitespace present in the tuxonice script).

Shouldn't -r4 now be arch by now?

best ... khayyam
Comment 3 Jeroen Roovers gentoo-dev 2012-07-11 02:46:24 UTC
*** Bug 425762 has been marked as a duplicate of this bug. ***