Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385609 - app-editors/xemacs-21.4.22-r2 calls gcc directly
Summary: app-editors/xemacs-21.4.22-r2 calls gcc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: XEmacs team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-04 14:58 UTC by Ian Delaney (RETIRED)
Modified: 2011-10-04 21:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
path for ebuild adds tc-getCC (xemacs-ebuild.patch,690 bytes, patch)
2011-10-04 15:39 UTC, Ian Delaney (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Delaney (RETIRED) gentoo-dev 2011-10-04 14:58:59 UTC
Reproducible: Always

Steps to Reproduce:
1. emerge package with ebuild /path/to/xemacs-21.4.22-r2.ebuild install to make a build lig
2. 
3.
Actual Results:  
log revelas entries with

gcc -c -march=athlon64 -O2 -pipe -fomit-frame-pointer

Expected Results:  
to call x86_64-pc-linux-gnu-gcc

autoconf version appears out of date
Comment 1 Ian Delaney (RETIRED) gentoo-dev 2011-10-04 15:39:36 UTC
Created attachment 288783 [details, diff]
path for ebuild adds tc-getCC

Seems it's fixed with above
Comment 2 Hans de Graaff gentoo-dev 2011-10-04 18:50:18 UTC
(In reply to comment #1)
> Created attachment 288783 [details, diff]
> path for ebuild adds tc-getCC
> 
> Seems it's fixed with above

This fix will cause hard-to-track bugs because now the configure script is run with a different compiler than the actual build, possibly leading to discrepancies in types.

I've fixed it by providing the right compiler to the configure script.
Comment 3 Ian Delaney (RETIRED) gentoo-dev 2011-10-04 21:04:17 UTC
that's another lesson learned. 
It is fixed.