Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385147 - =sys-apps/dbus-1.4*: crash via xfce4-panel
Summary: =sys-apps/dbus-1.4*: crash via xfce4-panel
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-30 22:10 UTC by Michael Orlitzky
Modified: 2013-05-13 13:13 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Backtrace from crash (xfce4-panel-gdb.txt,16.32 KB, text/plain)
2011-09-30 22:10 UTC, Michael Orlitzky
Details
emerge --info (emerge.info,13.86 KB, text/plain)
2011-10-02 18:52 UTC, Michael Orlitzky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Orlitzky gentoo-dev 2011-09-30 22:10:35 UTC
Created attachment 288417 [details]
Backtrace from crash

I can reproduce this by doing the following:

1) Right click my panel
2) Panel Properties
3) Add a new panel
4) Drag it anywhere
5) Boom

It looks like the problem is in DBUS to me, since it fails an assertion with debugging enabled. With debugging off, I was getting a glibc "double free or corruption."

Before this backtrace, I recompiled xfconf, xfce4-panel, dbus, and dbus-glib with CFLAGS="-ggdb", FEATURES="nostrip", and USE="debug".
Comment 1 SpanKY gentoo-dev 2011-10-02 18:29:20 UTC
please post `emerge --info` with all your bug reports
Comment 2 Michael Orlitzky gentoo-dev 2011-10-02 18:52:17 UTC
Created attachment 288589 [details]
emerge --info

Note that $FEATURES, $USE, $CFLAGS, and even $ACCEPT_KEYWORDS had been overridden in the original report.

I was able work around this by wiping my XFCE config and starting over with two empty panels; however, there's still a bug in either DBUS or Xfconf depending on whether or not DBUS clients are supposed to be able to cause it to fail assertions.
Comment 3 Samuli Suominen gentoo-dev 2013-05-13 13:13:07 UTC
Use XFCONF_FULL_DEBUG=yes in addition to those you mentioned earlier to really get ALL data

And try dbus-1.6.10, reopen the bug if the problem persists with later copies in tree