Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 384947 - media-video/aacskeys-0.4.0c-r1: please update ProcessingDeviceKeysSimple.txt
Summary: media-video/aacskeys-0.4.0c-r1: please update ProcessingDeviceKeysSimple.txt
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: media-video herd
URL: http://vlc-aacs.whoknowsmy.name/files...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-29 15:03 UTC by Alexander E. Patrakov
Modified: 2018-10-08 12:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
aacskeys-0.4.0e.ebuild (aacskeys-0.4.0e.ebuild,1.00 KB, text/plain)
2013-04-03 21:00 UTC, Wojciech Myrda
Details
HostKeyCertificate_org.txt.diff (HostKeyCertificate_org.txt.diff,363 bytes, patch)
2013-04-03 21:02 UTC, Wojciech Myrda
Details | Diff
HostKeyCertificate_PD7.txt.diff (HostKeyCertificate_PD7.txt.diff,361 bytes, patch)
2013-04-03 21:02 UTC, Wojciech Myrda
Details | Diff
HostKeyCertificate_PS3.txt.diff (HostKeyCertificate_PS3.txt.diff,355 bytes, patch)
2013-04-03 21:03 UTC, Wojciech Myrda
Details | Diff
HostKeyCertificate_v20.txt.diff (HostKeyCertificate_v20.txt.diff,371 bytes, patch)
2013-04-03 21:03 UTC, Wojciech Myrda
Details | Diff
ProcessingDeviceKeysSimple.txt.diff (ProcessingDeviceKeysSimple.txt.diff,1.09 KB, patch)
2013-04-03 21:04 UTC, Wojciech Myrda
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander E. Patrakov 2011-09-29 15:03:15 UTC
The set of processing keys in the included ProcessingDeviceKeysSimple.txt file is not enough for playing modern BluRay disks. Namely, this file doesn't include anything after MKB v10. An updated version of this file is available at http://ysk.orz.hm/BD/DeviceKey_MediaKey/ProcessingDeviceKeysSimple.txt which includes keys up to MKB v25.

Reproducible: Always

Steps to Reproduce:
1. USE=bluray emerge -av mplayer2 aacskeys libaacs  # from local overlay
2. Copy the keys to /etc/xdg/aacs
3. mplayer2 br:////media/ONE_NIGHT_ONLY_BARBRASTREISAND^_

Actual Results:  
mplayer2 cannot decrypt this BluRay (given the existing ProcessingDeviceKeysSimple.txt file from the aacskeys ebuild)

Expected Results:  
mplayer2 plays the BluRay (it does if I update the ProcessingDeviceKeysSimple.txt file)
Comment 1 Alexander E. Patrakov 2012-08-23 16:40:14 UTC
New keys are now available, referenced here: http://vlc-aacs.whoknowsmy.name/files/KEYDB.cfg

However, they are not in the same format. They do work with mplayer without any modification to the file.
Comment 2 Wojciech Myrda 2013-04-03 21:00:47 UTC
Created attachment 344284 [details]
aacskeys-0.4.0e.ebuild

Quite some time ago the package in new version 0.4.0e has been released. The attached is an ebuild proposition.

It does need a fix however. I am not sure why but those patches that it includes for HostCertificate apply cleanly but into /dev/null it seems as they are not available in "${S}" for doins to find it. ProcessingDeviceKeysSimple.txt on the other hand patches properly as it touches an existing file

There are probably better SRC_URI's for it as well but https://aur.archlinux.org/packages/aacskeys was only legimate place I found it
Comment 3 Wojciech Myrda 2013-04-03 21:02:32 UTC
Created attachment 344286 [details, diff]
HostKeyCertificate_org.txt.diff

patch 1/5
Comment 4 Wojciech Myrda 2013-04-03 21:02:55 UTC
Created attachment 344288 [details, diff]
HostKeyCertificate_PD7.txt.diff

patch 2/5
Comment 5 Wojciech Myrda 2013-04-03 21:03:28 UTC
Created attachment 344290 [details, diff]
HostKeyCertificate_PS3.txt.diff

patch 3/5
Comment 6 Wojciech Myrda 2013-04-03 21:03:57 UTC
Created attachment 344292 [details, diff]
HostKeyCertificate_v20.txt.diff

patch 4/5
Comment 7 Wojciech Myrda 2013-04-03 21:04:19 UTC
Created attachment 344294 [details, diff]
ProcessingDeviceKeysSimple.txt.diff

patch 5/5
Comment 8 Steve Dibb (RETIRED) gentoo-dev 2014-02-21 05:25:02 UTC
Are the HostKey(In reply to Wojciech Myrda from comment #3)
> Created attachment 344286 [details, diff] [details, diff]
> HostKeyCertificate_org.txt.diff
> 
> patch 1/5

Are the diffs supposed to apply to the original HostKeyCertificate.txt are they supposed to be installed as separate files?
Comment 9 Steve Dibb (RETIRED) gentoo-dev 2018-02-22 22:52:56 UTC
# Steve Dibb <beandog@gentoo.org> (22 Feb 2018)
# Dead upstream, long since replaced by libaacs for functionality.
# Masked for removal in 30 days. Bug #648560
media-video/aacskeys
Comment 10 Virgil Dupras gentoo-dev 2018-10-08 12:17:09 UTC
Removed from the tree in april.