Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 384869 - app-admin/webalizer should not die on USE=nls and no LINGUAS in pkg_setup
Summary: app-admin/webalizer should not die on USE=nls and no LINGUAS in pkg_setup
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
: 310845 678618 (view as bug list)
Depends on:
Blocks: 287931
  Show dependency tree
 
Reported: 2011-09-29 02:34 UTC by Paweł Hajdan, Jr. (RETIRED)
Modified: 2020-08-18 11:34 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-09-29 02:34:47 UTC
* you must set LINGUAS in /etc/make.conf
 * if you want to USE=nls
 * ERROR: app-admin/webalizer-2.01.10-r15 failed (setup phase):
 *   please either set LINGUAS or do not use nls
 * 
 * Call stack:
 *                      ebuild.sh, line  56:  Called pkg_setup
 *   webalizer-2.01.10-r15.ebuild, line  46:  Called die
 * The specific snippet of code:
 *              die "please either set LINGUAS or do not use nls"

That's quite annoying especially in arch testing / tinderboxing context.

Could you please either:

a) use EAPI=4 and do the check in pkg_pretend
b) make the check non-fatal, i.e. do not die, but maybe effectively disable nls?
Comment 1 Anthony Basile gentoo-dev 2013-01-13 14:46:53 UTC
I just adopted this puppy and I'll add that at some point when I rev bump.
Comment 2 Anthony Basile gentoo-dev 2013-01-13 14:50:01 UTC
*** Bug 310845 has been marked as a duplicate of this bug. ***
Comment 3 Toralf Förster gentoo-dev 2018-05-22 16:56:24 UTC
pong
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2020-08-18 11:34:37 UTC
*** Bug 678618 has been marked as a duplicate of this bug. ***