Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 384823 - Stabilize =media-gfx/povray-3.7.0_rc3 (was: fails to build with libpng15 and "conflicting type" of jpeg caused by some flags)
Summary: Stabilize =media-gfx/povray-3.7.0_rc3 (was: fails to build with libpng15 and ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Joe Peterson (RETIRED)
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 384701 387465
  Show dependency tree
 
Reported: 2011-09-28 17:58 UTC by Joe Peterson (RETIRED)
Modified: 2011-10-29 19:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Peterson (RETIRED) gentoo-dev 2011-09-28 17:58:39 UTC
The previously long-stable version (3.6.1-r4) was broken due to incompatibility with libjpeg > 6b (and 6b is not marked stable).

Version 3.7.0_rc3 has been the latest version for a very long time, so even though it is marked as an RC by upstream, I believe it should be marked stable at this point.  We can wait 30 days and mark the fixed 3.6.1-r5 stable as well, but it would be good to have a working stable version in the tree now.

Reproducible: Always
Comment 1 Joe Peterson (RETIRED) gentoo-dev 2011-09-30 21:18:20 UTC
More info:

A fix for 3.6.1-r4 is known and now being verified, but it will be ~arch and not stabilized immediately since it requires rebuilding.

To test 3.7.0_rc3, please just emerge it with FEATURES="test".  You should see a small image appear momentarily, and the test should pass.
Comment 2 Ian Delaney (RETIRED) gentoo-dev 2011-10-06 19:52:24 UTC
amd64:

emerges, passes the test phase
Comment 3 Jeroen Roovers gentoo-dev 2011-10-17 14:12:57 UTC
Stable for HPPA.
Comment 4 Samuli Suominen gentoo-dev 2011-10-17 21:34:03 UTC
Blocking libpng 1.5 stabilization wrt bug #387465.
Comment 5 Elijah "Armageddon" El Lazkani (amd64 AT) 2011-10-19 03:01:57 UTC
amd64: pass
Comment 6 Samuli Suominen gentoo-dev 2011-10-19 13:06:50 UTC
amd64 done
Comment 7 Samuli Suominen gentoo-dev 2011-10-21 16:42:17 UTC
x86 stable
Comment 8 Raúl Porcel (RETIRED) gentoo-dev 2011-10-29 16:20:03 UTC
alpha/ia64/sparc stable
Comment 9 Samuli Suominen gentoo-dev 2011-10-29 19:49:01 UTC
ppc/ppc64 stable