Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 384731 - sys-devel/libtool-2.4[-static-libs] fails runpath-in-lalib.at / need_lib_prefix.at
Summary: sys-devel/libtool-2.4[-static-libs] fails runpath-in-lalib.at / need_lib_pref...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 391305 395475 516808 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-27 22:12 UTC by Markus Oehme
Modified: 2014-11-01 02:44 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,47.38 KB, text/plain)
2011-09-27 22:12 UTC, Markus Oehme
Details
emerge --info (info.txt,5.40 KB, text/plain)
2011-09-27 22:12 UTC, Markus Oehme
Details
testsuite.log for failing tests 42, 84, 112 (testsuite.log,158.62 KB, text/plain)
2011-10-02 21:19 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Oehme 2011-09-27 22:12:25 UTC
Created attachment 288013 [details]
build log

On my hardened ~amd64 machine with gcc-4.6.1 sys-devel/libtool fails its testsuite. More exactly it fails tests 42, 84, 112.

42: Runpath in libtool library files FAILED (runpath in-lalib.at:61)
84: enforced lib prefix FAILED (need_lib_prefix.at:170)
112: Run tests with low max_cmd_len FAILED (cmdline_wrap.at:43)

ERROR: 107 tests were run,
8 failed (5 expected failures).
13 tests were skipped.

If I switch to vanilla-gcc-4.6.1 the result stays the same.
Comment 1 Markus Oehme 2011-09-27 22:12:40 UTC
Created attachment 288015 [details]
emerge --info
Comment 2 SpanKY gentoo-dev 2011-10-02 18:23:57 UTC
we need the testsuite.log file attached
Comment 3 Markus Oehme 2011-10-02 21:19:55 UTC
Created attachment 288609 [details]
testsuite.log for failing tests 42, 84, 112

Here you go!
Comment 4 Yaroslav Isakov 2011-11-01 21:03:08 UTC
I can confirm it - on my system (Portage 2.1.10.3 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.12.2-r0, 3.1.0-gentoo x86_64) these test was failed too.
Comment 5 Jason Bucata 2013-10-21 02:12:17 UTC
This also failed for me, on libtool-2.4.2.  I do *NOT* use hardened, which may help to simplify the situation.  This is amd64.  I still have my 32-bit install so I might be able to attempt this there if interested.  I'm on gcc 4.6.3.

The test numbers are now 42, 86, and 115.
Comment 6 SpanKY gentoo-dev 2014-10-28 00:14:06 UTC
*** Bug 391305 has been marked as a duplicate of this bug. ***
Comment 7 SpanKY gentoo-dev 2014-10-28 00:14:47 UTC
*** Bug 395475 has been marked as a duplicate of this bug. ***
Comment 8 SpanKY gentoo-dev 2014-10-28 00:15:19 UTC
*** Bug 516808 has been marked as a duplicate of this bug. ***
Comment 10 SpanKY gentoo-dev 2014-11-01 02:28:51 UTC
looks like the last two fail only when --disable-static is used
Comment 11 SpanKY gentoo-dev 2014-11-01 02:44:06 UTC
should be all set now in the tree; thanks for the report!

Commit message: Move up the libtool static hack to fix unit tests too
http://sources.gentoo.org/sys-devel/libtool/libtool-2.4.3-r1.ebuild?r1=1.4&r2=1.5