Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 384481 - sys-apps/tuxonice-userui-1.0 fails to build with libpng15
Summary: sys-apps/tuxonice-userui-1.0 fails to build with libpng15
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Krzysztof Pawlik (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-09-25 22:47 UTC by Bill Kenworthy
Modified: 2011-12-27 11:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
tuxonice-userui-1.0-libpng15.patch (foo.patch,3.28 KB, patch)
2011-09-26 14:30 UTC, Samuli Suominen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Kenworthy 2011-09-25 22:47:39 UTC
sys-apps/tuxonice-userui-1.0 fails to build with libpng15 which is currently ~x86

Reproducible: Always




make[1]: Entering directory `/tmp/portage/sys-apps/tuxonice-userui-1.0/work/tuxonice-userui-1.0/fbsplash'
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c userui_fbsplash_core.c -o userui_fbsplash_core.o
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c cmd.c -o cmd.o
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c common.c -o common.o
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c effects.c -o effects.o
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c image.c -o image.o
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c list.c -o list.o
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c parse.c -o parse.o
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c mng_callbacks.c -o mng_callbacks.o
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c mng_render.c -o mng_render.o
i686-pc-linux-gnu-gcc -w -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2/ -I. -c render.c -o render.o
image.c: In function ‘load_png’:
image.c:115:22: error: dereferencing pointer to incomplete type
image.c:120:14: error: dereferencing pointer to incomplete type
image.c:121:14: error: dereferencing pointer to incomplete type
image.c:124:14: error: dereferencing pointer to incomplete type
image.c:127:29: error: dereferencing pointer to incomplete type
image.c:131:16: error: dereferencing pointer to incomplete type
image.c:137:23: error: dereferencing pointer to incomplete type
image.c:137:54: error: dereferencing pointer to incomplete type
image.c:153:34: error: dereferencing pointer to incomplete type
image.c:153:86: error: dereferencing pointer to incomplete type
image.c:157:20: error: dereferencing pointer to incomplete type
image.c:158:21: error: dereferencing pointer to incomplete type
image.c:174:26: error: dereferencing pointer to incomplete type
image.c:176:34: error: dereferencing pointer to incomplete type
image.c:178:34: error: dereferencing pointer to incomplete type
image.c:187:24: error: dereferencing pointer to incomplete type
image.c:199:50: error: dereferencing pointer to incomplete type
image.c:199:81: error: dereferencing pointer to incomplete type
make[1]: *** [image.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/tmp/portage/sys-apps/tuxonice-userui-1.0/work/tuxonice-userui-1.0/fbsplash'
make: *** [fbsplash] Error 2
emake failed
 * ERROR: sys-apps/tuxonice-userui-1.0 failed (compile phase):
 *   emake tuxoniceui_fbsplash failed
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 2231:  Called die
 * The specific snippet of code:
 *           emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" tuxoniceui_fbsplash || die "emake tuxoniceui_fbsplash failed";
 * 
 * If you need support, post the output of 'emerge --info =sys-apps/tuxonice-userui-1.0',
 * the complete build log and the output of 'emerge -pqv =sys-apps/tuxonice-userui-1.0'.
 * The complete build log is located at '/var/log/emerge/sys-apps:tuxonice-userui-1.0:20110925-224057.log'.
 * The ebuild environment file is located at '/tmp/portage/sys-apps/tuxonice-userui-1.0/temp/environment'.
 * S: '/tmp/portage/sys-apps/tuxonice-userui-1.0/work/tuxonice-userui-1.0'

>>> Failed to emerge sys-apps/tuxonice-userui-1.0, Log file:

>>>  '/var/log/emerge/sys-apps:tuxonice-userui-1.0:20110925-224057.log'
moriah ~ #


moriah ~ # emerge --info
Portage 2.1.10.11 (default/linux/x86/10.0, gcc-4.5.3, glibc-2.12.2-r0, 2.6.39-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.39-gentoo-r4-i686-Pentium-R-_Dual-Core_CPU_E6600_@_3.06GHz-with-gentoo-2.0.3
Timestamp of tree: Sun, 25 Sep 2011 00:15:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.5.4-r4, 2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.4_p6-r1, 1.5-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo Mythtv-Ebuilds x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 Oracle-BCLA-JavaSE sun-bcla-java-vm AdobeFlash-10 AdobeFlash-10.1"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-w -march=core2 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-w -march=core2 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://ftp.iinet.net.au/pub/Gentoo"
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_AU.UTF-8"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/mythtv_portage/Gentoo /usr/local/portage"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="16bittmp X aac aalib acpi activefilter adns adplug alaw alsa ao apache2 asterisk async audacious bash-completion berkdb bgpclassless binfilter branding browserplugin bs2b buffysize bzip2 cairo calendar cdda cddb cdparanoia cdr cgi clamav cli cracklib crypt cscope ctype cue cups curl curlwrappers customlog cvs cxx dba dbus dedicated device-mapper dga dhcp dirac directfb djvu dlloader dri dv dvb dvd dvi eds encode erandom esd examples extensions extras faac fam fbcon fbsplash ffmpeg filter fits flac flash fluidsynth follow-xff font-server fontconfig foomaticdb fortran fpx freetds frontendonly ftp gcj gcrypt gd gdbm gdu geos gif gimp gimpprint glib glibc-omitfp gml gnome gnome-keyring gnutls gpc gphoto2 gpm graphviz gs gsm gstreamer gtk gtk2 gtkhtml h323 hal hdf hdf5 hpn iconv idn ilbc imagemagick imap imlib innodb iproute2 java javascript jbig jpeg jpeg2k kate kdrive lame lcms ldap libclamav libnotify libsamplerate lm_sensors logrotate lua lzo mad mbrola midi mms mmx mmxext mng modules motif mozilla mozsvg mp3 mpeg mpi-threads mtp mudflap multipath multislot multiuser mysql nautilus ncurses netlink netpbm nls nntp no-htdocs nptl nptlonly nsplugin oav objc odbc ogdi ogg old-linux opengl ospfapi pam passwordsave pch pcre pda pdf pdo perl php png pnm policykit postgres ppds pppd proj python pyzord qemu-ifup qt3support quicktime rar readline rpm rtc samba scanner schroedinger scrobbler sdl seamonkey sensord server session sftplogging sid sip slp smi smp smux sndfile soap sockets sound speex spell sqlite sse sse2 ssl ssse3 startup-notification subversion svg svga swat sysfs syslog szip t1lib tcl tcltk tcpd templates tga theora threads tidy tiff tk tokenizer toolbar truetype udev ulaw underscores unicode unzip urandom usb v4l v4l2 vcd vde vidix vim-pager vim-syntax vim-with-x virus-scan vorbis vpx wav wavpack wddx webdav win32codecs wmf wxGTK x86 xanim xext xine xml xmlrpc xorg xpm xsl xulrunner xv xvid yaz zaptel zip zlib zrtp zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias cgid" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_AU.UTF-8" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel fbdev vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

moriah ~ #
Comment 1 Samuli Suominen gentoo-dev 2011-09-26 14:30:17 UTC
Created attachment 287779 [details, diff]
tuxonice-userui-1.0-libpng15.patch
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2011-09-26 15:34:39 UTC
Fixed
Comment 3 Bill Kenworthy 2011-09-26 22:42:14 UTC
Synced and rebuilt - fixed

tkx,
BillK
Comment 4 Samuli Suominen gentoo-dev 2011-12-27 11:29:50 UTC
http://git.tuxonice.net/?p=tuxonice-userui.git;a=blob_plain;f=Makefile;hb=HEAD (Makefile from git master) has problem of using -lpng12 instead of -lpng

I have only -lpng15 and -lpng on this system, since everything is compiled against the new library

I think it's best to simply... sed -i -e "s/png12/png/" Makefile
Comment 5 Samuli Suominen gentoo-dev 2011-12-27 11:30:17 UTC
(In reply to comment #4)
> http://git.tuxonice.net/?p=tuxonice-userui.git;a=blob_plain;f=Makefile;hb=HEAD
> (Makefile from git master) has problem of using -lpng12 instead of -lpng
> 
> I have only -lpng15 and -lpng on this system, since everything is compiled
> against the new library
> 
> I think it's best to simply... sed -i -e "s/png12/png/" Makefile

oops, wrong bugzilla :)