Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 384461 - =app-editors/xemacs-21.4.22-r1 fails to build with libpng15 (due to unsupported mixing of stable and ~arch)
Summary: =app-editors/xemacs-21.4.22-r1 fails to build with libpng15 (due to unsupport...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: XEmacs team
URL: http://tracker.xemacs.org/XEmacs/its/...
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-09-25 19:57 UTC by Michael Mol
Modified: 2011-09-26 18:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,49.18 KB, text/plain)
2011-09-25 20:01 UTC, Michael Mol
Details
environment (environment,107.22 KB, text/plain)
2011-09-25 20:02 UTC, Michael Mol
Details
xemacs-21.4.22-libpng15.patch (xemacs-libpng15.patch,2.53 KB, patch)
2011-09-26 16:51 UTC, Samuli Suominen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Mol 2011-09-25 19:57:31 UTC
Emerge fails with:

glyphs-eimage.c: In function ‘png_instantiate’:
glyphs-eimage.c:949: error: dereferencing pointer to incomplete type
glyphs-eimage.c:950: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1005: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1008: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1009: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1012: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1015: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1018: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1020: error: dereferencing pointer to incomplete type
make[1]: *** [glyphs-eimage.o] Error 1

In my case, this is after rebuilding the system going from "ldap" to "-ldap". Prior to adding "-ldap", the emerge worked fine.

Reproducible: Always

Steps to Reproduce:
1. emerge xemacs with ldap support.
2. Update make.conf to remove ldap support.
3. Emerge system with --update --newuse --deep.
Actual Results:  
glyphs-eimage.c: In function ‘png_instantiate’:
glyphs-eimage.c:949: error: dereferencing pointer to incomplete type
glyphs-eimage.c:950: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1005: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1008: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1009: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1012: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1015: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1018: error: dereferencing pointer to incomplete type
glyphs-eimage.c:1020: error: dereferencing pointer to incomplete type
make[1]: *** [glyphs-eimage.o] Error 1

Expected Results:  
Successful emerge.

Portage 2.1.10.11 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.12.2-r0, 2.6.39-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.39-gentoo-r3-x86_64-AMD_Phenom-tm-_9650_Quad-Core_Processor-with-gentoo-2.0.3
Timestamp of tree: Sun, 25 Sep 2011 13:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.5, 4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA google-talkplugin"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -mcx16 -msahf -mpopcnt --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=amdfam10 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -mcx16 -msahf -mpopcnt --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=amdfam10 -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ http://mirrors.cs.wmich.edu/gentoo http://gentoo.mirrors.tds.net/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync29.us.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 audiofile avahi bcmath berkdb bzip2 cleartype cli consolekit cracklib crypt cscope css cups curl curlwrappers cxx dbus dri encode exif fam ffmpeg fftw flac fontconfig fortran gdbm gif gimp glut gmp gnuplot gpm gsl gsm gtk gzip hddtemp iconv imagemagick imap imlib ipv6 jabber javascript jpeg jpeg2k kdrive lame lapack libedit libnotify libsamplerate libwww lm_sensors lzma lzo mad matroska mbox mikmod mime mmap mmx mng modules mono mozilla mp3 mp4 mpeg mplayer mudflap multilib musepack mysql ncurses nls nptl nptlonly nsplugin objc offensive ogg openal opencl openexr opengl openmp pam pcre perl php png portaudio posix ppds pppd python rdesktop readline samba sasl seamonkey semantic-desktop session sharedmem shorten simplexml smp sndfile sox speex spell sse sse2 ssl subversion svg symlink sysfs syslog sysvipc szip taglib tcl tcpd theora threads timidity truetype udev unicode usb v4l2 videos vnc vorbis wavpack webkit wmf x264 xattr xcb xcomposite xft xinetd xml xmlrpc xmp xorg xpm xscreensaver xv xvid yahoo zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michael Mol 2011-09-25 20:00:58 UTC
emerge -pqv =app-editors/xemacs-21.4.22-r1

[ebuild   R   ] app-editors/xemacs-21.4.22-r1  USE="X berkdb gdbm gif gpm jpeg png -Xaw3d -athena -canna -dnd -eolconv -esd -freewnn -ldap* -motif -mule -nas -neXt -pop -postgres -tiff -xface -xim"
Comment 2 Michael Mol 2011-09-25 20:01:33 UTC
Created attachment 287725 [details]
build.log
Comment 3 Michael Mol 2011-09-25 20:02:40 UTC
Created attachment 287727 [details]
environment
Comment 4 Samuli Suominen gentoo-dev 2011-09-26 06:00:42 UTC
The real question is, why are you mixing unstable marked libpng15 with stable marked xemacs?
Comment 5 Samuli Suominen gentoo-dev 2011-09-26 06:07:48 UTC
Moving to xemacs maintainers anyway to say "It's time to stabilize new version of xemacs since libpng15 will go stable soon."
Comment 6 Hans de Graaff gentoo-dev 2011-09-26 06:16:46 UTC
(In reply to comment #5)
> Moving to xemacs maintainers anyway to say "It's time to stabilize new version
> of xemacs since libpng15 will go stable soon."

Not going to happen any time soon because xemacs 21.5 really isn't ready for stable. This will need to be fixed in 21.4 instead.
Comment 7 Samuli Suominen gentoo-dev 2011-09-26 06:39:32 UTC
Blocking bug 354479 then.
Comment 8 Michael Mol 2011-09-26 14:42:09 UTC
To answer Samuli's question...I've had ~amd64 for libpng for so long, I forgot about it. I don't even remember why I put it in there.

xemacs is the only failing package on my system out of the 25 which depend on libpng.

It would probably be sufficient to modify the ebuild to indicate it depends on libpng prior to 1.5. equery d libpng shows:

app-editors/xemacs-21.4.22-r1 (png ? >=media-libs/libpng-1.2)

Perhaps that should be (( >= media-libs/libpng-1.2) && (<media-libs/libpng-1.5))?
Comment 9 Samuli Suominen gentoo-dev 2011-09-26 16:51:11 UTC
Created attachment 287805 [details, diff]
xemacs-21.4.22-libpng15.patch

NOTE: To be applied *after* existing -large-images.patch
Comment 10 Hans de Graaff gentoo-dev 2011-09-26 18:30:55 UTC
Thanks for the patch. Fixed in xemacs-21.4.22-r2.