Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 384313 - media-video/vlc vlc-cache-gen Segmentation fault on hardened system
Summary: media-video/vlc vlc-cache-gen Segmentation fault on hardened system
Status: RESOLVED DUPLICATE of bug 405173
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-24 16:30 UTC by Anton Kochkov
Modified: 2013-08-03 13:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build log (vlc4.log,940.23 KB, text/plain)
2011-09-24 16:30 UTC, Anton Kochkov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Kochkov 2011-09-24 16:30:08 UTC
Created attachment 287609 [details]
full build log

CCLD   vlc-cache-gen
  GEN    ../modules/plugins.dat
/bin/sh: line 4: 21398 Segmentation fault      ./vlc-cache-gen ../modules
make[2]: *** [../modules/plugins.dat] Error 139
make[2]: Leaving directory `/var/tmp/portage/media-video/vlc-9999/work/vlc-9999/bin'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-video/vlc-9999/work/vlc-9999'
make: *** [all] Error 2
 * ERROR: media-video/vlc-9999 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of 'emerge --info =media-video/vlc-9999',
 * the complete build log and the output of 'emerge -pqv =media-video/vlc-9999'.
 * The complete build log is located at '/var/tmp/portage/media-video/vlc-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-9999/temp/environment'.
 * S: '/var/tmp/portage/media-video/vlc-9999/work/vlc-9999'

>>> Failed to emerge media-video/vlc-9999, Log file:

>>>  '/var/tmp/portage/media-video/vlc-9999/temp/build.log'


emerge --info output: https://bugs.gentoo.org/attachment.cgi?id=285883
Comment 1 Carl Michal 2012-08-23 17:15:31 UTC
Are you using proprietary nvidia drivers?

Is this a duplicate of #405173?

Try:

USE="-libnotify -svg -xv -xcb"

or, try compiling after: 

eselect opengl set xorg-x11
Comment 2 Anton Kochkov 2012-08-23 17:26:36 UTC
(In reply to comment #1)
> Are you using proprietary nvidia drivers?
> 
> Is this a duplicate of #405173?
> 
> Try:
> 
> USE="-libnotify -svg -xv -xcb"
> 
> or, try compiling after: 
> 
> eselect opengl set xorg-x11

Strange, but looks like it was just accidentally crash, I can't reproduce this bug anymore, on any of my machines.
Comment 3 Anton Kochkov 2012-08-23 17:30:04 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Are you using proprietary nvidia drivers?
> > 
> > Is this a duplicate of #405173?
> > 
> > Try:
> > 
> > USE="-libnotify -svg -xv -xcb"
> > 
> > or, try compiling after: 
> > 
> > eselect opengl set xorg-x11
> 
> Strange, but looks like it was just accidentally crash, I can't reproduce
> this bug anymore, on any of my machines.

Ah, forgot to mention, that I'm using xf86-video-intel on i7 sandybridge
Comment 4 Tassilo Horn 2013-07-11 17:49:59 UTC
I get the same compile error (reproducible) with vlc 2.0.7 also using x11-drivers/xf86-video-intel-2.21.11.

Compiling with  USE="-libnotify -svg -xv -xcb" did work, though.
Comment 5 Tassilo Horn 2013-07-11 17:50:24 UTC
(In reply to Tassilo Horn from comment #4)
> I get the same compile error (reproducible) with vlc 2.0.7 also using
> x11-drivers/xf86-video-intel-2.21.11.
> 
> Compiling with  USE="-libnotify -svg -xv -xcb" did work, though.

Ah, btw, this is not a hardened system here.
Comment 6 Denis M. (Phr33d0m) 2013-08-03 13:14:55 UTC
Being hardened or not is irrelevant here. Merging this bug with the more active one on the issue.

*** This bug has been marked as a duplicate of bug 405173 ***