Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 383799 - media-gfx/iscan-2.26.2 fails to emerge with libpng15
Summary: media-gfx/iscan-2.26.2 fails to emerge with libpng15
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Stefan Briesenick (RETIRED)
URL: http://www.avasys.jp/cgi-bin/lx/bbs/e...
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-09-20 10:18 UTC by Oleh
Modified: 2013-02-26 19:29 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,25.66 KB, text/plain)
2011-09-20 11:43 UTC, Oleh
Details
full iscan build log (iscan-2.26.2-build.log,25.47 KB, text/plain)
2011-09-21 19:57 UTC, Guy
Details
build.log (build.log,25.34 KB, text/plain)
2011-09-24 10:12 UTC, liva
Details
Patch attempt (iscan-2.26.2-libpng15.patch,557 bytes, patch)
2011-09-26 15:53 UTC, Samuli Suominen
Details | Diff
Another patch attempt (iscan-libpng15.patch,1.46 KB, text/plain)
2011-09-29 20:10 UTC, Ian Stakenvicius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleh 2011-09-20 10:18:42 UTC
After update to media-libs/libpng-1.5.4, iscan emerge failure occurs. Downgrade to 1.4.8-r1 makes it build and emerged withoput errors.

Reproducible: Always

Steps to Reproduce:
1.emerge =media-libs/libpng-1.5.4
2.emerge iscan, notice an emrge failure
3.emerge =media-libs/libpng-1.4.8-r1
4.emerge iscan works
Actual Results:  
make[3]: Leaving directory `/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2/lib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2'
make: *** [all] Error 2
emake failed
 * ERROR: media-gfx/iscan-2.26.2 failed (compile phase):
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   69:  Called src_compile
 *   environment, line 3184:  Called _eapi2_src_compile
 *     ebuild.sh, line  722:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =media-gfx/iscan-2.26.2',
 * the complete build log and the output of 'emerge -pqv =media-gfx/iscan-2.26.2'.
 * The complete build log is located at '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/environment'.
 * S: '/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2'

>>> Failed to emerge media-gfx/iscan-2.26.2, Log file:

>>>  '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/build.log'

 * Messages for package media-gfx/iscan-2.26.2:

 * ERROR: media-gfx/iscan-2.26.2 failed (compile phase):
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   69:  Called src_compile
 *   environment, line 3184:  Called _eapi2_src_compile
 *     ebuild.sh, line  722:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =media-gfx/iscan-2.26.2',
 * the complete build log and the output of 'emerge -pqv =media-gfx/iscan-2.26.2'.
 * The complete build log is located at '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/environment'.
 * S: '/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2'

Expected Results:  
media-gfx/iscan-2.2.6.2 emerged nad installed

emerge --info
Portage 2.3-r7 (default/linux/amd64/2008.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.32-042stab036.6 x86_64)
=================================================================
System uname: Linux-2.6.32-042stab036.6-x86_64-Intel-R-_Xeon-R-_CPU_E5530_@_2.40GHz-with-gentoo-2.1.8
Timestamp of tree: Tue, 20 Sep 2011 05:30:01 +0000
app-shells/bash:          4.2_p10
dev-lang/python:          2.7.1-r2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1.8-r2
sys-apps/openrc:          0.8.3-r2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1-r1
sys-devel/binutils:       2.20.1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.5
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.32 (virtual/os-headers)
sys-libs/glibc:           2.11.3
Repositories: gentoo
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages mini-manifest news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="git://github.com/funtoo/portage-mini-2011.git"
SYNC_USER="root"
USE="X acl alac alsa amd64 berkdb bzip2 cdr cli consolekit cracklib crypt cups cxx dbus dri dvd dvdr dvdread encode flac fortran gdbm gif gpm iconv ipv6 jpeg lame mad mmx modules mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg openmp pam pcre perl png policykit pppd python readline session sse sse2 ssl sysfs tcpd tiff truetype unicode vorbis wavpack xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK
Comment 1 Rafał Mużyło 2011-09-20 10:34:46 UTC
Attach full build log.
Comment 2 Oleh 2011-09-20 11:43:31 UTC
Created attachment 287143 [details]
build.log
Comment 3 Rafał Mużyło 2011-09-20 12:30:44 UTC
OK, so 2.26.4 has been released, but this problem is also present there.

Might be a bit tricky to fix, as those two (num_rows and flush_rows don't seem to be exported anymore).
Comment 4 Guy 2011-09-21 19:57:38 UTC
Created attachment 287359 [details]
full iscan build log

Same issue here.

I'd rather not downgrade libpng at this point since I've gotten all my -lpng14 issues resolve.
Comment 5 liva 2011-09-24 10:12:05 UTC
Created attachment 287599 [details]
build.log
Comment 6 liva 2011-09-24 10:14:06 UTC
with media-libs/libpng-1.5.5 same

# emerge --info
Portage 2.1.10.19 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.13-r4, 3.0.4-gentoo-liva x86_64)
=================================================================
System uname: Linux-3.0.4-gentoo-liva-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.0.3
Timestamp of tree: Sat, 24 Sep 2011 07:30:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo betagarden local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.mirrors.tera-byte.com/ http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ http://de-mirror.org/distro/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo http://mirror.leaseweb.com/gentoo/ http://mirror2.corbina.ru/gentoo-distfiles/ http://mirror.yandex.ru/gentoo-distfiles/ http://mirror.switch.ch/ftp/mirror/gentoo/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/betagarden /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt css cups custom-optimization cxx dbus declarative dga djvu dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fontconfig fortran ftp gdbm gdu gif gimp gpm gtk handbook hddtemp iconv icq icu idn ieee1394 jabber jpeg jpeg2k kde kipi lcms ldap libnotify lm_sensors lzo mad matroska mime mmap mmx mng modules mozila mp3 mp4 mpeg mplayer mudflap multilib ncurses nls nntp nptl nptlonly ogg openal opengl openmp oscar pam pango pcre pda pdf perl phonon plasma png policykit ppds pppd python qt3support qt4 raw rdesktop readline rss samba scanner sdl session smp sms something spell sse sse2 ssl startup-notification svg sysfs syslog tcpd tiff truetype udev unicode usb usd vcd videos vnc vorbis wifi x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="snd-ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

https://bugs.gentoo.org/attachment.cgi?id=287599
Comment 7 Cedric Godin 2011-09-24 13:23:03 UTC
(In reply to comment #0)
> After update to media-libs/libpng-1.5.4, iscan emerge failure occurs. Downgrade
> to 1.4.8-r1 makes it build and emerged withoput errors.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.emerge =media-libs/libpng-1.5.4
> 2.emerge iscan, notice an emrge failure
> 3.emerge =media-libs/libpng-1.4.8-r1
> 4.emerge iscan works
> Actual Results:  
> make[3]: Leaving directory
> `/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2/lib'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory
> `/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2/lib'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory
> `/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2'
> make: *** [all] Error 2
> emake failed
>  * ERROR: media-gfx/iscan-2.26.2 failed (compile phase):
>  *   emake failed
>  *
>  * Call stack:
>  *     ebuild.sh, line   69:  Called src_compile
>  *   environment, line 3184:  Called _eapi2_src_compile
>  *     ebuild.sh, line  722:  Called die
>  * The specific snippet of code:
>  *              emake || die "emake failed"
>  *
>  * If you need support, post the output of 'emerge --info
> =media-gfx/iscan-2.26.2',
>  * the complete build log and the output of 'emerge -pqv
> =media-gfx/iscan-2.26.2'.
>  * The complete build log is located at
> '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/build.log'.
>  * The ebuild environment file is located at
> '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/environment'.
>  * S: '/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2'
> 
> >>> Failed to emerge media-gfx/iscan-2.26.2, Log file:
> 
> >>>  '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/build.log'
> 
>  * Messages for package media-gfx/iscan-2.26.2:
> 
>  * ERROR: media-gfx/iscan-2.26.2 failed (compile phase):
>  *   emake failed
>  *
>  * Call stack:
>  *     ebuild.sh, line   69:  Called src_compile
>  *   environment, line 3184:  Called _eapi2_src_compile
>  *     ebuild.sh, line  722:  Called die
>  * The specific snippet of code:
>  *              emake || die "emake failed"
>  *
>  * If you need support, post the output of 'emerge --info
> =media-gfx/iscan-2.26.2',
>  * the complete build log and the output of 'emerge -pqv
> =media-gfx/iscan-2.26.2'.
>  * The complete build log is located at
> '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/build.log'.
>  * The ebuild environment file is located at
> '/var/tmp/portage/media-gfx/iscan-2.26.2/temp/environment'.
>  * S: '/var/tmp/portage/media-gfx/iscan-2.26.2/work/iscan-2.26.2'
> 
> Expected Results:  
> media-gfx/iscan-2.2.6.2 emerged nad installed
> 
> emerge --info
> Portage 2.3-r7 (default/linux/amd64/2008.0, gcc-4.4.5, glibc-2.11.3-r0,
> 2.6.32-042stab036.6 x86_64)
> =================================================================
> System uname:
> Linux-2.6.32-042stab036.6-x86_64-Intel-R-_Xeon-R-_CPU_E5530_@_2.40GHz-with-gentoo-2.1.8
> Timestamp of tree: Tue, 20 Sep 2011 05:30:01 +0000
> app-shells/bash:          4.2_p10
> dev-lang/python:          2.7.1-r2
> dev-util/cmake:           2.8.5-r2
> dev-util/pkgconfig:       0.26
> sys-apps/baselayout:      2.1.8-r2
> sys-apps/openrc:          0.8.3-r2
> sys-apps/sandbox:         2.5
> sys-devel/autoconf:       2.68
> sys-devel/automake:       1.11.1-r1
> sys-devel/binutils:       2.20.1
> sys-devel/gcc:            4.4.5
> sys-devel/gcc-config:     1.5
> sys-devel/libtool:        2.4-r3
> sys-devel/make:           3.82-r3
> sys-kernel/linux-headers: 2.6.32 (virtual/os-headers)
> sys-libs/glibc:           2.11.3
> Repositories: gentoo
> Installed sets: 
> ACCEPT_KEYWORDS="amd64 ~amd64"
> ACCEPT_LICENSE="* -@EULA"
> CBUILD="x86_64-pc-linux-gnu"
> CFLAGS="-march=core2 -O2 -pipe"
> CHOST="x86_64-pc-linux-gnu"
> CONFIG_PROTECT="/etc"
> CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf
> /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo
> /etc/udev/rules.d"
> CXXFLAGS="-march=core2 -O2 -pipe"
> DISTDIR="/usr/portage/distfiles"
> FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles
> fixpackages mini-manifest news parallel-fetch preserve-libs protect-owned
> sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans
> userfetch"
> FFLAGS=""
> GENTOO_MIRRORS="http://distfiles.gentoo.org"
> LANG="en_US.UTF-8"
> LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
> MAKEOPTS="-j12"
> PKGDIR="/usr/portage/packages"
> PORTAGE_CONFIGROOT="/"
> PORTAGE_TMPDIR="/var/tmp"
> PORTDIR="/usr/portage"
> PORTDIR_OVERLAY=""
> SYNC="git://github.com/funtoo/portage-mini-2011.git"
> SYNC_USER="root"
> USE="X acl alac alsa amd64 berkdb bzip2 cdr cli consolekit cracklib crypt cups
> cxx dbus dri dvd dvdr dvdread encode flac fortran gdbm gif gpm iconv ipv6 jpeg
> lame mad mmx modules mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg
> openmp pam pcre perl png policykit pppd python readline session sse sse2 ssl
> sysfs tcpd tiff truetype unicode vorbis wavpack xml xorg zlib"
> ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x
> ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3
> trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw
> asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa
> lfloat linear meter mmap_emul mulaw multi null plug rate route share shm
> softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon
> authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile
> authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock
> deflate dir disk_cache env expires ext_filter file_cache filter headers include
> info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif
> speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi
> words flow plan stage tables krita karbon braindump" CAMERAS="ptp2"
> COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
> ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin
> garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore
> rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx"
> INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz
> cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3"
> RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga
> neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy
> v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p
> iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark
> dhcpmac delude chaos account"
> Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS,
> PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK
Comment 8 Guy 2011-09-24 20:50:40 UTC
Same failure with libpng-1.5.5.

If anyone absolutely needs iscan and is willing to use TIFF instead of PNG:

USE=-png emerge iscan

works.
Comment 9 Dominique Michel 2011-09-25 06:39:06 UTC
(In reply to comment #8)
> Same failure with libpng-1.5.5.
> 
> If anyone absolutely needs iscan and is willing to use TIFF instead of PNG:
> 
> USE=-png emerge iscan
> 
> works.

Nice, it worked.
Comment 10 Samuli Suominen gentoo-dev 2011-09-26 15:53:04 UTC
Created attachment 287801 [details, diff]
Patch attempt

I'm not sure of this patch, at all, please review and test
Comment 11 Samuli Suominen gentoo-dev 2011-09-26 19:18:02 UTC
(In reply to comment #10)
> Created attachment 287801 [details, diff]
> Patch attempt
> 
> I'm not sure of this patch, at all, please review and test

The patch is most likely not correct after going through png manual again, so be careful... builds, but doesn't work (although not sure howto hit that codepath)
Comment 13 Ian Stakenvicius gentoo-dev 2011-09-29 20:10:11 UTC
Created attachment 288267 [details]
Another patch attempt

OK, on the basis that the conditional in question is checking to see if all lines have been flushed, and since interlacing is hard-coded to none, it can be assumed that the number of rows in the file is the vertical size of the image. So, i've modified the conditional a slightly different way.

I'm *NOT* sure if the conditional is correct, though, as it might be off-by-1.  Unfortunately I can't test it as I don't have a scanner.  I haven't found any documentation that describes the output of png_get_current_row_number to know if it maxes out at vertical_size or (vertical_size - 1).

I've also wrapped the additional libpng function call with the macros and such that are used to wrap all of the other libpng calls, and since this is a libpng-1.5 only function i used #if conditionals on PNG_LIBPNG_VER to ensure backwards-compatibility.
Comment 14 Ian Stakenvicius gentoo-dev 2011-09-29 20:12:00 UTC
FYI - this patch applies cleanly to both 2.21.0 and 2.26.2
Comment 15 Ian Stakenvicius gentoo-dev 2011-09-30 15:52:07 UTC
(In reply to comment #13)
> 
> I'm *NOT* sure if the conditional is correct, though, as it might be off-by-1. 
> Unfortunately I can't test it as I don't have a scanner.  I haven't found any
> documentation that describes the output of png_get_current_row_number to know
> if it maxes out at vertical_size or (vertical_size - 1).
> 

OK, so i hacked media-gfx/xv to use png_write_flush, and i tested this conditional and it works as I expected -- png_get_current_row_number == vertical_size when all rows have been written.  So this patch should be good to go.
Comment 16 Samuli Suominen gentoo-dev 2011-09-30 17:58:51 UTC
+  30 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> iscan-2.26.2.ebuild,
+  +files/iscan-2.26.2-libpng15.patch:
+  Fix building with libpng15 wrt #383799 by Ian Stakenvicius (patch pending
+  upstream review)