Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 383703 - media-video/xine-ui-0.99.6 fails to build against media-libs/libpng-1.5.4
Summary: media-video/xine-ui-0.99.6 fails to build against media-libs/libpng-1.5.4
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-09-19 20:48 UTC by Martin von Gagern
Modified: 2011-09-21 06:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (media-video:xine-ui-0.99.6.emerge--info,6.70 KB, text/plain)
2011-09-20 20:33 UTC, Martin von Gagern
Details
build log (media-video:xine-ui-0.99.6:20110920-202928.log,24.08 KB, text/plain)
2011-09-20 20:33 UTC, Martin von Gagern
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin von Gagern 2011-09-19 20:48:29 UTC
media-video/xine-ui-0.99.6 fails to build against media-libs/libpng-1.5.4, because some data structure is now declared incompletely in the headers, preventing access to its members.

load.c: In function ‘_LoadPNG’:
load.c:64:15: error: dereferencing pointer to incomplete type
load.c: In function ‘ispng’:
load.c:199:8: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
make[4]: *** [libImlib_light_a-load.o] Error 1
[...]
make[4]: Leaving directory `/var/tmp/portage/media-video/xine-ui-0.99.6/work/xine-ui-0.99.6/src/xitk/Imlib-light'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-video/xine-ui-0.99.6/work/xine-ui-0.99.6/src/xitk'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-video/xine-ui-0.99.6/work/xine-ui-0.99.6/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-video/xine-ui-0.99.6/work/xine-ui-0.99.6'
make: *** [all] Error 2
emake failed
 * ERROR: media-video/xine-ui-0.99.6 failed (compile phase):
 *   emake failed

The function in question has the variable
  png_infop info_ptr;
on which it performs the member access
  if (info_ptr->color_type == PNG_COLOR_TYPE_RGB_ALPHA)

Probably using png_get_tRNS would be the correct solution here, dunno.
Comment 1 Martin von Gagern 2011-09-19 22:35:14 UTC
Tried to report this upstream, but couldn't create an account at https://bugs.xine-project.org/ because the confirmation e-mail didn't arrive. Maybe it will be a couple of hours late, but if anyone reading this already has an account there, please feel free to file a bug report there and post the link to it here.
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2011-09-20 10:42:03 UTC
I can't reproduce it. I need a full build.log and the flags you used to build xine-ui
Comment 3 Martin von Gagern 2011-09-20 20:33:16 UTC
Created attachment 287201 [details]
emerge --info
Comment 4 Martin von Gagern 2011-09-20 20:33:39 UTC
Created attachment 287203 [details]
build log
Comment 5 Martin von Gagern 2011-09-20 20:39:20 UTC
(In reply to comment #2)
> I need a full build.log and the flags you used to build xine-ui

$ emerge -pqv =media-video/xine-ui-0.99.6
[ebuild   R   ] media-video/xine-ui-0.99.6  USE="X curl lirc nls readline xinerama -aalib -debug -libcaca -vdr" 

Looking at the sources, I guess the X use flag has the best chances to be responsible here. But I must say I'm surprised that this doesn't reproduce easily. Is Imlib-light built on your system, according to the build log?
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2011-09-20 21:26:51 UTC
Repository: bugfix  ??

So this is not the xine-ui from portage tree?

I am marking this as invalid. Please reopen if I am wrong or if the portage package has the same problem
Comment 7 Martin von Gagern 2011-09-21 06:00:14 UTC
(In reply to comment #6)
> Repository: bugfix  ??
> 
> So this is not the xine-ui from portage tree?

Argh! Remnant from bug #312599, had completely forgotten about that, and missed the relevant log lines as well. Sorry, and thanks for spotting this!

> I am marking this as invalid. Please reopen if I am wrong or if the portage
> package has the same problem

No, main portage works all right, so invalid it stays as far as I'm concerned.