Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 383669 - app-emulation/virtualbox-4.1.2: fails to compile due to Java name clash
Summary: app-emulation/virtualbox-4.1.2: fails to compile due to Java name clash
Status: RESOLVED DUPLICATE of bug 387039
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 395465 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-19 18:09 UTC by Denys Duchier
Modified: 2013-10-03 19:11 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,269.21 KB, text/plain)
2011-09-19 18:10 UTC, Denys Duchier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denys Duchier 2011-09-19 18:09:16 UTC
the errors are of the form:

/var/tmp/portage/app-emulation/virtualbox-4.1.2/work/VirtualBox-4.1.2_OSE/out/linux.amd64/release/obj/vboxjxpcom-gen/jxpcomgen/java/glue/Helper.java:121: error: name clash: unwrap(List<Integer>) and unwrap(List<Short>) have the same erasure

Reproducible: Always

Steps to Reproduce:
try to emerge virtualbox



Portage 2.2.0_alpha58 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.13-r4, 3.0.4-gentoo x86_64)
=================================================================
System uname: Linux-3.0.4-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-gentoo-2.0.3
Timestamp of tree: Sat, 17 Sep 2011 14:15:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo duchier
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://mirror.ovh.net/gentoo-distfiles/ http://de-mirror.org/distro/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 apng berkdb bluetooth branding bzip2 cairo cdda cdr cli clucene consolekit cracklib crypt cups cvs cxx dbus declarative djvu doc dri dts dvd dvdr emacs emboss encode exif fam firefox flac fontconfig fortran gd gdbm gdu gif gmp gnutls gpm gstreamer gtk iconv idn imagemagick ipv6 jadetex java jpeg jpeg2k json kde kipi kpathsea lame latex lcms ldap libnotify libxml2 lzma mad mmx mng modules mp3 mp4 mpeg msn mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ntp odbc ogg opengl openmp pam pango pcre pdf perl phonon php plasma png policykit ppds pppd python qt3support qt4 readline ruby sdl semantic-desktop session skype slp sms spell sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs tcpd theora threads tiff tk toolkit-scroll-bars truetype udev unicode usb v4l v4l2 vdpau vlc vorbis webkit webpresence x264 xattr xcb xcomposite xft xine xinerama xml xorg xscreensaver xulrunner xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en fr" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Denys Duchier 2011-09-19 18:10:22 UTC
Created attachment 287035 [details]
build.log

here is the build.log as an attachement
Comment 2 Mike Gilbert gentoo-dev 2011-09-20 04:00:35 UTC
From the build log:

GENTOO_VM=oracle-jdk-bin-1.7  CLASSPATH="" JAVA_HOME="/opt/oracle-jdk-bin-1.7.0"
JAVACFLAGS="-source 1.5 -target 1.5" COMPILER=""
Comment 3 Eric Siegel 2011-11-08 19:09:33 UTC
I am having this issue too, with icedtea 7 and virtualbox 4.1.4.

Also, see this other bug: https://bugs.gentoo.org/show_bug.cgi?id=387039
Comment 4 Ian Delaney (RETIRED) gentoo-dev 2011-12-13 11:56:10 UTC
this is almost a duplicate of 387039.  
This 
GENTOO_VM=oracle-jdk-bin-1.7 
distinguishes it.  Try icdtea-bin6
Comment 5 Martin von Gagern 2011-12-13 22:14:43 UTC
(In reply to comment #4)
> this is almost a duplicate of bug 387039.  
> This 
> GENTOO_VM=oracle-jdk-bin-1.7 
> distinguishes it.  Try icdtea-bin6

How can this distinguish things? Both this report (according to the build log from comment #1) and bug #387039 comment #0 mention oracle-jdk-bin-1.7.
Bug #387039 comment #3 and #4 look unrelated to me.

Workaround: JAVA_PKG_FORCE_VM=icedtea-6 emerge -1 virtualbox
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2011-12-21 09:55:38 UTC
*** Bug 395465 has been marked as a duplicate of this bug. ***
Comment 7 Juergen Rose 2011-12-21 10:34:54 UTC
Switching to Sun JDK 1.6.0.29 [sun-jdk-1.6] solved the corresponing issue with virtualbox-4.1.8 for me.
Comment 8 Eric Siegel 2011-12-21 14:52:14 UTC
That workaround seemed to work for me.

(In reply to comment #5)
> (In reply to comment #4)
> > this is almost a duplicate of bug 387039.  
> > This 
> > GENTOO_VM=oracle-jdk-bin-1.7 
> > distinguishes it.  Try icdtea-bin6
> 
> How can this distinguish things? Both this report (according to the build log
> from comment #1) and bug #387039 comment #0 mention oracle-jdk-bin-1.7.
> Bug #387039 comment #3 and #4 look unrelated to me.
> 
> Workaround: JAVA_PKG_FORCE_VM=icedtea-6 emerge -1 virtualbox
Comment 9 Ben Kohler gentoo-dev 2013-10-03 19:11:07 UTC

*** This bug has been marked as a duplicate of bug 387039 ***