Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 383581 - [Request] sys-devel/gcc-4.x: Re-add support for the D language
Summary: [Request] sys-devel/gcc-4.x: Re-add support for the D language
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL: https://bitbucket.org/goshawk/gdc/wik...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-19 06:40 UTC by Jonathan-Christofer Demay
Modified: 2017-08-15 13:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan-Christofer Demay 2011-09-19 06:40:21 UTC
Using the 'd' USE flag, gcc-4.1 can support the D language using the frontend from http://sourceforge.net/projects/dgcc/. This project has been long discontinued and therefore ebuilds for newer versions of GCC no longer support this USE flag.

However, for quite some time now, the gdc frontend has risen from the dead here: https://bitbucket.org/goshawk/gdc/wiki/Home. It supports GCC from 4.1.x to 4.6.x and, good thing, the code in toolchain.eclass that setup the frontend still works (apart from the url, I tested it with gcc-4.4 and gcc-4.5).

So, I was wondering what the Gentoo GCC team would think about bringing back the 'd' USE flag for >gcc-4.1* ? If so, what about adding a (mutually exclusive) 'd2' use flag since the new D frontend supports both versions of the language ?

Reproducible: Always
Comment 1 SpanKY gentoo-dev 2011-09-20 01:40:34 UTC
post a patch and i don't have a problem adding it
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2012-07-15 05:58:15 UTC
Patches were submitted for 4.8 but IIRC there was a lot of work that needed to be done to get it into shape.  I'm not sure what the current status is.
Comment 3 Andreas K. Hüttel gentoo-dev 2017-06-22 21:14:31 UTC
Is anyone still interested in this?

[Note to self, 
https://gdcproject.org/
https://github.com/D-Programming-GDC/GDC
]
Comment 4 Andreas K. Hüttel gentoo-dev 2017-08-15 13:03:37 UTC
(In reply to Andreas K. Hüttel from comment #3)
> Is anyone still interested in this?
> 
> [Note to self, 
> https://gdcproject.org/
> https://github.com/D-Programming-GDC/GDC
> ]

Seems no.