Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 383447 - app-text/ghostscript-gpl-9.05 fails to build
Summary: app-text/ghostscript-gpl-9.05 fails to build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 2 votes (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
: 414593 420641 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-18 04:45 UTC by Benjamin Peterson
Modified: 2014-04-26 23:25 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (x.log,658.16 KB, text/plain)
2011-09-18 23:25 UTC, Benjamin Peterson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Peterson 2011-09-18 04:45:48 UTC
emerging the latest updated of ghostscript fails.

Reproducible: Always

Actual Results:  
x86_64-pc-linux-gnu-gcc  -DHAVE_MKSTEMP -DHAVE_FILE64 -DHAVE_MKSTEMP64 -DHAVE_FONTCONFIG  -DHAVE_SETLOCALE -DHAVE_SSE2 -DHAVE_DBUS -DHAVE_BSWAP32 -DHAVE_BYTESWAP_H -fPIC  -O2 -Wall -Wstrict-prototypes -Wundef -Wmissing-declarations -Wmissing-prototypes -Wwrite-strings -Wno-strict-aliasing -Wdeclaration-after-statement -fno-builtin -fno-common -DHAVE_STDINT_H -DGX_COLOR_INDEX_TYPE="unsigned long int" -O2 -pipe -DUSE_LIBPAPER -DGS_DEVS_SHARED -DGS_DEVS_SHARED_DIR=\"/usr/lib64/ghostscript/9.04\" -I./soobj -I./base  -DWHICH_CMS="lcms" -g -o ./sobin/gsc ./psi/dxmainc.c \
-L./sobin -lgs
./psi/dxmainc.c: In function ‘gsdll_stdout’:
./psi/dxmainc.c:59: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
./psi/dxmainc.c: In function ‘gsdll_stderr’:
./psi/dxmainc.c:67: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
./sobin/libgs.so: In function `_start':
(.text+0x0): multiple definition of `_start'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../lib64/crt1.o:(.text+0x0): first defined here
./sobin/libgs.so: In function `_fini':
(.fini+0x0): multiple definition of `_fini'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../lib64/crti.o:(.fini+0x0): first defined here
./sobin/libgs.so:(.rodata+0x0): multiple definition of `_IO_stdin_used'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../lib64/crt1.o:(.rodata.cst4+0x0): first defined here
./sobin/libgs.so: In function `__data_start':
(.data+0x0): multiple definition of `__data_start'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../lib64/crt1.o:(.data+0x0): first defined here
./sobin/libgs.so: In function `main':
(.text+0xf0): multiple definition of `main'
/var/tmp/portage/app-text/ghostscript-gpl-9.04-r3/temp/ccN0lEY4.o:/var/tmp/portage/app-text/ghostscript-gpl-9.04-r3/work/ghostscript-9.04/./psi/dxmainc.c:75: first defined here
./sobin/libgs.so: In function `_init':
(.init+0x0): multiple definition of `_init'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../lib64/crti.o:(.init+0x0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: error in ./sobin/libgs.so(.eh_frame); no .eh_frame_hdr table will be created.
collect2: ld returned 1 exit status
make[2]: *** [sobin/gsc] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-text/ghostscript-gpl-9.04-r3/work/ghostscript-9.04'
make[1]: *** [so-subtarget] Error 2
make[1]: Leaving directory `/var/tmp/portage/app-text/ghostscript-gpl-9.04-r3/work/ghostscript-9.04'
make: *** [so] Error 2
emake failed
 * ERROR: app-text/ghostscript-gpl-9.04-r3 failed (compile phase):
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 3439:  Called die
 * The specific snippet of code:
 *       emake -j1 so all || die "emake failed";
 * 
 * If you need support, post the output of 'emerge --info =app-text/ghostscript-gpl-9.04-r3',
 * the complete build log and the output of 'emerge -pqv =app-text/ghostscript-gpl-9.04-r3'.
 * The complete build log is located at '/var/tmp/portage/app-text/ghostscript-gpl-9.04-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/ghostscript-gpl-9.04-r3/temp/environment'.
 * S: '/var/tmp/portage/app-text/ghostscript-gpl-9.04-r3/work/ghostscript-9.04'



Portage 2.1.10.11 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.12.2-r0, 2.6.39-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.39-gentoo-r3-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T5670_@_1.80GHz-with-gentoo-2.0.3
Timestamp of tree: Sun, 18 Sep 2011 04:30:01 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.arcticnetwork.ca/ http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://www.gtlib.gatech.edu/pub/gentoo ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://mirrors.cs.wmich.edu/gentoo http://gentoo.chem.wisc.edu/gentoo/ http://mirror.its.uidaho.edu/pub/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 apng berkdb bzip2 cairo cjk cli consolekit cracklib crypt cups curl cxx dbus dell device-mapper dri emacs encode firefox3 fortran freetype gdbm glut gpm gstreamer iconv immqt-bc ipv6 jpeg kde laptop libffi mmx modules mp3 mudflap multilib ncurses networkmanager nls nptl nptlonly offensive ogg opengl openmp pam pcre perl phonon png policykit pppd python qt3support qt4 readline sasl sdl session sql sqlite sse sse2 ssl svg symlink sysfs tcpd theora threads tiff truetype udev unicode vorbis webkit xcomposite xft xorg xulrunner zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mike Gilbert gentoo-dev 2011-09-18 22:15:49 UTC
Please attach the full build log.
Comment 2 Benjamin Peterson 2011-09-18 23:25:24 UTC
Created attachment 286935 [details]
build log
Comment 3 Frank Krömmelbein 2011-09-22 20:28:02 UTC
Same here on X86.
Comment 4 Ylosar Goer 2011-10-23 05:40:33 UTC
app-text/ghostscript-gpl-9.04-r4 still fails with the same errors


Portage 2.1.10.11 (default/linux/x86/10.0, gcc-4.5.3, glibc-2.12.2-r0, 2.6.39-gentoo-r3 i686)
=================================================================
System uname: Linux-2.6.39-gentoo-r3-i686-VIA_Esther_processor_1200MHz-with-gentoo-2.0.3
Timestamp of tree: Sun, 23 Oct 2011 04:15:01 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo local
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA @EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=i686 -mmmx -msse -msse2 -msse3 -mfpmath=sse -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=i686 -mmmx -msse -msse2 -msse3 -mfpmath=sse -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=""
FEATURES="assume-digests binpkg-logs buildpkg collision-protect distcc distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://ftp.free.fr/mirrors/ftp.gentoo.org/ http://mirror.ovh.net/gentoo-distfiles http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="lzop"
PORTAGE_COMPRESS_FLAGS="--delete"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--human-readable"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="apache2 bash-completion berkdb bzip2 caps clamd cli cracklib crypt cups curl cxx dri enscript expat fam fontconfig foomaticdb gd gdbm geoip gmp iconv idn ipv6 javamail javascript jbig jms jmx jpeg logrotate lzma lzo maildir mmx modules mpeg mudflap ncurses nls nptl nptlonly openmp pam pcre pic png pppd readline ruby session sqlite sqlite3 sse sse2 ssl svg sysfs tcpd threads threadsafe tiff truetype unicode vhosts vim-syntax x86 xml xml2 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="proxy proxy_http cgid alias auth_basic auth_digest authn_default authn_file authz_default authz_groupfile authz_host authz_user autoindex dav dav_fs dav_lock deflate dir env expires filter headers include info log_config logio mime mime_magic negotiation rewrite setenvif status" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="via" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND
Comment 5 Andreas K. Hüttel gentoo-dev 2012-02-01 21:32:21 UTC
Looks like something gets linked twice :|
Comment 6 radek.vlacil 2012-02-16 10:21:37 UTC
Same here even for version 9.05

Portage 2.1.10.46 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.13-r4, 3.2.5-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.2.5-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5620_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Thu, 16 Feb 2012 10:00:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.9.6-r3, 1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif extras fam firefox flac fortran gdbm gdu gif gpm gtk iconv ipv6 jpeg jpeg2k kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd qt3support qt4 readline sdl semantic-desktop session spell sqlite sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode upower usb vorbis x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 Andreas K. Hüttel gentoo-dev 2013-03-24 16:58:21 UTC
Please check if this is still the case with 9.06
Comment 8 Andreas K. Hüttel gentoo-dev 2013-03-24 20:16:07 UTC
*** Bug 420641 has been marked as a duplicate of this bug. ***
Comment 9 Petr Pisar 2013-05-04 10:28:26 UTC
I have a different problem that is maybe related. I cannot rebuild ghostscript-gpl-9.06 (after bumping libpng SONAME) because this compiler invocation has wrongly ordered library path. This is my error:

make[2]: Entering directory `/var/tmp/portage/app-text/ghostscript-gpl-9.06/work/ghostscript-9.06'
rm -f ./sobin/libgs.so.9
ln -s libgs.so.9.06 ./sobin/libgs.so.9
rm -f ./sobin/libgs.so
ln -s libgs.so.9.06 ./sobin/libgs.so
mips64el-unknown-linux-gnu-gcc  -DHAVE_MKSTEMP -DHAVE_FILE64 -DHAVE_MKSTEMP64 -DHAVE_FONTCONFIG -DHAVE_LIBIDN -DHAVE_SETLOCALE   -DHAVE_BSWAP32 -DHAVE_BYTESWAP_H -DHAVE_STRERROR -fPIC  -O2 -Wall -Wstrict-prototypes -Wundef -Wmissing-declarations -Wmissing-prototypes -Wwrite-strings -Wno-strict-aliasing -Wdeclaration-after-statement -fno-builtin -fno-common -DHAVE_STDINT_H=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_DIR_H=1 -DHAVE_SYS_TIME_H=1 -DHAVE_SYS_TIMES_H=1 -DGX_COLOR_INDEX_TYPE="unsigned long long" -O2 -march=loongson2f -mabi=n32 -pipe -mplt -Wa,-mfix-loongson2f-nop -g -DUSE_LIBPAPER  -DGS_DEVS_SHARED -DGS_DEVS_SHARED_DIR=\"/usr/lib32/ghostscript/9.06\"  -I./soobj -I./base  -DWHICH_CMS="lcms2" -g -o ./sobin/gsc ./psi/dxmainc.c \
-Wl,-O1 -Wl,--as-needed -L/usr/lib32  -L./sobin -lgs
/usr/lib/gcc/mips64el-unknown-linux-gnu/4.7.2/../../../../mips64el-unknown-linux-gnu/bin/ld: warning: libpng15.so.15, needed by /usr/lib32/libgs.so, not found (try using -rpath or -rpath-link)
/usr/lib32/libgs.so: undefined reference to `png_set_pHYs@PNG15_0'

The problem is the gcc finds system /usr/lib32/libgs.so before just compiled ./sobin/libgs.so. The problem are the last few arguments of the command "-L/usr/lib32  -L./sobin -lgs". Correct one is "-L./sobin -lgs -L/usr/lib32".
Comment 10 Petr Pisar 2013-05-04 11:00:27 UTC
These lines are wrong:

# find -name '*.mak' -exec grep -H -e '-L\$(BINDIR)' {} \;
./base/macos-fw.mak:    $(GLCC) -g -o $(GSSOC_XE) $(PSSRC)dxmainc.c $(LDFLAGS) -L$(BINDIR) -l$(GS)
./base/unix-dll.mak:    $(LDFLAGS) -L$(BINDIR) -l$(GS)
./base/unix-dll.mak:    $(LDFLAGS) -L$(BINDIR) -l$(GS) $(SOC_LIBS)

However the LDFLAGS is not in vanilla unix-dll.mak. This looks like a Gentoo patch. The $(LDFLAGS) and the -L$(BINDIR) should be reversed.
Comment 11 Petr Pisar 2013-05-04 12:59:29 UTC
It was a sed in the ebuild, this fixes my issue:

--- /usr/portage/app-text/ghostscript-gpl/ghostscript-gpl-9.06.ebuild   2013-05-02 04:31:07.000000000 +0200
+++ ghostscript-gpl-9.06.ebuild 2013-05-04 13:21:44.000000000 +0200
@@ -112,12 +112,13 @@
                sed -i "s:.*\$(GSSOX_XENAME)$::" base/*.mak || die "gsxso sed failed"
        fi

+       # Put LDFLAGS after BINDIR, bug #383447
        # search path fix
        sed -i -e "s:\$\(gsdatadir\)/lib:/usr/share/ghostscript/${PVM}/$(get_libdir):" \
                -e "s:exdir=.*:exdir=/usr/share/doc/${PF}/examples:" \
                -e "s:docdir=.*:docdir=/usr/share/doc/${PF}/html:" \
                -e "s:GS_DOCDIR=.*:GS_DOCDIR=/usr/share/doc/${PF}/html:" \
-               -e 's:-L$(BINDIR):$(LDFLAGS) &:g' \
+               -e 's:-L$(BINDIR):& $(LDFLAGS):g' \
                base/Makefile.in base/*.mak || die "sed failed"

        # bug 467100
Comment 12 Timo Gurr (RETIRED) gentoo-dev 2014-02-12 19:25:21 UTC
(In reply to Petr Pisar from comment #11)
> It was a sed in the ebuild, this fixes my issue:

Thanks for your investigation and providing a fix! I've committed your suggested change in ghostscript-gpl-9.10-r3.
Comment 13 Andreas K. Hüttel gentoo-dev 2014-04-26 23:25:45 UTC
*** Bug 414593 has been marked as a duplicate of this bug. ***