Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 383241 - dev-lang/perl-5.12.4-r1 - ./hints/linux.sh: line 194: ./a.out: cannot execute binary file
Summary: dev-lang/perl-5.12.4-r1 - ./hints/linux.sh: line 194: ./a.out: cannot execute...
Status: RESOLVED DUPLICATE of bug 134650
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-16 15:23 UTC by Maciej Grela
Modified: 2014-04-24 00:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The complete build log (build.log,8.21 KB, text/plain)
2011-09-16 15:25 UTC, Maciej Grela
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Grela 2011-09-16 15:23:12 UTC
When trying to emerge system the compile fails because of perl. Attached complete build log and emerge --info

This seems strange, first configure says, that it's disabling ndbm but then tries to link to it and fails (see complete build.log).

Reproducible: Always

Steps to Reproduce:
1. crossdev -t hppa
2. hppa-unknown-linux-gnu-emerge perl
3.
Actual Results:  
perl fails to compile:

[-O2 -pipe -fomit-frame-pointer -I/usr/hppa-unknown-linux-gnu/usr/include/ -I/usr/hppa-unknown-linux-gnu/include/]  
Any additional cc flags? [-DOVR_DBL_DIG=14]  
Let me guess what the preprocessor flags are...
Any additional ld flags (NOT including libraries)?
[-L/usr/hppa-unknown-linux-gnu/lib -L/usr/hppa-unknown-linux-gnu/usr/lib -L/usr/local/lib]  
Checking your choice of C compiler and flags for coherency...
I've tried to compile and run the following simple program:

#include <stdio.h>
int main() { printf("Ok\n"); return(0); }

I used the command:

	hppa-unknown-linux-gnu-gcc -o try -O2 -pipe -fomit-frame-pointer -I/usr/hppa-unknown-linux-gnu/usr/include/ -I/usr/hppa-unknown-linux-gnu/include/ -DOVR_DBL_DIG=14 -L/usr/hppa-unknown-linux-gnu/lib -L/usr/hppa-unknown-linux-gnu/usr/lib -L/usr/local/lib try.c -lnsl -lndbm -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
	 ./try

and I got the following output:

/usr/libexec/gcc/hppa-unknown-linux-gnu/ld: cannot find -lndbm
collect2: ld returned 1 exit status
I can't compile the test program.
You have a BIG problem.  Shall I abort Configure [y]  
Ok.  Stopping Configure.
 * ERROR: dev-lang/perl-5.12.4-r1 failed (configure phase):
 *   Unable to configure
 * 
 * Call stack:
 *     ebuild.sh, line  91:  Called src_configure
 *   environment, line 2841:  Called die
 * The specific snippet of code:
 *       sh Configure -des -Duseshrplib -Darchname="${myarch}" -Dcc="$(tc-getCC)" -Doptimize="${CFLAGS}" -Dldflags="${LDFLAGS}" -Dprefix='/usr' -Dsiteprefix='/usr' -Dvendorprefix='/usr' -Dscriptdir='/usr/bin' -Dprivlib="${PRIV_LIB}" -Darchlib="${ARCH_LIB}" -Dsitelib="${SITE_LIB}" -Dsitearch="${SITE_ARCH}" -Dvendorlib="${VENDOR_LIB}" -Dvendorarch="${VENDOR_ARCH}" -Dman1dir=/usr/share/man/man1 -Dman3dir=/usr/share/man/man3 -Dsiteman1dir=/usr/share/man/man1 -Dsiteman3dir=/usr/share/man/man3 -Dvendorman1dir=/usr/share/man/man1 -Dvendorman3dir=/usr/share/man/man3 -Dman1ext='1' -Dman3ext='3pm' -Dlibperl="${LIBPERL}" -Dlocincpth=' ' -Duselargefiles -Dd_semctl_semun -Dcf_by='Gentoo' -Dmyhostname='localhost' -Dperladmin='root@localhost' -Dinstallusrbinperl='n' -Ud_csh -Uusenm "${myconf[@]}" || die "Unable to configure"


Expected Results:  
perl should compile

kraken portage # hppa-unknown-linux-gnu-emerge --info =dev-lang/perl-5.12.4-r1
PORTAGE_BZIP2_COMMAND setting is invalid: 'bzip2'
PORTAGE_BZIP2_COMMAND setting from make.globals is invalid: 'bzip2'
PORTAGE_BZIP2_COMMAND setting is invalid: 'bzip2'
PORTAGE_BZIP2_COMMAND setting from make.globals is invalid: 'bzip2'
PORTAGE_BZIP2_COMMAND setting is invalid: 'bzip2'
PORTAGE_BZIP2_COMMAND setting from make.globals is invalid: 'bzip2'
PORTAGE_BZIP2_COMMAND setting is invalid: 'bzip2'
PORTAGE_BZIP2_COMMAND setting from make.globals is invalid: 'bzip2'
FEATURES variable contains unknown value(s): autopatch
Portage 2.1.10.16 (default/linux/hppa/10.0, gcc-4.5.3, unavailable, 3.0.3-kraken x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.0.3-kraken-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-gentoo-2.0.3
Timestamp of tree: Wed, 14 Sep 2011 19:15:01 +0000
app-shells/bash:          4.2_p10::<unknown repository>
dev-java/java-config:     2.1.11-r3::<unknown repository>
dev-lang/python:          2.4.6::<unknown repository>, 2.5.4-r4::<unknown repository>, 2.6.7-r2::<unknown repository>, 2.7.2-r2::<unknown repository>, 3.1.4-r2::<unknown repository>, 3.2-r2::<unknown repository>
dev-util/cmake:           2.8.5-r2::<unknown repository>
dev-util/pkgconfig:       0.26::<unknown repository>
sys-apps/baselayout:      2.0.3::<unknown repository>
sys-apps/openrc:          0.9.3-r1::<unknown repository>
sys-apps/sandbox:         2.5::<unknown repository>
sys-devel/autoconf:       2.13::<unknown repository>, 2.68::<unknown repository>
sys-devel/automake:       1.5-r1::<unknown repository>, 1.7.9-r2::<unknown repository>, 1.8.5-r4::<unknown repository>, 1.9.6-r3::<unknown repository>, 1.10.3::<unknown repository>, 1.11.1-r1::<unknown repository>
sys-devel/binutils:       2.21.1-r1::<unknown repository>
sys-devel/gcc:            4.5.3-r1::<unknown repository>
sys-devel/gcc-config:     1.4.1-r1::<unknown repository>
sys-devel/libtool:        2.4-r1::<unknown repository>
sys-devel/make:           3.82-r1::<unknown repository>
sys-kernel/linux-headers: 2.6.39::<unknown repository> (virtual/os-headers)
sys-libs/glibc:           2.13-r4::<unknown repository>
Repositories: gentoo
ACCEPT_KEYWORDS="hppa ~hppa"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-Os -pipe  -fomit-frame-pointer -I/usr/hppa-unknown-linux-gnu/usr/include/ -I/usr/hppa-unknown-linux-gnu/include/"
CHOST="hppa-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-Os -pipe  -fomit-frame-pointer -I/usr/hppa-unknown-linux-gnu/usr/include/ -I/usr/hppa-unknown-linux-gnu/include/"
DISTDIR="/var/cache/src"
FEATURES="assume-digests autopatch binpkg-logs buildpkg distlocks ebuild-locks fixlafiles fixpackages news nodoc noinfo noman parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.mirror.pw.edu.pl"
LANG="pl_PL.utf8"
LDFLAGS="-L/usr/hppa-unknown-linux-gnu/lib -L/usr/hppa-unknown-linux-gnu/usr/lib"
MAKEOPTS="-j3"
PKGDIR="/usr/hppa-unknown-linux-gnu/packages/"
PORTAGE_CONFIGROOT="/usr/hppa-unknown-linux-gnu/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/usr/hppa-unknown-linux-gnu/tmp/"
PORTDIR="/var/cache/ebuild/gentoo"
PORTDIR_OVERLAY="/var/cache/ebuild/bitcoin /var/cache/ebuild/cpan /var/cache/ebuild/crossdev /var/cache/ebuild/dropzone /var/cache/ebuild/gnome /var/cache/ebuild/kde /var/cache/ebuild/nokia-siemens-networks /var/cache/ebuild/sunrise /var/cache/ebuild/x11"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="berkdb bindist bzip2 cli cracklib crypt cups cxx firefox foomaticdb fortran gdbm gpm hppa iconv imlib ipv6 libwww make-symlinks minimal modules mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline session spell ssl sysfs tcpd unicode xml2 xorg xulrunner zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev dummy" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Maciej Grela 2011-09-16 15:25:21 UTC
Created attachment 286687 [details]
The complete build log
Comment 2 Jeroen Roovers gentoo-dev 2011-09-16 15:40:15 UTC
Are you cross-compiling again?
Comment 3 Maciej Grela 2011-09-16 19:02:31 UTC
Yes, I forgot to mention this in the summary.
Comment 4 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-04-23 09:46:05 UTC
Check with newest stable perl. I have no hppa hardware, reopen if still valid please.
Comment 5 Jeroen Roovers gentoo-dev 2014-04-23 14:17:46 UTC
That's not how versions work.
Comment 6 Jeroen Roovers gentoo-dev 2014-04-24 00:29:21 UTC
(In reply to Mikle Kolyada from comment #4)
> Check with newest stable perl. I have no hppa hardware, reopen if still
> valid please.

No PARISC hardware was harmed in producing this bug report. In fact, it was quite easy to reproduce it on an amd64 system with an hppa2.0 cross-compiler.

/usr/libexec/gcc/hppa-unknown-linux-gnu/ld: cannot find -lndbm

Why is there no libndbm?
Comment 7 Jeroen Roovers gentoo-dev 2014-04-24 00:38:49 UTC

*** This bug has been marked as a duplicate of bug 134650 ***