Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 383239 - media-gfx/wings-1.5.4 version bump
Summary: media-gfx/wings-1.5.4 version bump
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 3 votes (vote)
Assignee: Gentoo Graphics Project
Depends on: 502066
  Show dependency tree
Reported: 2011-09-16 14:58 UTC by Jacek Szafarkiewicz
Modified: 2016-06-11 10:14 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---

media-gfx/wings-1.4.1 ebuild (wings-1.4.1.ebuild,1.25 KB, text/plain)
2011-09-16 15:00 UTC, Jacek Szafarkiewicz
wings starter script (,198 bytes, text/plain)
2011-09-16 15:03 UTC, Jacek Szafarkiewicz
wings png icon (wings.png,9.39 KB, image/png)
2011-09-16 15:04 UTC, Jacek Szafarkiewicz
media-gfx/wings-1.4.1 ebuild (wings-1.4.1.ebuild,1.26 KB, text/plain)
2011-09-16 15:10 UTC, Jacek Szafarkiewicz
wings starter script (,124 bytes, text/plain)
2011-09-16 21:31 UTC, Jacek Szafarkiewicz
media-gfx/wings-1.4.1 ebuild (wings-1.4.1.ebuild,1.18 KB, text/plain)
2011-09-16 21:32 UTC, Jacek Szafarkiewicz
ebuild 1.5.2 (wings-1.5.2.ebuild,1.02 KB, text/plain)
2014-01-12 14:49 UTC, Jakub Panachida
ebuild 1.5.3 (wings-1.5.3.ebuild,1.09 KB, text/plain)
2015-02-15 22:31 UTC, Jakub Panachida

Note You need to log in before you can comment on or make changes to this bug.
Description Jacek Szafarkiewicz 2011-09-16 14:58:10 UTC
There is new version of wings3d, but in portage it stoped at version 1.1.1.
I've modified the older ebuilds and it looks like it is working.

Reproducible: Always
Comment 1 Jacek Szafarkiewicz 2011-09-16 15:00:15 UTC
Created attachment 286679 [details]
media-gfx/wings-1.4.1 ebuild

Little modified oryginal ebuild - it makes desktop entry
Comment 2 Jacek Szafarkiewicz 2011-09-16 15:03:29 UTC
Created attachment 286681 [details]
wings starter script

Little modified starter script (from oficial notes)
Comment 3 Jacek Szafarkiewicz 2011-09-16 15:04:44 UTC
Created attachment 286683 [details]
wings png icon

Oryginal icon with transparency
Comment 4 Jacek Szafarkiewicz 2011-09-16 15:10:19 UTC
Created attachment 286685 [details]
media-gfx/wings-1.4.1 ebuild

Little bugfix in icon install
Comment 5 Jacek Szafarkiewicz 2011-09-16 21:31:17 UTC
Created attachment 286707 [details]
wings starter script

Changes: dynamic version of script
Comment 6 Jacek Szafarkiewicz 2011-09-16 21:32:56 UTC
Created attachment 286711 [details]
media-gfx/wings-1.4.1 ebuild

Changes: use ebuild functions insted of 'cp' etc.
Comment 7 Jacek Szafarkiewicz 2011-09-16 21:42:53 UTC
Of course there aren't almost any 'die', because EAPI=4 add it automaticly.
I'am not sure if the category in 'make_desktop_entry' is used properly.

The (R)DEPEND USE flags are required by wings (in BUILD.unix).
Comment 8 Łukasz Stelmach 2013-07-31 12:42:57 UTC
Comment 9 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2013-12-25 12:04:19 UTC
I'd welcome a 1.5+ release too.
Comment 10 Jakub Panachida 2014-01-12 14:49:15 UTC
Created attachment 367718 [details]
ebuild 1.5.2

Version bump 1.5.2
I have it working locally like a charm.
Requires esdl-1.3.1 and cl for erlang <>
Rebar, required to build those two, is already in the portage
Comment 11 Vincent de Phily 2015-02-15 18:15:03 UTC
This bug should depend on bug #497898 (I'm pointing to the resolved-duplicate bug instead of the original, because it has an attached ebuild and updated summary).
Comment 12 Vincent de Phily 2015-02-15 18:21:21 UTC
This bug should depend on bug 502066.
Comment 13 Vincent de Phily 2015-02-15 21:42:44 UTC
The ebuilds work for me (bumped to 1.5.3). Played with the software a tiny bit. Some comments:

1) The BUILD.unix file says that minimum version of erlang is R16B01, we probably should reflect that in our dependencies, as erlang 15 is still available in the tree.

2) While BUILD.unix does suggest disabling hipe, it's only because "disabling HiPE also disables the use of floating point exceptions. Floating point exceptions have caused Wings to crash occasionally."
As HiPE can make a huge performance difference for other packages and disabling floating exceptions hides wings bugs instead of preventing them, I suggest not requiring USE=-hipe in the ebuild. At most, ewarn "upstream recommends rebuilding erlang with USE=-hipe if you encounter floating point exceptions".

3) The src_compile() function looks like the default one and could be ommited ?
Comment 14 Jakub Panachida 2015-02-15 22:30:13 UTC
I also use it with 1.5.3.

1. Right

2. Let's try it. I only use wings from erlang apps.

3. Right. It was a leftover form much earlier private ebuild.
Comment 15 Jakub Panachida 2015-02-15 22:31:38 UTC
Created attachment 396570 [details]
ebuild 1.5.3

I've attached updated ebuild.
Comment 16 Oleh 2016-02-01 15:11:33 UTC
any progress on this?
the only version present in portage is 1.1.1 and it's quite dated and doesn't compile due to various reason, reported already in b.g.o
Comment 17 Jonas Stein gentoo-dev 2016-02-14 22:15:18 UTC
Stable Release 1.5.4, Released August 2015.
Development Release 2.0.2 Released Dec 18 2015.

A recent version of Wings 3D is an important enhancement for all KiCad users who use the 3D rendering.
Comment 18 Juergen Rose 2016-03-28 10:26:45 UTC
(In reply to Jakub Panachida from comment #15)
> Created attachment 396570 [details]
> ebuild 1.5.3
> I've attached updated ebuild.

I tried this ebuild together with the ebuild of comment 2 of
and the ebuild of comment 1 of

'MAKEOPTS=-j1 emerge -vuND =wings-1.5.3' fails with:
erlc -Werror -I ../e3d +debug_info '-Dwings_version="1.5.3"' -pa ../intl_tools  -o../ebin wings_align.erl
erlc -Werror -I ../e3d +debug_info '-Dwings_version="1.5.3"' -pa ../intl_tools  -o../ebin wings_ask.erl
compile: warnings being treated as errors
wings_ask.erl:683: erlang:now/0: Deprecated BIF. See the "Time and Time Correction in Erlang" chapter of the ERTS User's Guide for more information.
wings_ask.erl:686: erlang:now/0: Deprecated BIF. See the "Time and Time Correction in Erlang" chapter of the ERTS User's Guide for more information.
Makefile:165: recipe for target '../ebin/wings_ask.beam' failed
make[2]: *** [../ebin/wings_ask.beam] Error 1

root@lynx:/usr/local/portage/dev-libs(82)# emerge --info '=media-gfx/wings-1.5.3::local'
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop, gcc-5.3.0, glibc-2.22-r2, 4.5.0-gentoo x86_64)
                         System Settings
System uname: Linux-4.5.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-3630QM_CPU_@_2.40GHz-with-gentoo-2.2
KiB Mem:    15206856 total,   5680840 free
KiB Swap:   50331644 total,  50282936 free
Timestamp of repository gentoo: Mon, 28 Mar 2016 06:30:01 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc[30128] (dcc_trace_version) distcc 3.2rc1 x86_64-pc-linux-gnu; built Dec 12 2015 19:11:03 [disabled]
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo, 3.5.1-r2::gentoo
dev-util/cmake:           3.5.1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.5::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.5::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r2::gentoo

    location: /usr/portage_lynx
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

    location: /var/lib/layman/sage-on-gentoo
    masters: gentoo science
    priority: 0

    location: /var/lib/layman/science
    masters: gentoo
    priority: 1

    location: /var/lib/layman/sunrise
    masters: gentoo
    priority: 2

    location: /var/lib/layman/x11
    masters: gentoo
    priority: 3

    location: /var/lib/layman/ago
    masters: gentoo
    priority: 4

    location: /var/lib/layman/tlp
    masters: gentoo
    priority: 5

    location: /usr/local/portage
    masters: gentoo
    priority: 6

    location: /var/lib/cpan
    masters: gentoo
    priority: 7

    location: /var/lib/g-octave
    masters: gentoo
    priority: 8

Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype- googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA NVIDIA-CUDA Nero-AAC-EULA GIMPS"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 amr ao apache2 apng applet archive armadillo arpack asf aspell assistant atlas audacious audiofile aufs automap automount bash-completion berkdb blas blast bluetooth bluray boost branding btrfs bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cilk cli cmake collada consolekit contrib cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia digitalradio djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples excel exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx ftp fuse gcj gd gdal gdbm gedit geoip geolocation geos gfortran gif gimp git glade glamor glib glpk gml gmp gnome gnome-keyring gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile hdaps hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jadetex java jbig jit john jpeg jpeg2k kate kde kdepim kdrive kerberos keymap kpathsea kvm ladspa lame lapack latex lcms ldap lensfun libffi libgda libkms libnotify libsamplerate lirc live lua lzma lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mpi-threads mplayer mtp multilib multimedia musepack musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg opencl opencv openexr opengl openmp openvg pam pango pcre pda pdf pdl2 perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds preview-latex proj projectm pstricks pulseaudio python q16 q32 qemu qhull qt3support qt4 qt5 quicktime raw readline reiserfs reports rle romio rpc rrdcgi rrdtool rtlsdr sage samba sasl schroedinger science sdk sdl seccomp secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 ssl startup-notification stlport subtitles subversion sudo suexec svg svm swig systemd szip t1lib tbb tcl tcpd tex tex4ht texmacs theora thesaurus thinkpad threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb utempter v4l v4l2 vaapi vala valgrind vdpau video vim-syntax virt-network virtualbox visio vorbis vpx vtk wav wayland webdav webdav-serf webkit wifi wmf wxwidgets x264 xa xattr xcb xetex xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zsh-completion zvbi" ABI_X86="64" ALSA_CARDS="intel8x0" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog sensors thermal" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="nss" DVB_CARDS="usb-wt220u dvb_usb_rtl28xxu" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev synaptics void" KERNEL="linux" LCD_DEVICES="cfontz hd44780 mtxorb ncurses X lcd2usb lcdlinux png usblcd SureElec" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en fr ru" LIRC_DEVICES="devinput" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="nouveau displaylink" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

root@lynx:/usr/local/portage/dev-libs(83)# qlist -Iv erlang

I tried also wings-1.5.4 (I copied the wings-1.5.3.ebuild to wings-1.5.4.ebuild), which failed with:
erlc -Werror -pa ../../ebin -pa ../../intl_tools -I ../../intl_tools -I ../../src -I ../../e3d  +debug_info -o../../plugins/import_export wpc_kerky.erl
erlc -Werror -pa ../../ebin -pa ../../intl_tools -I ../../intl_tools -I ../../src -I ../../e3d  +debug_info -o../../plugins/import_export wpc_lwo.erl
wpc_lwo.erl:16: can't find include lib "wings/e3d/e3d.hrl"
wpc_lwo.erl:64: record e3d_file undefined
wpc_lwo.erl:65: variable 'Mats' is unbound
Comment 19 Jeroen Roovers (RETIRED) gentoo-dev 2016-06-11 10:14:34 UTC
1.5.4 is in the tree. I've looked at 2.0.4 but I haven't added the ebuild yet.