Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 38312 - Limiting a possible KEYWORDS explosion as we add the *BSDs.
Summary: Limiting a possible KEYWORDS explosion as we add the *BSDs.
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-15 11:00 UTC by Grant Goodyear (RETIRED)
Modified: 2004-07-15 13:19 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grant Goodyear (RETIRED) gentoo-dev 2004-01-15 11:00:14 UTC
I've slowly been working on creating an x86 OpenBSD-based flavor of gentoo,
and my first step was to create an "x86obsd" keyword.  As drobbins has pointed
out, if we really get rolling on this project we could have an explosion of
arch*flavor*userland keywords, which would be _really_ ugly.  Drobbins has suggested a new "userland/arch" format for keywords, and Method has pointed out
that the even that may not be sufficient, as we should really have flags for
arch, libc, and userland (since it is possible to have a GNU userland running on
a system w/ a BSD kernel and either a BSD or a GNU libc).

I don't have a good solution at the moment, but I'm opening this bug so that
it doesn't get lost.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 jason wohlgemuth 2004-02-06 09:37:12 UTC
Lets not forget Solaris, that is what I'm working on right now, getting portage going under Solaris. After that I planned on trying my hand at Irix. I had this same idea that the arch and os should be separate variables.
Comment 2 Grant Goodyear (RETIRED) gentoo-dev 2004-07-15 13:19:48 UTC
Whoops, never got around to closing this bug.  See GLEP 22.