Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 382589 - app-portage/gentoolkit- revdep-rebuild --library '/usr/lib/' doesn#t work
Summary: app-portage/gentoolkit- revdep-rebuild --library '/usr/lib/libgmp....
Status: RESOLVED DUPLICATE of bug 357225
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage Tools Team
Depends on:
Reported: 2011-09-11 12:40 UTC by Toralf Förster
Modified: 2013-04-12 08:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2011-09-11 12:40:37 UTC
Hhm, while upgrading m< Gentoo after a week revdep-rebuild doesn't catch all candidates :
n22 ~ #  revdep-rebuild --library '/usr/lib/'
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries using /usr/lib/
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Checking dynamic linking 
[ 100% ]                 

 * There are no dynamic links to /usr/lib/ All done. 
n22 ~ # ldd /usr/lib/apache2/modules/ | grep gmp
ldd: warning: you do not have execution permission for `/usr/lib/apache2/modules/'                                                                          => not found
n22 ~ # equery b /usr/lib/apache2/modules/                                                                                                                  
 * Searching for /usr/lib/apache2/modules/ ...                                                                                                              
dev-lang/php-5.3.8 (/usr/lib/php5.3/apache2/                                                                                                               

Reproducible: Always

tfoerste@n22 ~ $ emerge --info  dev-lang/php
Portage (default/linux/x86/10.0/desktop/kde, gcc-4.4.5, glibc-2.12.2-r0, i686)
                        System Settings
System uname: Linux-
Timestamp of tree: Sat, 10 Sep 2011 19:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo betagarden toralf
CFLAGS="-O2 -march=native -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
FEATURES="assume-digests binpkg-logs ccache compress-build-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/betagarden /usr/local/portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdda cdr classic cli consolekit cracklib crypt css cups cxx dbus declarative dri dts dvb dvd dvdr emboss encode exif fam fastbuild fat ffmpeg firefox flac fortran gdbm gdu gif git gmp gphoto2 gpm gtk hyphenation iconv ipv6 java jpeg kde kipi kqemu kvm lastfm lcms ldap libnotify logrotate mad mbox mmx mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses nls nptl nptlonly nsplugin ntfs ogg opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pppd python qt3support qt4 rdesktop readline sdl semantic-desktop session sieve spell sse sse2 sse3 ssl ssse3 startup-notification svg sysfs tcpd thinkpad tiff tk truetype udev unicode usb vaapi vim-syntax vnc vorbis wmf x264 x86 xcb xcomposite xinerama xml xorg xpm xscreensaver xulrunner xv xvfb xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" LIRC_DEVICES="devinput inputlirc" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

dev-lang/php-5.3.8 was built with the following:
USE="apache2 berkdb bzip2 cli (consolekit) crypt ctype exif fileinfo filter gd gdbm gmp hash iconv ipv6 json ldap mysql mysqli nls phar (policykit) posix readline session simplexml spell ssl test tokenizer truetype unicode xml xpm xsl zlib -adabas -bcmath -birdstep -calendar -cdb -cgi -cjk -curl -curlwrappers -db2 -dbmaker -debug -doc -embed -empress -empress-bcs -enchant -esoob -firebird -flatfile -fpm -frontbase -ftp -gd-external -imap -inifile -interbase -intl -iodbc -kerberos -kolab -ldap-sasl -libedit -mhash -mssql -mysqlnd -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets -solid -sqlite -sqlite3 -suhosin -sybase-ct -sysvipc -threads -tidy -wddx -xmlreader -xmlrpc -xmlwriter -zip"
Comment 1 Rafał Mużyło 2011-09-11 13:45:45 UTC
...and would 'revdep-rebuild --library' have worked ?
Comment 2 Toralf Förster gentoo-dev 2011-09-11 13:52:00 UTC
(In reply to comment #1)
> ...and would 'revdep-rebuild --library' have worked ?
oh - yes (but I used --pretend just in case you need some additional tests)
Comment 3 Jack 2011-11-14 22:13:34 UTC
In my case, 'revdep rebuild --library /usr/lib64/libgmp.20.3' found several files to rebuild, but it did not find gcc (/usr/libexec/gcc/x86_64-pc-linux-gnu/4.5.3/cc1) so my next emerge after deleting that lib failed.  creating a symlink from to seemed to fix it, and really strangely, after deleting again, that cc1 is linked (per ldd) to
Comment 4 Toralf Förster gentoo-dev 2011-11-18 14:59:03 UTC
Hhm, at my user mdoe linux image I run into a similar issue, revdep-rebuild --library built 2 packages new (dev-libs/mpc-0.8.2 and net-misc/curl-7.21.4), but overlooked (might be due to the symlink ?):

n22 ~ # locate | xargs ls -l
lrwxrwxrwx 1 root root      34 Jan 11  2011 /usr/lib/apache2/modules/ -> /usr/lib/php5.3/apache2/
-rw-r--r-- 1 root root 8736320 Nov 18 15:51 /usr/lib/php5.3/apache2/

Therefore apache2 doesn't started with an error in /etc/apache2/modules.d/70_mod_php5.conf
Comment 5 Myckel Habets 2011-12-14 06:12:02 UTC
Got a b0rked build system here as well because of this.

Did the revdep-rebuild and deleted the lib as the libgmp ebuild suggested, but libtool wasn't rebuild. And libtool needs itself to rebuild.

Symlink from /usr/lib/ to the latest stable seems to be a work around this problem.
Comment 6 Myckel Habets 2011-12-14 06:43:22 UTC
(In reply to comment #5)
> Got a b0rked build system here as well because of this.
> Did the revdep-rebuild and deleted the lib as the libgmp ebuild suggested, but
> libtool wasn't rebuild. And libtool needs itself to rebuild.
> Symlink from /usr/lib/ to the latest stable seems to be a work
> around this problem.

Eh.. automake that is. Not libtool. And rebuilding keeps linking against
Comment 7 Samuli Suominen (RETIRED) gentoo-dev 2013-04-12 08:57:30 UTC

*** This bug has been marked as a duplicate of bug 357225 ***